aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-02-26 19:56:37 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-02-26 19:56:37 +0000
commit1d1b5dbe04500c277fe7402852202b0156b58299 (patch)
tree6b5f20267f815bb627f3cb4d0f5e6314fb56d7dd /www
parentf4c948a4e98a4b0ff4b5f8395228dc85fb38efee (diff)
This Trac plugin implements a page for creating time estimates. The
estimates will be attached to whatever tickets are specified in the tickets box. WWW: http://trac-hacks.org/wiki/EstimatorPlugin Feature safe: yes
Notes
Notes: svn path=/head/; revision=250376
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-estimator/Makefile29
-rw-r--r--www/trac-estimator/distinfo3
-rw-r--r--www/trac-estimator/pkg-descr5
-rw-r--r--www/trac-estimator/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 07d58e30e411..1a20e7bcee19 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1596,6 +1596,7 @@
SUBDIR += trac-datefield
SUBDIR += trac-down
SUBDIR += trac-email2trac
+ SUBDIR += trac-estimator
SUBDIR += trac-fivestarvote
SUBDIR += trac-fullblog
SUBDIR += trac-gantt
diff --git a/www/trac-estimator/Makefile b/www/trac-estimator/Makefile
new file mode 100644
index 000000000000..cc7db4a37f74
--- /dev/null
+++ b/www/trac-estimator/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: trac-estimator
+# Date created: February 26 2010
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= estimator
+PORTVERSION= 0.1.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Produce detailed range-based estimations for Trac tickets
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.11
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/.r/_r/} PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>
diff --git a/www/trac-estimator/distinfo b/www/trac-estimator/distinfo
new file mode 100644
index 000000000000..e5543d877778
--- /dev/null
+++ b/www/trac-estimator/distinfo
@@ -0,0 +1,3 @@
+MD5 (estimatorplugin-0.1.1.tar.gz) = 6ca198b332354ac2196ecc7783617296
+SHA256 (estimatorplugin-0.1.1.tar.gz) = bc6d16af2da264b91c1445d5fc8732f0fa77913a70f8c94e859ff2e402f14155
+SIZE (estimatorplugin-0.1.1.tar.gz) = 32631
diff --git a/www/trac-estimator/pkg-descr b/www/trac-estimator/pkg-descr
new file mode 100644
index 000000000000..3277a6f22ea1
--- /dev/null
+++ b/www/trac-estimator/pkg-descr
@@ -0,0 +1,5 @@
+This Trac plugin implements a page for creating time estimates. The
+estimates will be attached to whatever tickets are specified in the
+tickets box.
+
+WWW: http://trac-hacks.org/wiki/EstimatorPlugin
diff --git a/www/trac-estimator/pkg-plist b/www/trac-estimator/pkg-plist
new file mode 100644
index 000000000000..96ce700c0845
--- /dev/null
+++ b/www/trac-estimator/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/estimatorplugin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg