aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-03 22:15:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-03 22:15:57 +0000
commit41e397476e4859a04fcf59b0c27675bd1889c841 (patch)
tree631d0c9c8ba7223c7c86a600cbc1aa672fc91bcc /www
parentbc534130350a916638fc125618a4df8c2dd8cf79 (diff)
downloadports-41e397476e4859a04fcf59b0c27675bd1889c841.tar.gz
ports-41e397476e4859a04fcf59b0c27675bd1889c841.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/npm-node10/Makefile13
2 files changed, 14 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a6c356e7706c..e9ef4274f501 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -534,6 +534,7 @@
SUBDIR += npapi-xine
SUBDIR += npc
SUBDIR += npm
+ SUBDIR += npm-node10
SUBDIR += npm-node6
SUBDIR += npm-node8
SUBDIR += nspluginwrapper
diff --git a/www/npm-node10/Makefile b/www/npm-node10/Makefile
new file mode 100644
index 000000000000..a0501a66b6b9
--- /dev/null
+++ b/www/npm-node10/Makefile
@@ -0,0 +1,13 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -node10
+
+CONFLICTS_INSTALL= npm npm-node6 npm-node8
+
+OPTIONS_EXCLUDE=NODE NODE6 NODE8
+OPTIONS_SLAVE= NODE10
+
+MASTERDIR= ${.CURDIR}/../npm
+
+.include "${MASTERDIR}/Makefile"