aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-09-19 20:46:13 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-09-19 20:46:13 +0000
commit63ba86356fda945e0ff55325abdc4c5dc89651f3 (patch)
tree9417f685b30df3cb9a0599c5ba304985815bf531 /www
parent00789911dc825bb8e782673bedf5a3b0f225be7b (diff)
downloadports-63ba86356fda945e0ff55325abdc4c5dc89651f3.tar.gz
ports-63ba86356fda945e0ff55325abdc4c5dc89651f3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/squid/Makefile30
-rw-r--r--www/squid/files/pkg-message.in11
-rw-r--r--www/squid/pkg-plist2
3 files changed, 33 insertions, 10 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index fe415818fa3e..7546d80d753f 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -2,6 +2,7 @@
PORTNAME= squid
PORTVERSION= 3.4.8
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
@@ -45,16 +46,16 @@ SUB_FILES+= pkg-install pkg-message
OPTIONS_SUB= yes
OPTIONS_DEFINE= ARP_ACL AUTH_KERB AUTH_LDAP AUTH_NIS AUTH_SASL AUTH_SMB \
- AUTH_SQL \
- CACHE_DIGESTS DEBUG DELAY_POOLS DNS_HELPER ECAP ESI \
- FOLLOW_XFF FS_AUFS HTCP ICAP ICMP IDENT IPV6 KQUEUE \
+ AUTH_SQL CACHE_DIGESTS DEBUG DELAY_POOLS DNS_HELPER ECAP ESI \
+ FOLLOW_XFF FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT IPV6 KQUEUE \
LARGEFILE SNMP SSL SSL_CRTD STACKTRACES LAX_HTTP \
TP_IPF TP_IPFW TP_PF VIA_DB WCCP WCCPV2 DOCS EXAMPLES
-# Note: FS_FCOSS was removed from OPTIONS, it is broken and only experimentel
+# Note: FS_FCOSS was removed from OPTIONS, it is broken and only experimental
#OPTIONS_DEFINE+= FS_COSS
-OPTIONS_DEFAULT=AUTH_KERB AUTH_NIS FS_AUFS HTCP IDENT KQUEUE SNMP WCCP WCCPV2
+OPTIONS_DEFAULT=AUTH_KERB AUTH_NIS FS_AUFS FS_DISKD HTCP IDENT KQUEUE SNMP \
+ WCCP WCCPV2
ARP_ACL_CONFIGURE_ENABLE= eui
AUTH_LDAP_CFLAGS= -I${LOCALBASE}/include
@@ -97,6 +98,7 @@ STACKTRACES_CONFIGURE_ENABLE= stacktraces
TP_IPFW_CONFIGURE_ENABLE= ipfw-transparent
TP_IPF_CONFIGURE_ENABLE= ipf-transparent
TP_PF_CONFIGURE_ENABLE= pf-transparent
+TP_PF_CONFIGURE_WITH= nat-devpf
VIA_DB_CONFIGURE_ENABLE= forw-via-db
WCCPV2_CONFIGURE_ENABLE= wccpv2
WCCP_CONFIGURE_ENABLE= wccp
@@ -118,8 +120,10 @@ DNS_HELPER_DESC= Use external dnsserver processes for DNS
ECAP_DESC= Loadable content adaptation modules
ESI_DESC= ESI support
FOLLOW_XFF_DESC= Support for the X-Following-For header
-FS_AUFS_DESC= AUFS (async-io) support
+FS_AUFS_DESC= AUFS (threaded-io) support
FS_COSS_DESC= COSS (not stable yet)
+FS_DISKD_DESC= DISKD storage engine controlled by separate service
+FS_ROCK_DESC= ROCK (unstable)
HTCP_DESC= HTCP support
ICAP_DESC= the ICAP client
ICMP_DESC= ICMP pinging and network measurement
@@ -236,8 +240,8 @@ CONFIGURE_ARGS+= --enable-auth-basic="${basic_auth}" \
--enable-auth-ntlm="${ntlm_auth}"
# Storage schemes:
-storage_schemes= diskd rock ufs
-diskio_modules= AIO Blocking DiskDaemon IpcIo Mmapped
+storage_schemes= ufs
+diskio_modules= AIO Blocking IpcIo Mmapped
.if ${PORT_OPTIONS:MFS_AUFS}
storage_schemes+= aufs
@@ -254,6 +258,16 @@ BROKEN= FS_COSS does not compile
storage_schemes+= coss
.endif
+.if ${PORT_OPTIONS:MFS_DISKD}
+storage_schemes+= diskd
+diskio_modules+= DiskDaemon
+.endif
+
+.if ${PORT_OPTIONS:MFS_ROCK}
+storage_schemes+= rock
+.endif
+
+
CONFIGURE_ARGS+= --enable-storeio="${storage_schemes}" \
--enable-disk-io="${diskio_modules}"
diff --git a/www/squid/files/pkg-message.in b/www/squid/files/pkg-message.in
index aab1e73c235d..47cd8f66bf4f 100644
--- a/www/squid/files/pkg-message.in
+++ b/www/squid/files/pkg-message.in
@@ -10,6 +10,15 @@
If your cache directories are already initialized (e.g. after an
upgrade of squid) you do not need to initialize them again.
+ 0 When using DiskD storage scheme remember to read documentation:
+ http://wiki.squid-cache.org/Features/DiskDaemon
+ and alter your kern.ipc defaults in /boot/loader.conf. DiskD will not
+ work reliably without this. Last recomendations were:
+
+ kern.ipc.msgmnb=8192
+ kern.ipc.msgssz=64
+ kern.ipc.msgtql=2048
+
o The default configuration will deny everyone but the local host and
local networks as defined in RFC 1918 for IPv4 and RFCs 4193 and
4291 for IPv6 access to the proxy service. Edit the "http_access
@@ -22,7 +31,7 @@
Note:
If you just updated your Squid installation from an earlier version,
- make sure to check your Squid configuration against the 3.3 default
+ make sure to check your Squid configuration against the 3.4 default
configuration file %%PREFIX%%/etc/squid/squid.conf.sample.
%%PREFIX%%/etc/squid/squid.conf.documented is a fully annotated
diff --git a/www/squid/pkg-plist b/www/squid/pkg-plist
index 92c4113a7fc5..6583e35b0a76 100644
--- a/www/squid/pkg-plist
+++ b/www/squid/pkg-plist
@@ -2070,7 +2070,7 @@ libexec/squid/cachemgr.cgi
%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%libexec/squid/cert_tool
%%SSL%%libexec/squid/cert_valid.pl
libexec/squid/digest_file_auth
-libexec/squid/diskd
+%%FS_DISKD%%libexec/squid/diskd
%%DNS_HELPER%%libexec/squid/dnsserver
libexec/squid/ext_file_userip_acl
%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%libexec/squid/ext_kerberos_ldap_group_acl