aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2008-12-09 23:44:15 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2008-12-09 23:44:15 +0000
commit70488963ea0e5de1a7168500b712ef6b1c57bc23 (patch)
treefaf4b192b3bcb6850fb84da3699c04bca6fce3a9 /www
parent5d0e94ff76488d083e4f2797f16bee704db654dc (diff)
downloadports-70488963ea0e5de1a7168500b712ef6b1c57bc23.tar.gz
ports-70488963ea0e5de1a7168500b712ef6b1c57bc23.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-tweakui/Makefile42
-rw-r--r--www/trac-tweakui/distinfo3
-rw-r--r--www/trac-tweakui/files/patch-setup.py18
-rw-r--r--www/trac-tweakui/files/pkg-message.in24
-rw-r--r--www/trac-tweakui/pkg-descr9
-rw-r--r--www/trac-tweakui/pkg-plist42
7 files changed, 139 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 71fbd7735694..d887e04afa15 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1411,6 +1411,7 @@
SUBDIR += trac-tags
SUBDIR += trac-ticketdelete
SUBDIR += trac-tocmacro
+ SUBDIR += trac-tweakui
SUBDIR += trac-wantedpages
SUBDIR += trac-webadmin
SUBDIR += trac-wikinegotiator
diff --git a/www/trac-tweakui/Makefile b/www/trac-tweakui/Makefile
new file mode 100644
index 000000000000..4c2f9252cd03
--- /dev/null
+++ b/www/trac-tweakui/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: trac-tweakui
+# Date created: Dec 09 2008
+# Whom: glarkin
+#
+# $FreeBSD$
+#
+
+PORTNAME= tweakui
+PORTVERSION= 0.1.4465
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Easily tweak Trac pages with Javascript expressions
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+SUB_FILES= pkg-message
+
+WRKSRC= ${WRKDIR}/trac${PORTNAME}plugin/0.11
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracTweakUI
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:R}
+PLIST_SUB+= EGGVERSION="${PORTVERSION:R}" PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @cd ${WRKSRC}/tractweakui/htdocs && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-tweakui/distinfo b/www/trac-tweakui/distinfo
new file mode 100644
index 000000000000..e9508861a9a7
--- /dev/null
+++ b/www/trac-tweakui/distinfo
@@ -0,0 +1,3 @@
+MD5 (tweakuiplugin-0.1.4465.zip) = 6447996c5757cca5d03d7c713c3a5ae0
+SHA256 (tweakuiplugin-0.1.4465.zip) = 8f0eece11e27977a7fad78b58739e959dee737339bd56c28105f201359e29d1e
+SIZE (tweakuiplugin-0.1.4465.zip) = 77684
diff --git a/www/trac-tweakui/files/patch-setup.py b/www/trac-tweakui/files/patch-setup.py
new file mode 100644
index 000000000000..0c08bd8819d6
--- /dev/null
+++ b/www/trac-tweakui/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- ./setup.py.orig 2008-12-09 11:20:48.000000000 -0500
++++ ./setup.py 2008-12-09 11:17:27.000000000 -0500
+@@ -4,6 +4,8 @@
+ name = 'TracTweakUI',
+ version = '0.1',
+ packages = ['tractweakui'],
++ package_dir = {'tractweakui': 'tractweakui'},
++ package_data = {'tractweakui': ['templates/*.html']},
+ include_package_data = True,
+ author = "Richard Liao",
+ author_email = 'richard.liao.i@gmail.com',
+@@ -18,4 +20,4 @@
+ ],
+ install_requires = [],
+ entry_points = {'trac.plugins': ['tractweakui = tractweakui.web_ui']},
+-)
+\ No newline at end of file
++)
diff --git a/www/trac-tweakui/files/pkg-message.in b/www/trac-tweakui/files/pkg-message.in
new file mode 100644
index 000000000000..e40bfcccd175
--- /dev/null
+++ b/www/trac-tweakui/files/pkg-message.in
@@ -0,0 +1,24 @@
+**************************************************
+To complete the installation, please add:
+
+[components]
+tractweakui.* = enabled
+
+to your trac.ini to enable the plugin.
+
+Next, visit:
+http://trac-hacks.org/wiki/TracTweakUiPlugin#Example
+for usage examples.
+
+If you have installed the examples into
+%%EXAMPLESDIR%%,
+you can incorporate them into your Trac project
+with the following command:
+
+cp -Rp %%EXAMPLESDIR%%/* \
+ $TRAC_ENV/htdocs
+
+$TRAC_ENV is the root directory of your Trac
+project. You can copy the TweakUi examples into
+as many Trac projects as you like.
+**************************************************
diff --git a/www/trac-tweakui/pkg-descr b/www/trac-tweakui/pkg-descr
new file mode 100644
index 000000000000..6dea99cbfc2b
--- /dev/null
+++ b/www/trac-tweakui/pkg-descr
@@ -0,0 +1,9 @@
+This plugin implements a Javascript deployment platform, enabling
+Trac administrators to easily tweak Trac pages with Javascript
+expressions.
+
+The plugin supports the Trac web admin system, and it can apply
+Javascript tweaks to multiple pages by matching their names with
+regular expressions.
+
+WWW: http://trac-hacks.org/wiki/TracTweakUiPlugin
diff --git a/www/trac-tweakui/pkg-plist b/www/trac-tweakui/pkg-plist
new file mode 100644
index 000000000000..a3c0a9e1d12d
--- /dev/null
+++ b/www/trac-tweakui/pkg-plist
@@ -0,0 +1,42 @@
+%%PYTHON_SITELIBDIR%%/TracTweakUI-%%EGGVERSION%%-py%%PYTHONVERSION%%.egg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trac.ico
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/jquery.dimensions.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/wait.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/jquery.cluetip.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/jquery.cluetip.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/cluetip/jquery.hoverIntent.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/fieldnotice/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/fieldnotice/jquery.fieldnotice.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editfullscreen/jquery.autogrow.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editfullscreen/jquery.editfullscreen.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editfullscreen/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/form-defaults/jquery.form-defaults.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/form-defaults/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/validate/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/validate/jquery.validate.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/unitfeeder/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/unitfeeder/jquery.unitfeeder.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/datePicker.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/jquery.datePicker.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/date.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/datePicker_icon.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/datepicker/calendar.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editcc/jquery.editcc.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editcc/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editcc/jquery.editcc.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/editcc/del.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/makelink/__template__.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tractweakui/makelink/jquery.makelink.js
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/cluetip
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/fieldnotice
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/editfullscreen
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/form-defaults
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/validate
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/unitfeeder
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/datepicker
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/editcc
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui/makelink
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tractweakui
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%