aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-14 20:12:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-14 20:12:18 +0000
commitb3d80d62b7c1e29e1770134aafae10a6ef672d57 (patch)
treeca2eb5e7ea8c9f67acd829d9a9456cfcafa1915a /www
parent76d6d3a80afb399a61bb3cfb9cf1c1a10ab37360 (diff)
downloadports-b3d80d62b7c1e29e1770134aafae10a6ef672d57.tar.gz
ports-b3d80d62b7c1e29e1770134aafae10a6ef672d57.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-RTx-Calendar/Makefile38
-rw-r--r--www/p5-RTx-Calendar/distinfo3
-rw-r--r--www/p5-RTx-Calendar/pkg-descr14
-rw-r--r--www/p5-RTx-Calendar/pkg-message9
-rw-r--r--www/p5-RTx-Calendar/pkg-plist40
6 files changed, 105 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index afb5a3dd5b5e..5f6179653afa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -956,6 +956,7 @@
SUBDIR += p5-RT-Client-REST
SUBDIR += p5-RT-Extension-LDAPImport
SUBDIR += p5-RT-Extension-SLA
+ SUBDIR += p5-RTx-Calendar
SUBDIR += p5-RTx-Statistics
SUBDIR += p5-Reaction
SUBDIR += p5-SCGI
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
new file mode 100644
index 000000000000..04b8db354e28
--- /dev/null
+++ b/www/p5-RTx-Calendar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection Makefile for: RTx-Calendar
+# Date created: 16 August 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RTx-Calendar
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= Calendar extension module for the RT ticketing system
+
+BUILD_DEPENDS= ${LOCALBASE}/${RTHOME}/bin/rt:${PORTSDIR}/www/rt36 \
+ ${SITE_PERL}/Date/ICal.pm:${PORTSDIR}/devel/p5-Date-ICal \
+ ${SITE_PERL}/Data/ICal.pm:${PORTSDIR}/deskutils/p5-Data-ICal \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RTHOME?= rt3
+PLIST_SUB+= RTHOME=${RTHOME}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
+
+MAN3PREFIX= ${PREFIX}/${RTHOME}/local
+MAN3= RTx::Calendar.3
+
+# Don't use normal CONFIGURE_ARGS
+do-configure:
+ @cd ${CONFIGURE_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} \
+ ${PERL5} ./${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/www/p5-RTx-Calendar/distinfo b/www/p5-RTx-Calendar/distinfo
new file mode 100644
index 000000000000..64135f407d25
--- /dev/null
+++ b/www/p5-RTx-Calendar/distinfo
@@ -0,0 +1,3 @@
+MD5 (RTx-Calendar-0.05.tar.gz) = 53a305c3a5929d77276f98c255186591
+SHA256 (RTx-Calendar-0.05.tar.gz) = f9311929943f35bd631df442da3e428e8524b8236c449d0ccd9266e3aa0d9721
+SIZE (RTx-Calendar-0.05.tar.gz) = 27640
diff --git a/www/p5-RTx-Calendar/pkg-descr b/www/p5-RTx-Calendar/pkg-descr
new file mode 100644
index 000000000000..68c910cdf13a
--- /dev/null
+++ b/www/p5-RTx-Calendar/pkg-descr
@@ -0,0 +1,14 @@
+This RT extension provides a calendar view for your tickets and your
+reminders so you see when is your next due ticket. You can find it in
+the menu Search->Calendar.
+
+There's a portlet to put on your home page (see Prefs/MyRT.html)
+
+You can also enable ics (ICal) feeds for your default calendar and all
+your private searches in Prefs/Calendar.html. Authentication is magic
+number based so that you can give those feeds to other people.
+
+You can find screenshots on
+http://gaspard.mine.nu/dotclear/index.php?tag/rtx-calendar
+
+WWW: http://search.cpan.org/dist/RTx-Calendar/
diff --git a/www/p5-RTx-Calendar/pkg-message b/www/p5-RTx-Calendar/pkg-message
new file mode 100644
index 000000000000..4a4f8d012e67
--- /dev/null
+++ b/www/p5-RTx-Calendar/pkg-message
@@ -0,0 +1,9 @@
+
+ To use MyCalendar portlet you must add MyCalendar to $HomepageComponents
+ in etc/RT_SiteConfig.pm like that :
+
+ Set($HomepageComponents, [qw(QuickCreate Quicksearch MyCalendar
+ MyAdminQueues MySupportQueues MyReminders RefreshHomepage)]);
+
+ To enable private searches ICal feeds, you need to give
+ CreateSavedSearch and LoadSavedSearch rights to your users.
diff --git a/www/p5-RTx-Calendar/pkg-plist b/www/p5-RTx-Calendar/pkg-plist
new file mode 100644
index 000000000000..e642f30edaa7
--- /dev/null
+++ b/www/p5-RTx-Calendar/pkg-plist
@@ -0,0 +1,40 @@
+%%RTHOME%%/share/html/Search/Calendar.html
+%%RTHOME%%/share/html/Prefs/Elements/CalendarFeed
+%%RTHOME%%/share/html/Prefs/Calendar.html
+%%RTHOME%%/share/html/NoAuth/images/updated.png
+%%RTHOME%%/share/html/NoAuth/images/starts_due.png
+%%RTHOME%%/share/html/NoAuth/images/starts.png
+%%RTHOME%%/share/html/NoAuth/images/started.png
+%%RTHOME%%/share/html/NoAuth/images/resolved.png
+%%RTHOME%%/share/html/NoAuth/images/reminder.png
+%%RTHOME%%/share/html/NoAuth/images/due.png
+%%RTHOME%%/share/html/NoAuth/images/created_due.png
+%%RTHOME%%/share/html/NoAuth/images/created.png
+%%RTHOME%%/share/html/NoAuth/css/calendar.css
+%%RTHOME%%/share/html/NoAuth/Calendar/dhandler
+%%RTHOME%%/share/html/Elements/MyCalendar
+%%RTHOME%%/share/html/Elements/CalendarEvent
+%%RTHOME%%/share/html/Callbacks/RTx-Calendar/User/Elements/Tabs/Default
+%%RTHOME%%/share/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs/Default
+%%RTHOME%%/share/html/Callbacks/RTx-Calendar/Elements/Header/Head
+%%RTHOME%%/local/man/auto/RTx/Calendar/.packlist
+%%RTHOME%%/local/lib/RTx/Calendar.pm
+@dirrm %%RTHOME%%/share/html/NoAuth/Calendar
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/User/Elements/Tabs
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/User/Elements
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/User
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/Ticket/Elements
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/Ticket
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/Elements/Header
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar/Elements
+@dirrm %%RTHOME%%/share/html/Callbacks/RTx-Calendar
+@dirrmtry %%RTHOME%%/share/html/Callbacks
+@dirrm %%RTHOME%%/local/man/auto/RTx/Calendar
+@dirrmtry %%RTHOME%%/local/man/auto/RTx
+@dirrmtry %%RTHOME%%/local/man/auto
+@dirrmtry %%RTHOME%%/local/man/man3
+@dirrmtry %%RTHOME%%/local/man
+@dirrmtry %%RTHOME%%/local/lib/RTx
+@dirrmtry %%RTHOME%%/local/lib
+@dirrmtry %%RTHOME%%/local