aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-11-08 06:44:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-11-08 06:44:31 +0000
commitf23b9daea9d920356f727fdedb291c58726276df (patch)
tree86624afdedc1e6fde13d9bae8e5aa05985c7ec11 /www
parent0e73f57ef048a18709704b2da78e8c43d074472a (diff)
downloadports-f23b9daea9d920356f727fdedb291c58726276df.tar.gz
ports-f23b9daea9d920356f727fdedb291c58726276df.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/beonex/Makefile145
-rw-r--r--www/beonex/distinfo1
-rw-r--r--www/beonex/files/patch-Makefile.in16
-rw-r--r--www/beonex/files/patch-basebrowser-unix28
-rw-r--r--www/beonex/files/patch-ptio.c26
-rw-r--r--www/beonex/files/patch-rules.mk16
-rw-r--r--www/beonex/files/patch-unix.js18
-rw-r--r--www/beonex/files/patch-xptc_platforms_unixish_x86.h27
-rw-r--r--www/beonex/files/patch-xptcinvoke_linux_alpha.cpp53
-rw-r--r--www/beonex/files/patch-xptcstubs_linux_alpha.cpp110
-rw-r--r--www/beonex/pkg-descr9
-rw-r--r--www/beonex/pkg-message4
13 files changed, 0 insertions, 454 deletions
diff --git a/www/Makefile b/www/Makefile
index e5d5d48d4370..c1dbcda5d79f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -28,7 +28,6 @@
SUBDIR += auth_ldap
SUBDIR += awstats
SUBDIR += axis
- SUBDIR += beonex
SUBDIR += bins
SUBDIR += bk2site
SUBDIR += bkmrkconv
diff --git a/www/beonex/Makefile b/www/beonex/Makefile
deleted file mode 100644
index 19e2a756c07f..000000000000
--- a/www/beonex/Makefile
+++ /dev/null
@@ -1,145 +0,0 @@
-# New ports collection makefile for: beonex
-# Date created: 2002-09-26
-# Whom: trevor
-# based on ports/www/mozilla
-#
-# $FreeBSD$
-#
-
-PORTNAME= beonex
-PORTVERSION= 0.8.1
-CATEGORIES= www
-MASTER_SITES= http://ftp.ibiblio.org/pub/packages/infosystems/WWW/clients/beonex/communicator/0.8/ \
- ftp://ftp.ibiblio.org/pub/packages/infosystems/WWW/clients/beonex/communicator/0.8/
-DISTNAME= beonex-comm-${PORTVERSION}-stable-1-source-tarball
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Open-source browser, HTML editor, mail and news client
-FORBIDDEN= "warning from author about security problems"
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
-
-WRKSRC= ${WRKDIR}/mozilla
-
-WITHOUT_CHATZILLA="see <URL:http://online.securityfocus.com/archive/1/270249>"
-
-USE_BZIP2= yes
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* --exclude */macbuild/*\
- --exclude */package/*
-
-USE_X_PREFIX= yes
-USE_PERL5= yes
-USE_GMAKE= yes
-USE_GNOME= orbit gtk12
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= \
- --disable-auto-deps \
- --enable-chrome-format=jar \
- --disable-cpp-exceptions \
- --disable-cpp-rtti \
- --enable-crypto \
- --disable-debug \
- --enable-default-toolkit=gtk \
- --enable-double-buffer \
- --disable-dtd-debug \
- --disable-jsd \
- --enable-mathml \
- --disable-md \
- --disable-optimize \
- --disable-pedantic \
- --disable-plaintext-editor-only \
- --enable-strip \
- --enable-strip-libs \
- --disable-tests \
- --disable-xterm-updates \
- --enable-xinerama \
- --with-system-jpeg=${LOCALBASE} \
- --with-system-mng=${LOCALBASE} \
- --with-system-png=${LOCALBASE}
-# disabled due to compilation errors
-# --with-pthreads
-# --enable-svg
-
-# compiles but segfaults on 5.0-RC3/alpha
-ONLY_FOR_ARCHS= i386
-PLIST= ${WRKDIR}/pkg-plist
-# LDAP is only used by mail and news so disable both together
-.if defined(WITHOUT_MAILNEWS)
-CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
-.else
-# mail and news desired, but not LDAP
-.if defined(WITHOUT_LDAP)
-CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
-.else
-CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
-.endif
-.endif
-
-.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=cookie,wallet,content-packs,pref,transformiix,irc,spellcheck,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=cookie,wallet,content-packs,pref,transformiix,spellcheck,xmlterm
-.endif
-CONFIGURE_ENV= BUILD_OFFICIAL=1 MOZILLA_OFFICIAL=1 MOZ_INTERNAL_LIBART_LGPL=1 \
- ${CC}=${CXX}
-
-.include <bsd.port.pre.mk>
-
-MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
- MOZ_INTERNAL_LIBART_LGPL=1
-ALL_TARGET= default
-
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --enable-reorder
-.endif
-
-.if exists(${LOCALBASE}/include/freetype/freetype.h)
-BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Beonex. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Beonex"
-.endif
-
-pre-everything::
- @ ${CAT} ${PKGMESSAGE}
-
-post-build:
-.if defined(WITHOUT_CHATZILLA)
- ${RM} -f ${WRKSRC}/dist/bin/chrome/chatzilla.jar \
- ${WRKSRC}/extensions/irc/js/lib/chatzilla-service.js
-.endif
- (cd ${WRKSRC}/dist/bin && \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
- ${ECHO_CMD} skin,install,select,modern/1.0 >> \
- chrome/installed-chrome.txt; \
- ${ECHO_CMD} locale,install,select,en-US >> \
- chrome/installed-chrome.txt; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
-
-pre-install:
- ${ECHO_CMD} bin/beonex > ${PLIST}
-.for ii in component.reg components/xpti.dat
- ${ECHO_CMD} '@unexec rm -f %D/lib/beonex/${ii} || true' >> ${PLIST}
-.endfor
- cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
- ${SED} -e 's:^:lib/beonex/:' >> ${PLIST} \
- && ${FIND} -d * -type d | \
- ${SED} -e 's:^:@dirrm lib/beonex/:' >> ${PLIST}
- ${ECHO_CMD} @dirrm lib/beonex >> ${PLIST}
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/beonex
- ${CHMOD} 755 ${PREFIX}/lib/beonex
- cd ${WRKSRC}/dist/bin && ${FIND} * | \
- cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/beonex
- ${ECHO_CMD} "#!/bin/sh" > ${WRKDIR}/beonex
- ${ECHO_CMD} 'cd ${PREFIX}/lib/beonex && exec ./mozilla "$$@"' >> \
- ${WRKDIR}/beonex
- ${INSTALL_SCRIPT} ${WRKDIR}/beonex ${PREFIX}/bin/
- ${LN} -sf \
- ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so\
- ${PREFIX}/lib/beonex/plugins/libjavaplugin_oji.so
-
-.include <bsd.port.post.mk>
diff --git a/www/beonex/distinfo b/www/beonex/distinfo
deleted file mode 100644
index eac6e5fd38a6..000000000000
--- a/www/beonex/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (beonex-comm-0.8.1-stable-1-source-tarball.tar.bz2) = 71ba6b57b063a02c5bd917c358b3ba61
diff --git a/www/beonex/files/patch-Makefile.in b/www/beonex/files/patch-Makefile.in
deleted file mode 100644
index 7ea938ef0260..000000000000
--- a/www/beonex/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
-$FreeBSD$
-
-Avoid compilation error.
-
-author: Trevor Johnson
-
---- Makefile.in.orig Fri May 24 23:46:25 2002
-+++ Makefile.in Thu Sep 26 23:45:58 2002
-@@ -169,7 +169,6 @@
- endif
-
- ifdef MOZ_INTERNAL_LIBART_LGPL
--tier_9_dirs += other-licenses/libart_lgpl
- endif
-
- tier_9_dirs += \
diff --git a/www/beonex/files/patch-basebrowser-unix b/www/beonex/files/patch-basebrowser-unix
deleted file mode 100644
index b0ae51e2fc7e..000000000000
--- a/www/beonex/files/patch-basebrowser-unix
+++ /dev/null
@@ -1,28 +0,0 @@
-$FreeBSD$
-
-"Install files necessary for viewing pages in Asian languages using
-ports based on mozilla-embedded (galeon, skipstone etc.)"
-
-author: Takashi KANAMARU <kanamaru@sekine-lab.ei.tuat.ac.jp>
-
---- embedding/config/basebrowser-unix.orig Thu Feb 7 23:50:19 2002
-+++ embedding/config/basebrowser-unix Tue Mar 12 17:06:08 2002
-@@ -203,12 +204,12 @@
- components/unicharutil.xpt
- components/libchardet.so
- ; optional - on english only systems
--; components/libucvja.so for japanese
--; components/libucvko.so for korean
--; components/libucvcn.so for simplified chinese
--; components/libucvtw.so for traditional chinese
--; components/libucvtw2.so for traditional chinese
--; components/libucvibm.so for ibm
-+components/libucvja.so
-+components/libucvko.so
-+components/libucvcn.so
-+components/libucvtw.so
-+components/libucvtw2.so
-+components/libucvibm.so
-
-
- res/language.properties
diff --git a/www/beonex/files/patch-ptio.c b/www/beonex/files/patch-ptio.c
deleted file mode 100644
index 243fa27d1b36..000000000000
--- a/www/beonex/files/patch-ptio.c
+++ /dev/null
@@ -1,26 +0,0 @@
-Don't use mapped IPv6 address when connecting [in] IPv4 node.
-
-author: Hajimu UMEMOTO (FreeBSD.org login "ume")
-
-Index: nsprpub/pr/src/pthreads/ptio.c
-diff -u nsprpub/pr/src/pthreads/ptio.c.orig nsprpub/pr/src/pthreads/ptio.c
---- nsprpub/pr/src/pthreads/ptio.c.orig Fri Apr 12 03:14:39 2002
-+++ nsprpub/pr/src/pthreads/ptio.c Tue Jul 30 18:52:11 2002
-@@ -3414,6 +3414,17 @@
- if (osfd == -1) pt_MapError(_PR_MD_MAP_SOCKET_ERROR, errno);
- else
- {
-+#if (defined(_PR_INET6_PROBE) || defined(_PR_INET6)) && \
-+ defined(__FreeBSD__) && defined(IPV6_V6ONLY)
-+ if (domain == PR_AF_INET6) {
-+ int opt = 0;
-+ if (setsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
-+ &opt, sizeof(opt))) {
-+ close(osfd);
-+ return NULL;
-+ }
-+ }
-+#endif
- fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
- if (fd == NULL) close(osfd);
- }
diff --git a/www/beonex/files/patch-rules.mk b/www/beonex/files/patch-rules.mk
deleted file mode 100644
index 828b3ac3e3f1..000000000000
--- a/www/beonex/files/patch-rules.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-$FreeBSD$
-
-Enable compilation under -CURRENT.
-
-author: Trevor Johnson
-
---- config/rules.mk.orig Thu Aug 29 00:00:31 2002
-+++ config/rules.mk Wed Oct 2 01:15:29 2002
-@@ -68,7 +68,6 @@
- topsrcdir = $(DEPTH)
- endif
-
--CXX=gcc
- LDFLAGS += -Wl,-Bstatic -Wl,-lstdc++ -Wl,-Bdynamic
-
-
diff --git a/www/beonex/files/patch-unix.js b/www/beonex/files/patch-unix.js
deleted file mode 100644
index 3714c39003a2..000000000000
--- a/www/beonex/files/patch-unix.js
+++ /dev/null
@@ -1,18 +0,0 @@
-$FreeBSD$
-
-"correct name of the freetype library, so that it is easier to get AA fonts
-working."
-
-author: Maxim Sobolev
-
---- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
-+++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
-@@ -227,7 +227,7 @@
-
- // TrueType
- pref("font.FreeType2.enable", false);
--pref("font.freetype2.shared-library", "libfreetype.so.6");
-+pref("font.freetype2.shared-library", "libfreetype.so.9");
- // if libfreetype was built without hinting compiled in
- // it is best to leave hinting off
- pref("font.FreeType2.autohinted", false);
diff --git a/www/beonex/files/patch-xptc_platforms_unixish_x86.h b/www/beonex/files/patch-xptc_platforms_unixish_x86.h
deleted file mode 100644
index 0a90befc070d..000000000000
--- a/www/beonex/files/patch-xptc_platforms_unixish_x86.h
+++ /dev/null
@@ -1,27 +0,0 @@
-$FreeBSD$
-
-"Fix build on -CURRENT"
-
-author: Peter Kostouros <kpeter@melbpc.org.au>
-
---- xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h.orig Fri Jun 21 01:12:40 2002
-+++ xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h Fri Jun 21 01:41:51 2002
-@@ -94,8 +94,16 @@
- * gcc is that the system gcc defines __FreeBSD_cc_version. This variable
- * can also identify the period of time that 4.0-CURRENT used thunks.
- */
--#if defined(__FreeBSD_cc_version) && \
-- (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003)
-+
-+/* It seems we need to use thunks in FreeBSD -CURRENT after gcc-3.1 was merged.
-+ * This solves a problem wherein regxpcom and/or regchrome would seg fault
-+ * after running for a while. This problem has also exhibited itself on
-+ * the alpha platform. Therefore, use thunks on all versions of
-+ * -CURRENT that are using gcc-3.1.
-+ */
-+#if defined(__FreeBSD_cc_version) && \
-+ (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003) && \
-+ (__FreeBSD_cc_version < 500003)
- #define CFRONT_STYLE_THIS_ADJUST
- #else
- #define THUNK_BASED_THIS_ADJUST
diff --git a/www/beonex/files/patch-xptcinvoke_linux_alpha.cpp b/www/beonex/files/patch-xptcinvoke_linux_alpha.cpp
deleted file mode 100644
index 8ea665ba7119..000000000000
--- a/www/beonex/files/patch-xptcinvoke_linux_alpha.cpp
+++ /dev/null
@@ -1,53 +0,0 @@
-# http://bugzilla.mozilla.org/attachment.cgi?id=84336&action=view
-# http://bugzilla.mozilla.org/show_bug.cgi?id=86446
-# patch by Glen Nakamura <glen@imodulo.com> to enable compilation with gcc 3.1 on Alpha
-
-Index: xptcinvoke_linux_alpha.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp,v
-retrieving revision 1.3.38.1
-diff -c -3 -p -r1.3.38.1 xptcinvoke_linux_alpha.cpp
-*** xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 10 Apr 2002 03:37:38 -0000 1.3.38.1
---- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 20 May 2002 22:37:04 -0000
-***************
-*** 20,25 ****
---- 20,26 ----
- * the Initial Developer. All Rights Reserved.
- *
- * Contributor(s):
-+ * Glen Nakamura <glen@imodulo.com>
- *
- * Alternatively, the contents of this file may be used under the terms of
- * either the GNU General Public License Version 2 or later (the "GPL"), or
-***************
-*** 37,44 ****
-
- /* Platform specific code to invoke XPCOM methods on native objects */
-
-- /* contributed by Glen Nakamura <glen.nakamura@usa.net> */
--
- #include "xptcprivate.h"
-
- /* Prototype specifies unmangled function name and disables unused warning */
---- 38,43 ----
-*************** __asm__(
-*** 163,169 ****
---- 162,172 ----
- "bis $16,$16,$1\n\t" /* load "this" */
- "ldq $2,16($15)\n\t" /* load "methodIndex" */
- "ldq $1,0($1)\n\t" /* load vtable */
-+ #if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
-+ "s8addq $2,$31,$2\n\t" /* vtable index = "methodIndex" * 8 */
-+ #else /* not G++ V3 ABI */
- "s8addq $2,16,$2\n\t" /* vtable index = "methodIndex" * 8 + 16 */
-+ #endif /* G++ V3 ABI */
- "addq $1,$2,$1\n\t"
- "ldq $27,0($1)\n\t" /* load address of function */
- "jsr $26,($27),0\n\t" /* call virtual function */
-*************** __asm__(
-*** 176,179 ****
- "ret $31,($26),1\n\t"
- ".end XPTC_InvokeByIndex"
- );
--
---- 179,181 ----
diff --git a/www/beonex/files/patch-xptcstubs_linux_alpha.cpp b/www/beonex/files/patch-xptcstubs_linux_alpha.cpp
deleted file mode 100644
index 64d305c81039..000000000000
--- a/www/beonex/files/patch-xptcstubs_linux_alpha.cpp
+++ /dev/null
@@ -1,110 +0,0 @@
-# http://bugzilla.mozilla.org/attachment.cgi?id=84336&action=view
-# http://bugzilla.mozilla.org/show_bug.cgi?id=86446
-# patch by Glen Nakamura <glen@imodulo.com> to enable compilation with gcc 3.1 on Alpha
-
-Index: xptcstubs_linux_alpha.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp,v
-retrieving revision 1.3.38.1
-diff -c -3 -p -r1.3.38.1 xptcstubs_linux_alpha.cpp
-*** xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 10 Apr 2002 03:37:42 -0000 1.3.38.1
---- xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 20 May 2002 22:37:04 -0000
-***************
-*** 20,25 ****
---- 20,26 ----
- * the Initial Developer. All Rights Reserved.
- *
- * Contributor(s):
-+ * Glen Nakamura <glen@imodulo.com>
- *
- * Alternatively, the contents of this file may be used under the terms of
- * either the GNU General Public License Version 2 or later (the "GPL"), or
-***************
-*** 37,44 ****
-
- /* Implement shared vtbl methods. */
-
-- /* contributed by Glen Nakamura <glen.nakamura@usa.net> */
--
- #include "xptcprivate.h"
-
- /* Prototype specifies unmangled function name and disables unused warning */
---- 38,43 ----
-*************** __asm__(
-*** 188,210 ****
- * nsresult nsXPTCStubBase::Stub##n()
- * Sets register $1 to "methodIndex" and jumps to SharedStub.
- */
- #define STUB_ENTRY(n) \
- __asm__( \
-! "#### Stub"#n" ####\n" \
-! ".text\n\t" \
-! ".align 5\n\t" \
-! ".globl Stub"#n"__14nsXPTCStubBase\n\t" \
-! ".ent Stub"#n"__14nsXPTCStubBase\n" \
-! "Stub"#n"__14nsXPTCStubBase:\n\t" \
-! ".frame $30,0,$26,0\n\t" \
-! "ldgp $29,0($27)\n" \
-! "$Stub"#n"__14nsXPTCStubBase..ng:\n\t" \
-! ".prologue 1\n\t" \
-! "lda $1,"#n"\n\t" \
-! "br $31,$SharedStub..ng\n\t" \
-! ".end Stub"#n"__14nsXPTCStubBase" \
- );
-
- #define SENTINEL_ENTRY(n) \
- nsresult nsXPTCStubBase::Sentinel##n() \
- { \
---- 187,231 ----
- * nsresult nsXPTCStubBase::Stub##n()
- * Sets register $1 to "methodIndex" and jumps to SharedStub.
- */
-+ #define STUB_MANGLED_ENTRY(n, symbol) \
-+ "#### Stub"#n" ####" "\n\t" \
-+ ".text" "\n\t" \
-+ ".align 5" "\n\t" \
-+ ".globl " symbol "\n\t" \
-+ ".ent " symbol "\n" \
-+ symbol ":" "\n\t" \
-+ ".frame $30,0,$26,0" "\n\t" \
-+ "ldgp $29,0($27)" "\n" \
-+ "$" symbol "..ng:" "\n\t" \
-+ ".prologue 1" "\n\t" \
-+ "lda $1,"#n "\n\t" \
-+ "br $31,$SharedStub..ng" "\n\t" \
-+ ".end " symbol
-+
-+ #if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
-+
-+ #define STUB_ENTRY(n) \
-+ __asm__( \
-+ ".if "#n" < 10" "\n\t" \
-+ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase5Stub"#n"Ev") "\n\t" \
-+ ".elseif "#n" < 100" "\n\t" \
-+ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase6Stub"#n"Ev") "\n\t" \
-+ ".elseif "#n" < 1000" "\n\t" \
-+ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase7Stub"#n"Ev") "\n\t" \
-+ ".else" "\n\t" \
-+ ".err \"Stub"#n" >= 1000 not yet supported.\"" "\n\t" \
-+ ".endif" \
-+ );
-+
-+ #else /* not G++ V3 ABI */
-+
- #define STUB_ENTRY(n) \
- __asm__( \
-! STUB_MANGLED_ENTRY(n, "Stub"#n"__14nsXPTCStubBase") \
- );
-
-+ #endif /* G++ V3 ABI */
-+
- #define SENTINEL_ENTRY(n) \
- nsresult nsXPTCStubBase::Sentinel##n() \
- { \
-*************** nsresult nsXPTCStubBase::Sentinel##n() \
-*** 213,216 ****
- }
-
- #include "xptcstubsdef.inc"
--
---- 234,236 ----
diff --git a/www/beonex/pkg-descr b/www/beonex/pkg-descr
deleted file mode 100644
index 448e8a75a37c..000000000000
--- a/www/beonex/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-This is the Beonex Communicator suite (Web browser, HTML editor, e-mail user
-agent, news reader, address book, and spell-checker). It is based on Mozilla,
-but with extra emphasis on security and privacy.
-
-Because of a security bug, the Chatzilla IRC client is not included in this
-port. Support for SVG and threading are disabled because of compilation
-problems. Java has not been tested.
-
-WWW: http://www.beonex.com
diff --git a/www/beonex/pkg-message b/www/beonex/pkg-message
deleted file mode 100644
index f592d23af753..000000000000
--- a/www/beonex/pkg-message
+++ /dev/null
@@ -1,4 +0,0 @@
-*** WARNING ***
-* The beonex source code has not been reviewed
-* by the maintainer of the FreeBSD port.
-***