aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /www
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
ports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/instiki/Makefile7
-rw-r--r--www/rubygem-actionpack/Makefile7
-rw-r--r--www/rubygem-actionwebservice/Makefile7
-rw-r--r--www/rubygem-amazon-ecs/Makefile7
-rw-r--r--www/rubygem-bluecloth/Makefile7
-rw-r--r--www/rubygem-haml/Makefile7
-rw-r--r--www/rubygem-hpricot/Makefile7
-rw-r--r--www/rubygem-layout-yullio/Makefile7
-rw-r--r--www/rubygem-maruku/Makefile5
-rw-r--r--www/rubygem-mechanize/Makefile5
-rw-r--r--www/rubygem-mongrel/Makefile7
-rw-r--r--www/rubygem-mongrel_cluster/Makefile5
-rw-r--r--www/rubygem-rack/Makefile7
-rw-r--r--www/rubygem-rails-app-installer/Makefile11
-rw-r--r--www/rubygem-rails/Makefile6
-rw-r--r--www/rubygem-redcloth/Makefile6
-rw-r--r--www/rubygem-rubyfulsoup/Makefile5
-rw-r--r--www/rubygem-scrapi/Makefile3
-rw-r--r--www/rubygem-scrubyt/Makefile7
-rw-r--r--www/rubygem-staticmatic/Makefile7
-rw-r--r--www/rubygem-taggable/Makefile7
-rw-r--r--www/rubygem-thin/Makefile7
22 files changed, 77 insertions, 67 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index d1bd0fc9751a..dd6a217ea057 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -16,10 +16,9 @@ MAINTAINER= beech@FreeBSD.org
COMMENT= Easy to set up wiki clone implemented in ruby
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
USE_RUBY= yes
-USE_RUBY_FEATURES= 1.8
+USE_RAKE= yes
USE_LDCONFIG= yes
INSTIKIPORT?= 2500
@@ -38,7 +37,7 @@ RUBY_SHEBANG_FILES=instiki
# can't include this because it redefines do-install.
# .include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
# For now, copy and paste the definition of SPEC_DIR from the above
-REV= 1.8
+REV= ${RUBY_VER}
GEMS_BASE_DIR= lib/ruby/gems/${REV}
SPEC_DIR= ${GEMS_BASE_DIR}/specifications
BUILD_DEPENDS+= ${LOCALBASE}/${SPEC_DIR}/BlueCloth-1.0.0.gemspec:${PORTSDIR}/www/rubygem-bluecloth
@@ -53,7 +52,7 @@ post-patch:
do-build:
( cd ${WRKSRC}/db/ && \
- rake environment RAILS_ENV=production db:migrate )
+ ${RAKE_BIN} environment RAILS_ENV=production db:migrate )
do-install:
@${FIND} -E ${WRKSRC} -type f -iregex ".*\._.+" -exec ${RM} "{}" \;
diff --git a/www/rubygem-actionpack/Makefile b/www/rubygem-actionpack/Makefile
index 48ea64cc70a3..84759612c096 100644
--- a/www/rubygem-actionpack/Makefile
+++ b/www/rubygem-actionpack/Makefile
@@ -16,6 +16,9 @@ COMMENT= Action Controller and Action View of Rails MVC Framework
BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-1.4.4.gemspec:${PORTSDIR}/devel/rubygem-activesupport
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -29,6 +32,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-actionwebservice/Makefile b/www/rubygem-actionwebservice/Makefile
index bef31eea6a7e..2aab9b3eb915 100644
--- a/www/rubygem-actionwebservice/Makefile
+++ b/www/rubygem-actionwebservice/Makefile
@@ -17,6 +17,9 @@ BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/actionpack-1.13.6.gemspec:${PORTSDIR}/ww
${LOCALBASE}/${SPEC_DIR}/activerecord-1.15.6.gemspec:${PORTSDIR}/databases/rubygem-activerecord
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -30,6 +33,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-amazon-ecs/Makefile b/www/rubygem-amazon-ecs/Makefile
index 239866e54e43..f8566ef4a9aa 100644
--- a/www/rubygem-amazon-ecs/Makefile
+++ b/www/rubygem-amazon-ecs/Makefile
@@ -16,6 +16,9 @@ COMMENT= A generic Amazon E-commerce REST API written in Ruby
RUN_DEPENDS= rubygem-hpricot>=0:${PORTSDIR}/www/rubygem-hpricot
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
${ECHO} %%GEM_CACHE%% > pkg-plist.new
@@ -25,6 +28,4 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm %%GEM_LIB_DIR%%,' >> pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-bluecloth/Makefile b/www/rubygem-bluecloth/Makefile
index d8ce926ba5bc..39f5923d0572 100644
--- a/www/rubygem-bluecloth/Makefile
+++ b/www/rubygem-bluecloth/Makefile
@@ -14,6 +14,7 @@ COMMENT= Ruby implementation of Markdown, a text-to-HTML conversion tool
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-haml/Makefile b/www/rubygem-haml/Makefile
index 59e871926120..01dcc6209ae8 100644
--- a/www/rubygem-haml/Makefile
+++ b/www/rubygem-haml/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gogo@cs.uni-sb.de
COMMENT= Markup language to describe XHTML
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-hpricot/Makefile b/www/rubygem-hpricot/Makefile
index ee10a0857598..d350049788cb 100644
--- a/www/rubygem-hpricot/Makefile
+++ b/www/rubygem-hpricot/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= gems
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Fast, Enjoyable HTML Parser for Ruby
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-layout-yullio/Makefile b/www/rubygem-layout-yullio/Makefile
index f7284912acf8..a2af44291ca9 100644
--- a/www/rubygem-layout-yullio/Makefile
+++ b/www/rubygem-layout-yullio/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= sow:${PORTSDIR}/devel/rubygem-hoe
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-maruku/Makefile b/www/rubygem-maruku/Makefile
index 2419acf51eef..4a680e574bad 100644
--- a/www/rubygem-maruku/Makefile
+++ b/www/rubygem-maruku/Makefile
@@ -16,8 +16,7 @@ BUILD_DEPENDS= rubygem-syntax>=1.0.0:${PORTSDIR}/textproc/rubygem-syntax
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RUBYGEMS= yes
USE_RUBY_FEATURES= iconv
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-mechanize/Makefile b/www/rubygem-mechanize/Makefile
index ca8f8382e11b..a59038f6d6aa 100644
--- a/www/rubygem-mechanize/Makefile
+++ b/www/rubygem-mechanize/Makefile
@@ -17,6 +17,7 @@ BUILD_DEPENDS= rubygem-hpricot>=0:${PORTSDIR}/www/rubygem-hpricot \
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RUBYGEMS= yes
post-install:
@${ECHO} ${GEM_CACHE} > ${TMPPLIST}
@@ -26,6 +27,4 @@ post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-mongrel/Makefile b/www/rubygem-mongrel/Makefile
index e373603259c3..02cd02f9d5e1 100644
--- a/www/rubygem-mongrel/Makefile
+++ b/www/rubygem-mongrel/Makefile
@@ -18,6 +18,9 @@ BUILD_DEPENDS= gpgen:${PORTSDIR}/devel/rubygem-gem_plugin \
rubygem-fastthread>=1.0.1:${PORTSDIR}/devel/rubygem-fastthread
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
PATCHNAME= cgi_multipart_eof_fix-2.5.0
PLIST_SUB= CGIFIX="${PATCHNAME}"
@@ -37,6 +40,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-mongrel_cluster/Makefile b/www/rubygem-mongrel_cluster/Makefile
index 9d81a7b4abb3..6bf9c45cbbf1 100644
--- a/www/rubygem-mongrel_cluster/Makefile
+++ b/www/rubygem-mongrel_cluster/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RC_SUBR= mongrel_cluster
USE_RUBY= yes
+USE_RUBYGEMS= yes
REINPLACE_ARGS= -i ""
# This target is only meant to be used by the port maintainer.
@@ -42,6 +43,4 @@ post-install:
@${REINPLACE_CMD} -e 's|\"mongrel_rails\"|\"${PREFIX}/bin/mongrel_rails\"|g' \
${PREFIX}/${GEM_LIB_DIR}/lib/${PORTNAME}/init.rb
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-rack/Makefile b/www/rubygem-rack/Makefile
index 839fcee7c21d..46b62c21fe0a 100644
--- a/www/rubygem-rack/Makefile
+++ b/www/rubygem-rack/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= rack
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Rack, a Ruby Webserver Interface
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rails-app-installer/Makefile b/www/rubygem-rails-app-installer/Makefile
index 72e271005222..549653875c63 100644
--- a/www/rubygem-rails-app-installer/Makefile
+++ b/www/rubygem-rails-app-installer/Makefile
@@ -14,12 +14,15 @@ MASTER_SITE_SUBDIR= rails-installer
MAINTAINER= geraud@gcu.info
COMMENT= An installer for Rails apps
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- rubygem-sqlite3>=1.1.0:${PORTSDIR}/databases/rubygem-sqlite3 \
+BUILD_DEPENDS= rubygem-sqlite3>=1.1.0:${PORTSDIR}/databases/rubygem-sqlite3 \
rubygem-mongrel>=0.3.13:${PORTSDIR}/www/rubygem-mongrel \
rubygem-mongrel_cluster>=0.2.0:${PORTSDIR}/www/rubygem-mongrel_cluster
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -33,6 +36,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-rails/Makefile b/www/rubygem-rails/Makefile
index 8db6b6a370cc..887f36b7c513 100644
--- a/www/rubygem-rails/Makefile
+++ b/www/rubygem-rails/Makefile
@@ -13,8 +13,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= MVC web application framework
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- ${LOCALBASE}/${SPEC_DIR}/activesupport-1.4.4.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
+BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-1.4.4.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
${LOCALBASE}/${SPEC_DIR}/activerecord-1.15.6.gemspec:${PORTSDIR}/databases/rubygem-activerecord \
${LOCALBASE}/${SPEC_DIR}/actionpack-1.13.6.gemspec:${PORTSDIR}/www/rubygem-actionpack \
${LOCALBASE}/${SPEC_DIR}/actionmailer-1.3.6.gemspec:${PORTSDIR}/mail/rubygem-actionmailer \
@@ -27,6 +26,8 @@ OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
# to get RUBY_SITEARCHLIBDIR
USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
# This target is only meant to be used by the port maintainer.
x-generate-plist:
@@ -51,5 +52,4 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/fcgi.so:${PORTSDIR}/www/ruby-fcgi
RUN_DEPENDS+= rubygem-memcache-client>=1.2.0:${PORTSDIR}/databases/rubygem-memcache-client
.endif
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/rubygem-redcloth/Makefile b/www/rubygem-redcloth/Makefile
index 9b1eb4faebc4..1f4e88363c3e 100644
--- a/www/rubygem-redcloth/Makefile
+++ b/www/rubygem-redcloth/Makefile
@@ -14,8 +14,8 @@ DISTNAME= RedCloth-${PORTVERSION}
MAINTAINER= jw@innerewut.de
COMMENT= A module for using Textile in Ruby
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-rubyfulsoup/Makefile b/www/rubygem-rubyfulsoup/Makefile
index 86c3ed492dc9..984b8ea52c91 100644
--- a/www/rubygem-rubyfulsoup/Makefile
+++ b/www/rubygem-rubyfulsoup/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= rubygem-htmltools>=1.10:${PORTSDIR}/textproc/rubygem-htmltools
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= rubyful_soup-${PORTVERSION}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-scrapi/Makefile b/www/rubygem-scrapi/Makefile
index 84435cbe4c5e..b68cfcbbdccf 100644
--- a/www/rubygem-scrapi/Makefile
+++ b/www/rubygem-scrapi/Makefile
@@ -17,6 +17,8 @@ COMMENT= A scrAPI toolkit for Ruby
BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/tidy-1.1.2.gemspec:${PORTSDIR}/textproc/rubygem-tidy \
tidy:${PORTSDIR}/www/tidy-lib
+USE_RUBY= yes
+USE_RUBYGEMS= yes
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
@@ -26,5 +28,4 @@ post-install:
${RM} -f ${LOCALBASE}/${GEM_LIB_DIR}/lib/tidy/libtidy.so
${LN} -sf ${LOCALBASE}/lib/libtidy.so ${LOCALBASE}/${GEM_LIB_DIR}/lib/tidy/
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/rubygem-scrubyt/Makefile b/www/rubygem-scrubyt/Makefile
index 736689785e96..8b2413649072 100644
--- a/www/rubygem-scrubyt/Makefile
+++ b/www/rubygem-scrubyt/Makefile
@@ -16,6 +16,9 @@ COMMENT= A powerful web scraping toolkit written in Ruby
RUN_DEPENDS= rubygem-mechanize>=0.6.3:${PORTSDIR}/www/rubygem-mechanize
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
${ECHO} %%GEM_CACHE%% > pkg-plist.new
@@ -25,6 +28,4 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm %%GEM_LIB_DIR%%,' >> pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/rubygem-staticmatic/Makefile b/www/rubygem-staticmatic/Makefile
index f48c791f7e62..5ff03c674525 100644
--- a/www/rubygem-staticmatic/Makefile
+++ b/www/rubygem-staticmatic/Makefile
@@ -16,6 +16,7 @@ COMMENT= Manage static websites using Haml and Sass
RUN_DEPENDS= rubygem-haml>=1.7.0:${PORTSDIR}/www/rubygem-haml \
rubygem-mongrel>=1.0.1:${PORTSDIR}/www/rubygem-mongrel
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-taggable/Makefile b/www/rubygem-taggable/Makefile
index 6d0feff1467f..e60421441dfb 100644
--- a/www/rubygem-taggable/Makefile
+++ b/www/rubygem-taggable/Makefile
@@ -18,6 +18,7 @@ COMMENT= Add tagging capabilities to your ActiveRecord objects
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-thin/Makefile b/www/rubygem-thin/Makefile
index 306b42484e41..71c40644c860 100644
--- a/www/rubygem-thin/Makefile
+++ b/www/rubygem-thin/Makefile
@@ -17,6 +17,7 @@ BUILD_DEPENDS= rackup:${PORTSDIR}/www/rubygem-rack \
rubygem-daemons>=1.0.9:${PORTSDIR}/devel/rubygem-daemons
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>