aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-09-13 10:29:41 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-09-13 10:29:41 +0000
commit2f928a99ef61f371745940ea602ab29f7d086007 (patch)
treeb58566d873656eff4d0507a4ae52f5b885286614 /www
parenteb004ee7e2329813e4dd6e48c0a4e62b9c753ea8 (diff)
downloadports-2f928a99ef61f371745940ea602ab29f7d086007.tar.gz
ports-2f928a99ef61f371745940ea602ab29f7d086007.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile19
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo6
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist6
3 files changed, 19 insertions, 12 deletions
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile
index 8659c0a2b181..3b8e7e86bf11 100644
--- a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile
@@ -6,30 +6,31 @@
#
PORTNAME= Catalyst-Plugin-Authentication-Store-DBIC
-PORTVERSION= 0.07000
+PORTVERSION= 0.08000
CATEGORIES= www perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Catalyst
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/0*$//}
MAINTAINER= lbr@FreeBSD.org
COMMENT= Authentication/authorization on a DBIx::Class/Class::DBI model
-BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Catalyst-Plugin-Authentication>=0.06:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
- p5-Catalyst-Plugin-Authorization-Roles>=0.03:${PORTSDIR}/www/p5-Catalyst-Plugin-Authorization-Roles \
p5-Set-Object>=1.14:${PORTSDIR}/devel/p5-Set-Object \
- p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Catalyst-Plugin-Authorization-Roles>=0.03:${PORTSDIR}/www/p5-Catalyst-Plugin-Authorization-Roles \
+ p5-Catalyst-Plugin-Session-State-Cookie>=0.02:${PORTSDIR}/www/p5-Catalyst-Plugin-Session-State-Cookie
+BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_MODBUILD= 5.8.1+
+PERL_CONFIGURE= 5.8.1+
MAN3= Catalyst::Plugin::Authentication::Store::DBIC.3 \
Catalyst::Plugin::Authentication::Store::DBIC::Backend.3 \
Catalyst::Plugin::Authentication::Store::DBIC::User.3
post-extract:
- @${PERL} -i.bak -ne 'print unless /^\s*recommends/ .. /},$$/' ${WRKSRC}/Build.PL
+ @${PERL} -i.bak -ne 'print unless /^\s*feature/ .. /;\s*$$/' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo
index cc058d902451..17de5b145841 100644
--- a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo
@@ -1,3 +1,3 @@
-MD5 (Catalyst-Plugin-Authentication-Store-DBIC-0.07.tar.gz) = 796f4b369f3717fc289126f6758a7ba9
-SHA256 (Catalyst-Plugin-Authentication-Store-DBIC-0.07.tar.gz) = 4ee68cfce7f94597383954ab57a79376cea38a6105a266dd20d0fb62e5a8c6b3
-SIZE (Catalyst-Plugin-Authentication-Store-DBIC-0.07.tar.gz) = 13410
+MD5 (Catalyst-Plugin-Authentication-Store-DBIC-0.08.tar.gz) = 76dd90881b7872ee030a69e3ddf7c22f
+SHA256 (Catalyst-Plugin-Authentication-Store-DBIC-0.08.tar.gz) = 6379a4ad62a7640a09a9831aa17b3c00fe555cf763433a4f698d40953c8bdc7d
+SIZE (Catalyst-Plugin-Authentication-Store-DBIC-0.08.tar.gz) = 29334
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist
index 4235b9ffcace..0c1c54200823 100644
--- a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist
@@ -2,6 +2,12 @@
%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC/User.pm
%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC/Backend.pm
%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store/DBIC/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store/DBIC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC/User
@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC
@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store