aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-02-03 22:35:20 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-02-03 22:35:20 +0000
commit837b118303151ea6a4c7dcaea8b50c317247bf9d (patch)
tree0cc42e9347d1c594d500c900441160020d9370b2 /www
parent127287b4193da0876eed4d97b7bfb99aec88fd30 (diff)
downloadports-837b118303151ea6a4c7dcaea8b50c317247bf9d.tar.gz
ports-837b118303151ea6a4c7dcaea8b50c317247bf9d.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/tidy-devel/Makefile66
-rw-r--r--www/tidy-devel/distinfo9
-rw-r--r--www/tidy-devel/files/patch-build_gmake_Makefile12
-rw-r--r--www/tidy-devel/files/patch-include_platform.h8
-rw-r--r--www/tidy-devel/files/patch-test_testaccessone.sh11
-rw-r--r--www/tidy-devel/pkg-plist53
6 files changed, 70 insertions, 89 deletions
diff --git a/www/tidy-devel/Makefile b/www/tidy-devel/Makefile
index afce0561819d..4a173c716db3 100644
--- a/www/tidy-devel/Makefile
+++ b/www/tidy-devel/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME?= tidy
-PORTVERSION= 051026
-PORTREVISION= 2
+DISTVERSION= 070203-cvs
CATEGORIES= www
-MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
- http://tidy.sourceforge.net/docs/:docs
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+#MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
+# http://tidy.sourceforge.net/docs/:docs
+#MASTER_SITE_SUBDIR= . old
PKGNAMESUFFIX?= -devel
-DISTNAME= tidy_src
-EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= thierry@FreeBSD.org
COMMENT?= Utility to clean up and pretty print HTML/XHTML/XML
+USE_BZIP2= yes
+
+SLAVEDIRS= www/tidy-lib
WRKSRC= ${WRKDIR}/${PORTNAME}
.if !defined(WITH_SHLIB)
@@ -29,7 +29,7 @@ PLIST_SUB= SHLIB="@comment " NSHLIB=""
USE_AUTOTOOLS= automake:15 autoconf:253 libtool:15
AUTOMAKE_ARGS+= -a -c --foreign
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= SHLIB="" NSHLIB="@comment "
.endif
@@ -47,26 +47,48 @@ BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt
ALL_TARGET= all doc
DOCFILES= quickref.html
. endif
-DOCVER= 051020
-DISTFILES+= tidy_docs_${DOCVER}${EXTRACT_SUFX}:docs
DOCFILES+= Overview.html checked_by_tidy.gif faq.html grid.gif pending.html \
release-notes.html tidy.css tidy.gif
.endif
+.if defined(MAINTAINER_MODE)
+
+CVSROOT= ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy"
+CVS_PASSFILE= ${WRKDIR}/temp-cvs-passfile
+
+getcvs:
+ ${MKDIR} ${WRKDIR}/cvs
+ ${ECHO_CMD} ${CVSROOT} A > ${CVS_PASSFILE}
+ cd ${WRKDIR}/cvs && \
+ CVSROOT=${CVSROOT} CVS_PASSFILE=${CVS_PASSFILE} cvs -z3 co -P tidy
+
+tarball:
+ ${RM} -rf ${WRKDIR}/cvs/tidy/CVSROOT
+ ${FIND} ${WRKDIR}/cvs -name CVS | ${XARGS} ${RM} -rf
+ cd ${WRKDIR}/cvs && \
+ ${TAR} cfj ${_DISTDIR}${DISTFILES} tidy
+
+.endif
+
post-patch:
+ ${CHMOD} a+x ${WRKSRC}/test/testxml.sh
.if !defined(WITH_SHLIB)
- @${CP} ${WRKSRC}/build/gmake/Makefile ${WRKSRC}
+ ${CP} ${WRKSRC}/build/gmake/Makefile ${WRKSRC}
.else
- @${CP} -R -f ${WRKSRC}/build/gnuauto/* ${WRKSRC}
+ ${CP} -R -f ${WRKSRC}/build/gnuauto/* ${WRKSRC}
+. for t in testone.sh testaccessone.sh
+ ${REINPLACE_CMD} -e 's|../bin/tidy|../console/tidy|' \
+ ${WRKSRC}/test/${t}
+. endfor
.endif
patch-autotools::
.if defined(WITH_SHLIB)
- @(cd ${WRKSRC} \
+ (cd ${WRKSRC} \
&& ${LIBTOOLIZE} --force --copy \
&& ${ACLOCAL} \
&& ${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' aclocal.m4)
- @(cd ${PATCH_WRKSRC}; \
+ (cd ${PATCH_WRKSRC}; \
for ltf in ${LIBTOOLFILES}; do \
${CP} $$ltf $$ltf.tmp; \
${SED} -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
@@ -86,17 +108,21 @@ pre-install:
post-install:
.for pgm in ${BIN2STRIP}
- @${STRIP_CMD} ${PREFIX}/bin/${pgm}
+ ${STRIP_CMD} ${PREFIX}/bin/${pgm}
.endfor
.if defined(WITH_SHLIB)
- @${STRIP_CMD} ${PREFIX}/lib/libtidy-0.99.so.0
+ ${STRIP_CMD} ${PREFIX}/lib/libtidy-0.99.so.0
.endif
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}/api
- @${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/htmldoc/|} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/htmldoc/api/* ${DOCSDIR}/api
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/htmldoc/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
+regression-test:
+.for t in testaccess.sh testall.sh testxml.sh
+ cd ${WRKSRC}/test && ./${t}
+.endfor
+
.include <bsd.port.mk>
diff --git a/www/tidy-devel/distinfo b/www/tidy-devel/distinfo
index db7021a54053..cdf355978304 100644
--- a/www/tidy-devel/distinfo
+++ b/www/tidy-devel/distinfo
@@ -1,6 +1,3 @@
-MD5 (tidy_src_051026.tgz) = 1e39fafd6808978871346658c8da1454
-SHA256 (tidy_src_051026.tgz) = 538aadc6f06e988cca932bfecae00313063ce01e62f4d395cf84736fca41bbfd
-SIZE (tidy_src_051026.tgz) = 256131
-MD5 (tidy_docs_051020.tgz) = 86de2f198e57399c063d2567b2a25628
-SHA256 (tidy_docs_051020.tgz) = 8afdf165e7d5ce13cd64af4a5d0961627e006dbb3697fef97d378c94f052e35c
-SIZE (tidy_docs_051020.tgz) = 150402
+MD5 (tidy-070203-cvs.tar.bz2) = 11f1636343d73cbb8b392deb71cd3c1e
+SHA256 (tidy-070203-cvs.tar.bz2) = f9fbf6ef1f8928dd90d1c5c92177236b59eb04b01313d20b32236a4a084243e5
+SIZE (tidy-070203-cvs.tar.bz2) = 368341
diff --git a/www/tidy-devel/files/patch-build_gmake_Makefile b/www/tidy-devel/files/patch-build_gmake_Makefile
index 5deee6bec0d6..cf687d2f5359 100644
--- a/www/tidy-devel/files/patch-build_gmake_Makefile
+++ b/www/tidy-devel/files/patch-build_gmake_Makefile
@@ -1,5 +1,5 @@
---- build/gmake/Makefile.orig Thu Jul 14 08:58:05 2005
-+++ build/gmake/Makefile Thu Jul 14 22:57:37 2005
+--- build/gmake/Makefile.orig Sun Jan 21 21:20:58 2007
++++ build/gmake/Makefile Sat Feb 3 17:35:37 2007
@@ -58,8 +58,8 @@
PROJECT=tidy
@@ -20,14 +20,14 @@
INCDIR = ${TOPDIR}/include
APPDIR = ${TOPDIR}/console
SRCDIR = ${TOPDIR}/src
-@@ -79,8 +79,8 @@
+@@ -90,8 +90,8 @@
# CFLAGS etc..
# For optimised builds, flags such as "-O2" should be added and -D_DEBUG=1
# disabled.
-CC= gcc
--CFLAGS= -g -Wall -Wno-switch -Wno-parentheses -I $(INCDIR)
+-CFLAGS= -g -pedantic -Wall -Wno-switch -Wno-parentheses -I $(INCDIR)
+#CC= gcc
-+CFLAGS+= -g -Wall -Wno-switch -Wno-parentheses -I $(INCDIR) -fPIC
++CFLAGS+= -g -pedantic -Wall -Wno-switch -Wno-parentheses -I $(INCDIR) -fPIC
# flags only supported with gcc 3.x
- # CFLAGS += -Wunused-parameter
+ CFLAGS += -Wunused-parameter
diff --git a/www/tidy-devel/files/patch-include_platform.h b/www/tidy-devel/files/patch-include_platform.h
index 179306b98f93..a49840924eed 100644
--- a/www/tidy-devel/files/patch-include_platform.h
+++ b/www/tidy-devel/files/patch-include_platform.h
@@ -1,11 +1,11 @@
---- include/platform.h.orig Mon Mar 31 09:57:04 2003
-+++ include/platform.h Mon Mar 31 21:23:33 2003
+--- include/platform.h.orig Sun Jan 21 21:36:21 2007
++++ include/platform.h Sat Feb 3 17:39:40 2007
@@ -33,7 +33,7 @@
It enables tidy to find config files named ~/.tidyrc if
the HTML_TIDY environment variable is not set.
*/
--/* #define USER_CONFIG_FILE "~/.tidyrc" */
-+#define USER_CONFIG_FILE "~/.tidyrc"
+-/* #define TIDY_USER_CONFIG_FILE "~/.tidyrc" */
++#define TIDY_USER_CONFIG_FILE "~/.tidyrc"
/*
Uncomment the following #define if your
diff --git a/www/tidy-devel/files/patch-test_testaccessone.sh b/www/tidy-devel/files/patch-test_testaccessone.sh
new file mode 100644
index 000000000000..ce8d5a771384
--- /dev/null
+++ b/www/tidy-devel/files/patch-test_testaccessone.sh
@@ -0,0 +1,11 @@
+--- test/testaccessone.sh.orig Wed Mar 23 13:57:19 2005
++++ test/testaccessone.sh Sat Feb 3 18:59:46 2007
+@@ -71,7 +71,7 @@
+ $TIDY -f $MSGFILE --accessibility-check $ACCESSLEVEL -config $CFGFILE "$@" --gnu-emacs yes --tidy-mark no -o $TIDYFILE $INFILE
+ STATUS=$?
+
+-if [ `grep -c -e ' \['$TESTEXPECTED'\]: ' $MSGFILE` -eq 0 ]
++if [ `grep -c -e ' \['$TESTEXPECTED'\]: ' $MSGFILE` = 0 ]
+ then
+ echo "--- test '$TESTEXPECTED' not detected in file '$INFILE'"
+ cat $MSGFILE
diff --git a/www/tidy-devel/pkg-plist b/www/tidy-devel/pkg-plist
index 1eca1892c4f0..410f3b959e4d 100644
--- a/www/tidy-devel/pkg-plist
+++ b/www/tidy-devel/pkg-plist
@@ -2,7 +2,6 @@
bin/tab2space
bin/tidy
include/tidy/buffio.h
-include/tidy/fileio.h
include/tidy/platform.h
include/tidy/tidy.h
include/tidy/tidyenum.h
@@ -20,57 +19,5 @@ lib/libtidy.a
%%PORTDOCS%%%%DOCSDIR%%/release-notes.html
%%PORTDOCS%%%%DOCSDIR%%/tidy.css
%%PORTDOCS%%%%DOCSDIR%%/tidy.gif
-%%PORTDOCS%%%%DOCSDIR%%/api/annotated.html
-%%PORTDOCS%%%%DOCSDIR%%/api/buffio_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/api/buffio_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/api/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/api/doxygen.png
-%%PORTDOCS%%%%DOCSDIR%%/api/fileio_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/api/fileio_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/api/files.html
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2blank.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2doc.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2folderclosed.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2folderopen.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2lastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2link.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2mlastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2mnode.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2node.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2plastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2pnode.png
-%%PORTDOCS%%%%DOCSDIR%%/api/ftv2vertline.png
-%%PORTDOCS%%%%DOCSDIR%%/api/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/api/globals.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__AttrGet.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Attribute.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Basic.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Clean.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__IO.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Memory.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__NodeAsk.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Opaque.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Parse.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Save.html
-%%PORTDOCS%%%%DOCSDIR%%/api/group__Tree.html
-%%PORTDOCS%%%%DOCSDIR%%/api/index.html
-%%PORTDOCS%%%%DOCSDIR%%/api/main.html
-%%PORTDOCS%%%%DOCSDIR%%/api/modules.html
-%%PORTDOCS%%%%DOCSDIR%%/api/structTidyAttr.html
-%%PORTDOCS%%%%DOCSDIR%%/api/structTidyDoc.html
-%%PORTDOCS%%%%DOCSDIR%%/api/structTidyNode.html
-%%PORTDOCS%%%%DOCSDIR%%/api/structTidyOption.html
-%%PORTDOCS%%%%DOCSDIR%%/api/struct__TidyBuffer.html
-%%PORTDOCS%%%%DOCSDIR%%/api/struct__TidyInputSource.html
-%%PORTDOCS%%%%DOCSDIR%%/api/struct__TidyOutputSink.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tidy_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tidy_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tidyenum_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tidyenum_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tree.html
-%%PORTDOCS%%%%DOCSDIR%%/api/tree.js
-%%PORTDOCS%%%%DOCSDIR%%/api/treeview.js
@dirrm include/tidy
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/api
%%PORTDOCS%%@dirrm %%DOCSDIR%%