aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-06 12:00:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-06 12:00:08 +0000
commit8e4e3b184c22ddb50734c337605fbb5ac1976734 (patch)
treefe7df51ede487ee925ddb1dbf30b4016de18237e /www
parentf56a7d53f0103750defbbf824f685230d12e22da (diff)
downloadports-8e4e3b184c22ddb50734c337605fbb5ac1976734.tar.gz
ports-8e4e3b184c22ddb50734c337605fbb5ac1976734.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/abyssws/Makefile38
-rw-r--r--www/abyssws/distinfo3
-rw-r--r--www/abyssws/files/abyssws.sh.in35
-rw-r--r--www/abyssws/pkg-descr16
-rw-r--r--www/abyssws/pkg-install50
-rw-r--r--www/abyssws/pkg-plist103
7 files changed, 246 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 49148abf1764..3cfdcb27e2c3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -5,6 +5,7 @@
SUBDIR += MT
SUBDIR += WebMagick
+ SUBDIR += abyssws
SUBDIR += adblock
SUBDIR += admuser
SUBDIR += adzap
diff --git a/www/abyssws/Makefile b/www/abyssws/Makefile
new file mode 100644
index 000000000000..6d454bb0f250
--- /dev/null
+++ b/www/abyssws/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: abyssws
+# Date created: 26 August 2007
+# Whom: Daniel Voisine
+#
+# $FreeBSD$
+#
+
+PORTNAME= abyssws
+PORTVERSION= 2.4
+CATEGORIES= www
+MASTER_SITES= http://www.aprelium.com/data/
+DISTNAME= abwsx1-freebsd
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= voisined@wit.edu
+COMMENT= Abyss Web Server is a compact and easy to use web server
+
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
+WRKSRC= ${WRKDIR}/abyssws
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+
+USE_RC_SUBR= abyssws.sh
+
+pre-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/abyssws
+ ${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${PREFIX}/lib/abyssws -xf -
+
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/www/abyssws/distinfo b/www/abyssws/distinfo
new file mode 100644
index 000000000000..7e128bca4785
--- /dev/null
+++ b/www/abyssws/distinfo
@@ -0,0 +1,3 @@
+MD5 (abwsx1-freebsd.tgz) = b97675bf528ca336fa7b68fb616c0df1
+SHA256 (abwsx1-freebsd.tgz) = ce1d575abc6ffaa75b60293a2ffc6b5488c8193bb948b2797f7f946848519adb
+SIZE (abwsx1-freebsd.tgz) = 338272
diff --git a/www/abyssws/files/abyssws.sh.in b/www/abyssws/files/abyssws.sh.in
new file mode 100644
index 000000000000..b0d6a9244ca7
--- /dev/null
+++ b/www/abyssws/files/abyssws.sh.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: abyssws
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# abyssws_enable (bool): Set to NO by default.
+# Set it to YES to enable abyssws.
+#
+
+. %%RC_SUBR%%
+
+name=abyssws
+rcvar=${name}_enable
+
+command="%%PREFIX%%/lib/abyssws/abyssws"
+command_args="-d >/dev/null"
+pidfile="%%PREFIX%%/lib/abyssws/log/abyssws.pid"
+stop_postcmd="abyssws_poststop"
+
+abyssws_poststop()
+{
+ /bin/rm -f "${pidfile}"
+}
+
+load_rc_config $name
+
+: ${abyssws_enable="NO"}
+
+run_rc_command "$1"
diff --git a/www/abyssws/pkg-descr b/www/abyssws/pkg-descr
new file mode 100644
index 000000000000..42b493cf29b4
--- /dev/null
+++ b/www/abyssws/pkg-descr
@@ -0,0 +1,16 @@
+Abyss Web Server is a compact and easy to use web server.
+
+Despite its small footprint, it supports HTTP/1.1, dynamic content generation
+through CGI/FastCGI scripts, ISAPI extensions, native ASP.NET support, Server
+Side Includes (SSI), custom error pages, password protection, IP address
+control, anti-leeching, and bandwidth throttling.
+
+It also features an automatic antihacking system as well as a multilingual
+remote web management interface that makes its configuration as easy as
+browsing a web site.
+
+It supports a wide range of Web technologies and can run advanced PHP, Perl,
+Python, ASP, ASP.NET, and Ruby on Rails Web applications which can be backed
+by databases such as MySQL, SQLite, MS SQL Server, MS Access, or Oracle.
+
+WWW: http://www.aprelium.com/
diff --git a/www/abyssws/pkg-install b/www/abyssws/pkg-install
new file mode 100644
index 000000000000..36925b9a26e9
--- /dev/null
+++ b/www/abyssws/pkg-install
@@ -0,0 +1,50 @@
+#! /bin/sh
+
+# $FreeBSD$
+
+PATH=/bin:/usr/sbin
+WSHOME=${PKG_PREFIX}/lib/abyssws
+
+USER=abyssws
+GROUP=${USER}
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d ${WSHOME} -c "Abyss Web Server"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if ! [ -x ~${USER} ] ; then
+ mkdir -p ${WSHOME}
+ chown ${USER}:${GROUP} ${WSHOME}
+ fi
+ ;;
+
+POST-INSTALL)
+ chown -R ${USER}:${GROUP} ${WSHOME}
+ chmod -R u+w,o-rx ${WSHOME}
+ chmod u+s ${WSHOME}/abyssws
+ ;;
+
+
+esac
diff --git a/www/abyssws/pkg-plist b/www/abyssws/pkg-plist
new file mode 100644
index 000000000000..747a5cbb38da
--- /dev/null
+++ b/www/abyssws/pkg-plist
@@ -0,0 +1,103 @@
+lib/abyssws/Installation Instructions.html
+lib/abyssws/abyssws
+lib/abyssws/console/about.gif
+lib/abyssws/console/alias.gif
+lib/abyssws/console/antileech.gif
+lib/abyssws/console/aspnet.gif
+lib/abyssws/console/bandwidth.gif
+lib/abyssws/console/console.css
+lib/abyssws/console/console.gif
+lib/abyssws/console/delete.gif
+lib/abyssws/console/down.gif
+lib/abyssws/console/drive.gif
+lib/abyssws/console/edit.gif
+lib/abyssws/console/err.gif
+lib/abyssws/console/error.gif
+lib/abyssws/console/favicon.ico
+lib/abyssws/console/file.gif
+lib/abyssws/console/first.gif
+lib/abyssws/console/folder.gif
+lib/abyssws/console/halflogo.gif
+lib/abyssws/console/help.gif
+lib/abyssws/console/index.gif
+lib/abyssws/console/info.gif
+lib/abyssws/console/ipcard.gif
+lib/abyssws/console/language.gif
+lib/abyssws/console/last.gif
+lib/abyssws/console/listing.gif
+lib/abyssws/console/log.gif
+lib/abyssws/console/mime.gif
+lib/abyssws/console/parameters.gif
+lib/abyssws/console/pfolder.gif
+lib/abyssws/console/qm-ltr.gif
+lib/abyssws/console/qm-rtl.gif
+lib/abyssws/console/rewriting.gif
+lib/abyssws/console/scripting.gif
+lib/abyssws/console/server.gif
+lib/abyssws/console/sgroup.gif
+lib/abyssws/console/shield.gif
+lib/abyssws/console/ssi.gif
+lib/abyssws/console/stats.gif
+lib/abyssws/console/suser.gif
+lib/abyssws/console/up.gif
+lib/abyssws/console/user.gif
+lib/abyssws/console/usercard.gif
+lib/abyssws/doc/accessconsole.html
+lib/abyssws/doc/altformats.html
+lib/abyssws/doc/asksupport.html
+lib/abyssws/doc/cgiinternals.html
+lib/abyssws/doc/cgivars.html
+lib/abyssws/doc/chapters.html
+lib/abyssws/doc/commandline.html
+lib/abyssws/doc/console.html
+lib/abyssws/doc/consoleconfig.html
+lib/abyssws/doc/consoleinterface.html
+lib/abyssws/doc/contact1.html
+lib/abyssws/doc/conventions.html
+lib/abyssws/doc/delete.png
+lib/abyssws/doc/directives.html
+lib/abyssws/doc/dirlist.html
+lib/abyssws/doc/dirscript.html
+lib/abyssws/doc/edit.png
+lib/abyssws/doc/fastcgi.html
+lib/abyssws/doc/glossary.html
+lib/abyssws/doc/hosts-add.html
+lib/abyssws/doc/hosts-configuration.html
+lib/abyssws/doc/hosts.html
+lib/abyssws/doc/howdowswork.html
+lib/abyssws/doc/index.html
+lib/abyssws/doc/install.html
+lib/abyssws/doc/intro.html
+lib/abyssws/doc/ipformat.html
+lib/abyssws/doc/isapi.html
+lib/abyssws/doc/knowledge.html
+lib/abyssws/doc/ln63.html
+lib/abyssws/doc/patternsformat.html
+lib/abyssws/doc/portsproblems.html
+lib/abyssws/doc/preface.html
+lib/abyssws/doc/qm-ltr.png
+lib/abyssws/doc/regex.html
+lib/abyssws/doc/scripting.html
+lib/abyssws/doc/server.html
+lib/abyssws/doc/servergeneral.html
+lib/abyssws/doc/serverstats.html
+lib/abyssws/doc/setupsimple.html
+lib/abyssws/doc/shutdown.html
+lib/abyssws/doc/ssi.html
+lib/abyssws/doc/ssiencoding.html
+lib/abyssws/doc/ssisyntax.html
+lib/abyssws/doc/start.html
+lib/abyssws/doc/stylesheet.css
+lib/abyssws/doc/troubleshooting.html
+lib/abyssws/doc/useroption.html
+lib/abyssws/lang/ar.lng
+lib/abyssws/lang/fr.lng
+lib/abyssws/license.txt
+lib/abyssws/htdocs/index.html
+lib/abyssws/htdocs/pwrabyss.gif
+@dirrm lib/abyssws/console
+@dirrm lib/abyssws/doc
+@dirrmtry lib/abyssws/htdocs
+@dirrm lib/abyssws/lang
+@dirrmtry lib/abyssws/log
+@dirrmtry lib/abyssws