aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-10-02 08:48:14 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 10:15:28 +0000
commitae9c04d9402d301333632788cbb058f4209916b1 (patch)
treefc53d944fbde059f3e061547adb3bc40fd223f05 /www
parentba7ccc09c2978db59fc6e87a38745202cf0e6bfa (diff)
downloadports-ae9c04d9402d301333632788cbb058f4209916b1.tar.gz
ports-ae9c04d9402d301333632788cbb058f4209916b1.zip
www/gitlab-ce: fix default backup configuration
PR: 258922 (cherry picked from commit 2c47b503373d7c6c29cf94a2756f4179828f60c0)
Diffstat (limited to 'www')
-rw-r--r--www/gitlab-ce/Makefile3
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example20
2 files changed, 18 insertions, 5 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 5cd7434ee967..eaf4bd59dc9d 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gitlab-ce
PORTVERSION= 14.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -395,7 +395,6 @@ post-install:
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets/private" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets/private/internal" >> ${TMPPLIST}
- @${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor/assets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor/assets/stylesheets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/workhorse/changelogs/unreleased" >> ${TMPPLIST}
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index fab515d68357..6c9974f4a7df 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,6 +1,6 @@
---- config/gitlab.yml.example.orig 2021-09-21 10:06:28 UTC
+--- config/gitlab.yml.example.orig 2021-10-01 16:06:26 UTC
+++ config/gitlab.yml.example
-@@ -1128,8 +1128,8 @@ production: &base
+@@ -1128,14 +1128,14 @@ production: &base
# real path not the symlink.
storages: # You must have at least a `default` storage path.
default:
@@ -11,6 +11,13 @@
# gitaly_token: 'special token' # Optional: override global gitaly.token for this storage.
## Backup settings
+ backup:
+ path: "tmp/backups" # Relative paths are relative to Rails.root (default: tmp/backups/)
+- # gitaly_backup_path: # Path of the gitaly-backup binary (default: searches $PATH)
++ gitaly_backup_path: %%PREFIX%%/share/gitaly/bin/gitaly-backup # Path of the gitaly-backup binary (default: searches $PATH)
+ # archive_permissions: 0640 # Permissions for the resulting backup.tar file (default: 0600)
+ # keep_time: 604800 # default: 0 (forever) (in seconds)
+ # pg_schema: public # default: nil, it means that all schemas will be backed up
@@ -1184,12 +1184,12 @@ production: &base
## GitLab Shell settings
@@ -59,7 +66,7 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1453,7 +1453,7 @@ test:
+@@ -1453,13 +1453,13 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
@@ -68,3 +75,10 @@
token: secret
workhorse:
secret_file: tmp/gitlab_workhorse_test_secret
+ backup:
+ path: tmp/tests/backups
+- gitaly_backup_path: tmp/tests/gitaly/_build/bin/gitaly-backup
++ gitaly_backup_path: %%PREFIX%%/share/gitaly/bin/gitaly-backup
+ pseudonymizer:
+ manifest: config/pseudonymizer.yml
+ upload: