aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-28 10:15:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-28 10:15:44 +0000
commitd0bd017cccc7859bae3b558e49fd0257a3bb8485 (patch)
tree551978826b476a9e2619d846ac6180fda32ad7fd /www
parentd15541202cb35b6951a72e58a185b4e9cb811125 (diff)
downloadports-d0bd017cccc7859bae3b558e49fd0257a3bb8485.tar.gz
ports-d0bd017cccc7859bae3b558e49fd0257a3bb8485.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pumperweb/Makefile26
-rw-r--r--www/pumperweb/pkg-descr6
-rw-r--r--www/pumperweb/pkg-plist1
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a311b5be163a..954106675050 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -948,6 +948,7 @@
SUBDIR += pserv
SUBDIR += pubcookie-login-server
SUBDIR += publicfile
+ SUBDIR += pumperweb
SUBDIR += punbb
SUBDIR += pwebstats
SUBDIR += py-HTMLgen
diff --git a/www/pumperweb/Makefile b/www/pumperweb/Makefile
new file mode 100644
index 000000000000..1125078b26d1
--- /dev/null
+++ b/www/pumperweb/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pumperweb
+# Date created: 2007-03-28
+# Whom: Thinker K.F. Li <thinker@branda.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pumperweb
+PORTVERSION= 0.1
+CATEGORIES= www devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thinker@branda.to
+COMMENT= PumperWeb is a meta project that creates a WEB framework
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ez_web/ez_user_auth.py:${PORTSDIR}/www/py-ez_web \
+ ${PYTHON_SITELIBDIR}/sqlcc/__init__.py:${PORTSDIR}/devel/py-sqlcc
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+
+.include <bsd.port.mk>
diff --git a/www/pumperweb/pkg-descr b/www/pumperweb/pkg-descr
new file mode 100644
index 000000000000..30f5a6577e77
--- /dev/null
+++ b/www/pumperweb/pkg-descr
@@ -0,0 +1,6 @@
+PumperWeb is a set of tools for Python WEB developer. It tries to keep
+programmer's life simple. No more heavy framework, not more dirty. PumperWeb
+keeps programmers simple and smart. There is a old said, "Keep It Simple &
+Stupid". Stupid! A good stupid is another way to be smart.
+
+WWW: https://opensvn.csie.org/traccgi/PumperWeb/wiki
diff --git a/www/pumperweb/pkg-plist b/www/pumperweb/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/www/pumperweb/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$