aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-19 17:50:25 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-19 17:50:25 +0000
commitd4e268e8514dcc1c279e865834abe13f8380f6ba (patch)
tree74f2fe99cf44b6fd176e4b8adf0e59b472974e4f /www
parent582fa8f6c789917c94950d6254b97cd49dd9f4dc (diff)
downloadports-d4e268e8514dcc1c279e865834abe13f8380f6ba.tar.gz
ports-d4e268e8514dcc1c279e865834abe13f8380f6ba.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-HTML-Form/Makefile2
-rw-r--r--www/p5-HTTP-Cookies/Makefile2
-rw-r--r--www/p5-HTTP-Daemon/Makefile2
-rw-r--r--www/p5-HTTP-Date/Makefile2
-rw-r--r--www/p5-HTTP-Message/Makefile2
-rw-r--r--www/p5-HTTP-Negotiate/Makefile2
-rw-r--r--www/p5-LWP-MediaTypes/Makefile2
-rw-r--r--www/p5-WWW-RobotRules/Makefile2
8 files changed, 16 insertions, 0 deletions
diff --git a/www/p5-HTML-Form/Makefile b/www/p5-HTML-Form/Makefile
index 3f53035db7c2..237a9642f814 100644
--- a/www/p5-HTML-Form/Makefile
+++ b/www/p5-HTML-Form/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-URI>=1.10:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTML::Form.3
diff --git a/www/p5-HTTP-Cookies/Makefile b/www/p5-HTTP-Cookies/Makefile
index 74533060b338..84201914cda2 100644
--- a/www/p5-HTTP-Cookies/Makefile
+++ b/www/p5-HTTP-Cookies/Makefile
@@ -18,6 +18,8 @@ RUN_DEPENDS= p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date \
p5-HTTP-Message>=6:${PORTSDIR}/www/p5-HTTP-Message
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTTP::Cookies.3 \
diff --git a/www/p5-HTTP-Daemon/Makefile b/www/p5-HTTP-Daemon/Makefile
index c6a52bf3c837..92a4afc23a11 100644
--- a/www/p5-HTTP-Daemon/Makefile
+++ b/www/p5-HTTP-Daemon/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date \
p5-LWP-MediaTypes>=6:${PORTSDIR}/www/p5-LWP-MediaTypes
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTTP::Daemon.3
diff --git a/www/p5-HTTP-Date/Makefile b/www/p5-HTTP-Date/Makefile
index 1651b2cc68a0..7a87f04d89bd 100644
--- a/www/p5-HTTP-Date/Makefile
+++ b/www/p5-HTTP-Date/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Conversion routines for the HTTP protocol date formats
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTTP::Date.3
diff --git a/www/p5-HTTP-Message/Makefile b/www/p5-HTTP-Message/Makefile
index 3a0564ea3289..c2e6203cdba5 100644
--- a/www/p5-HTTP-Message/Makefile
+++ b/www/p5-HTTP-Message/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
p5-URI>=1.10:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTTP::Config.3 \
diff --git a/www/p5-HTTP-Negotiate/Makefile b/www/p5-HTTP-Negotiate/Makefile
index 57dd834b839c..d8cd29b9b07f 100644
--- a/www/p5-HTTP-Negotiate/Makefile
+++ b/www/p5-HTTP-Negotiate/Makefile
@@ -17,6 +17,8 @@ COMMENT= Implementation of the HTTP content negotiation algorithm
RUN_DEPENDS= p5-HTTP-Message>=6:${PORTSDIR}/www/p5-HTTP-Message
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= HTTP::Negotiate.3
diff --git a/www/p5-LWP-MediaTypes/Makefile b/www/p5-LWP-MediaTypes/Makefile
index c254f975d9b7..5c73522a8848 100644
--- a/www/p5-LWP-MediaTypes/Makefile
+++ b/www/p5-LWP-MediaTypes/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Guess media type for a file or a URL
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= LWP::MediaTypes.3
diff --git a/www/p5-WWW-RobotRules/Makefile b/www/p5-WWW-RobotRules/Makefile
index e890fec8fded..bd9a31eee85a 100644
--- a/www/p5-WWW-RobotRules/Makefile
+++ b/www/p5-WWW-RobotRules/Makefile
@@ -18,6 +18,8 @@ RUN_DEPENDS= p5-URI>=1.10:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
+CONFLICTS= p5-libwww-5*
+
PERL_CONFIGURE= yes
MAN3= WWW::RobotRules.3 \