aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-16 13:55:15 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-16 13:55:15 +0000
commitdaa5ddad4ae6cc63f0507d44e4a7729fc1963bcb (patch)
tree93a87087b181a6ce8f797feac0f8b4529d7d4cd2 /www
parent55cd7af66ea087baa1cfe46eb203a46514f24733 (diff)
downloadports-daa5ddad4ae6cc63f0507d44e4a7729fc1963bcb.tar.gz
ports-daa5ddad4ae6cc63f0507d44e4a7729fc1963bcb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer/Makefile54
-rw-r--r--www/p5-Dancer/distinfo3
-rw-r--r--www/p5-Dancer/pkg-descr3
-rw-r--r--www/p5-Dancer/pkg-plist56
5 files changed, 117 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 587b0572dddf..1954d24f6696 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -884,6 +884,7 @@
SUBDIR += p5-Continuity
SUBDIR += p5-Corona
SUBDIR += p5-DBIx-Class-HTMLWidget
+ SUBDIR += p5-Dancer
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-FAQ-OMatic
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
new file mode 100644
index 000000000000..61ac14992546
--- /dev/null
+++ b/www/p5-Dancer/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: Dancer
+# Date created: 16 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer
+PORTVERSION= 1.175
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUKRIA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for minimal-effort oriented web application framework
+
+RUN_DEPENDS= \
+ p5-HTTP-Body>0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Server-Simple-PSGI>=0.11:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
+ p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dancer.1
+MAN3= Dancer.3 \
+ Dancer::Config.3 \
+ Dancer::Cookbook.3 \
+ Dancer::Deployment.3 \
+ Dancer::Engine.3 \
+ Dancer::Error.3 \
+ Dancer::HTTP.3 \
+ Dancer::Logger.3 \
+ Dancer::ModuleLoader.3 \
+ Dancer::Plugin.3 \
+ Dancer::Request.3 \
+ Dancer::Request::Upload.3 \
+ Dancer::Route::Cache.3 \
+ Dancer::Serializer.3 \
+ Dancer::Serializer::JSON.3 \
+ Dancer::Serializer::Mutable.3 \
+ Dancer::Serializer::YAML.3 \
+ Dancer::Session.3 \
+ Dancer::Session::Abstract.3 \
+ Dancer::Session::Simple.3 \
+ Dancer::Session::YAML.3 \
+ Dancer::Template.3 \
+ Dancer::Template::Abstract.3 \
+ Dancer::Template::Simple.3 \
+ Dancer::Template::TemplateToolkit.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer/distinfo b/www/p5-Dancer/distinfo
new file mode 100644
index 000000000000..27de1eb29a34
--- /dev/null
+++ b/www/p5-Dancer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Dancer-1.175.tar.gz) = 4a1e70eda6a261713dd02d0bf1b342ab
+SHA256 (Dancer-1.175.tar.gz) = 8874cf84e59e323383aad9da9071a9a703241631ce18bfc6434047a4d5002386
+SIZE (Dancer-1.175.tar.gz) = 96616
diff --git a/www/p5-Dancer/pkg-descr b/www/p5-Dancer/pkg-descr
new file mode 100644
index 000000000000..5fe538eb02d1
--- /dev/null
+++ b/www/p5-Dancer/pkg-descr
@@ -0,0 +1,3 @@
+A minimal-effort oriented web application framework.
+
+WWW: http://search.cpan.org/dist/Dancer/
diff --git a/www/p5-Dancer/pkg-plist b/www/p5-Dancer/pkg-plist
new file mode 100644
index 000000000000..a8dabf8a83f6
--- /dev/null
+++ b/www/p5-Dancer/pkg-plist
@@ -0,0 +1,56 @@
+bin/dancer
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/.packlist
+%%SITE_PERL%%/Dancer.pm
+%%SITE_PERL%%/Dancer/Config.pm
+%%SITE_PERL%%/Dancer/Cookbook.pod
+%%SITE_PERL%%/Dancer/Cookie.pm
+%%SITE_PERL%%/Dancer/Cookies.pm
+%%SITE_PERL%%/Dancer/Deployment.pod
+%%SITE_PERL%%/Dancer/Engine.pm
+%%SITE_PERL%%/Dancer/Error.pm
+%%SITE_PERL%%/Dancer/FileUtils.pm
+%%SITE_PERL%%/Dancer/GetOpt.pm
+%%SITE_PERL%%/Dancer/HTTP.pm
+%%SITE_PERL%%/Dancer/Handler.pm
+%%SITE_PERL%%/Dancer/Handler/PSGI.pm
+%%SITE_PERL%%/Dancer/Handler/Standalone.pm
+%%SITE_PERL%%/Dancer/Helpers.pm
+%%SITE_PERL%%/Dancer/Logger.pm
+%%SITE_PERL%%/Dancer/Logger/Abstract.pm
+%%SITE_PERL%%/Dancer/Logger/File.pm
+%%SITE_PERL%%/Dancer/ModuleLoader.pm
+%%SITE_PERL%%/Dancer/Object.pm
+%%SITE_PERL%%/Dancer/Plugin.pm
+%%SITE_PERL%%/Dancer/Renderer.pm
+%%SITE_PERL%%/Dancer/Request.pm
+%%SITE_PERL%%/Dancer/Request/Upload.pm
+%%SITE_PERL%%/Dancer/Response.pm
+%%SITE_PERL%%/Dancer/Route.pm
+%%SITE_PERL%%/Dancer/Route/Builder.pm
+%%SITE_PERL%%/Dancer/Route/Cache.pm
+%%SITE_PERL%%/Dancer/Route/Registry.pm
+%%SITE_PERL%%/Dancer/Serializer.pm
+%%SITE_PERL%%/Dancer/Serializer/Abstract.pm
+%%SITE_PERL%%/Dancer/Serializer/Dumper.pm
+%%SITE_PERL%%/Dancer/Serializer/JSON.pm
+%%SITE_PERL%%/Dancer/Serializer/Mutable.pm
+%%SITE_PERL%%/Dancer/Serializer/XML.pm
+%%SITE_PERL%%/Dancer/Serializer/YAML.pm
+%%SITE_PERL%%/Dancer/Session.pm
+%%SITE_PERL%%/Dancer/Session/Abstract.pm
+%%SITE_PERL%%/Dancer/Session/Simple.pm
+%%SITE_PERL%%/Dancer/Session/YAML.pm
+%%SITE_PERL%%/Dancer/SharedData.pm
+%%SITE_PERL%%/Dancer/Template.pm
+%%SITE_PERL%%/Dancer/Template/Abstract.pm
+%%SITE_PERL%%/Dancer/Template/Simple.pm
+%%SITE_PERL%%/Dancer/Template/TemplateToolkit.pm
+@dirrm %%SITE_PERL%%/Dancer/Template
+@dirrm %%SITE_PERL%%/Dancer/Session
+@dirrm %%SITE_PERL%%/Dancer/Serializer
+@dirrm %%SITE_PERL%%/Dancer/Route
+@dirrm %%SITE_PERL%%/Dancer/Request
+@dirrm %%SITE_PERL%%/Dancer/Logger
+@dirrm %%SITE_PERL%%/Dancer/Handler
+@dirrm %%SITE_PERL%%/Dancer
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer