aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /www
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/encompass/Makefile2
-rw-r--r--www/galeon/Makefile8
-rw-r--r--www/galeon2/Makefile8
-rw-r--r--www/gtkhtml/Makefile2
-rw-r--r--www/gtkhtml3/Makefile2
-rw-r--r--www/gtkhtml38/Makefile2
-rw-r--r--www/kannel/Makefile2
-rw-r--r--www/kdewebdev/Makefile2
-rw-r--r--www/kdewebdev4/Makefile2
-rw-r--r--www/libgtkhtml/Makefile2
-rw-r--r--www/peacock/Makefile2
-rw-r--r--www/quanta/Makefile2
-rw-r--r--www/screem-devel/Makefile2
-rw-r--r--www/screem/Makefile2
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid23/Makefile2
-rw-r--r--www/squid24/Makefile2
-rw-r--r--www/squid25/Makefile2
-rw-r--r--www/squid26/Makefile2
-rw-r--r--www/squid27/Makefile2
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid31/Makefile2
22 files changed, 28 insertions, 28 deletions
diff --git a/www/encompass/Makefile b/www/encompass/Makefile
index e5ddf337de2c..afcb392d4b65 100644
--- a/www/encompass/Makefile
+++ b/www/encompass/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 674bd58ef19f..4a42e13b96bf 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -39,8 +39,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT -D_THREAD_SAFE -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread ${GCC_R_LIB}"
+ -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
.if exists(/usr/lib/libgcc_r.a)
GCC_R_LIB= -lgcc_r
@@ -56,12 +56,12 @@ post-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|-lpthread|-pthread|g'
+ s|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 674bd58ef19f..4a42e13b96bf 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -39,8 +39,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT -D_THREAD_SAFE -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread ${GCC_R_LIB}"
+ -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
.if exists(/usr/lib/libgcc_r.a)
GCC_R_LIB= -lgcc_r
@@ -56,12 +56,12 @@ post-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|-lpthread|-pthread|g'
+ s|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index 18ad5f791f56..6b045d0f6e7b 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index 18ad5f791f56..6b045d0f6e7b 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index 18ad5f791f56..6b045d0f6e7b 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index ea0e18d85cfd..09cdbcdd3d8f 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
USE_AUTOCONF= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/gateway-${PORTVERSION}/
-CFLAGS+= -pthread
+CFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS+= --with-malloc=native
do-install:
diff --git a/www/kdewebdev/Makefile b/www/kdewebdev/Makefile
index fd6556d7ba6c..58217d55e780 100644
--- a/www/kdewebdev/Makefile
+++ b/www/kdewebdev/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc -pthread"
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index fd6556d7ba6c..58217d55e780 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc -pthread"
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/libgtkhtml/Makefile b/www/libgtkhtml/Makefile
index 18ad5f791f56..6b045d0f6e7b 100644
--- a/www/libgtkhtml/Makefile
+++ b/www/libgtkhtml/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/peacock/Makefile b/www/peacock/Makefile
index 159a473acc66..d4276efbe6b9 100644
--- a/www/peacock/Makefile
+++ b/www/peacock/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/www/quanta/Makefile b/www/quanta/Makefile
index fd6556d7ba6c..58217d55e780 100644
--- a/www/quanta/Makefile
+++ b/www/quanta/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc -pthread"
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index 51fa9d9fc26c..f1a4460143cc 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --with-gnomevfs
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\@GNOME_DATA_PREFIX\@|\$$\(datadir\)|g ; \
diff --git a/www/screem/Makefile b/www/screem/Makefile
index 51fa9d9fc26c..f1a4460143cc 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --with-gnomevfs
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\@GNOME_DATA_PREFIX\@|\$$\(datadir\)|g ; \
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid23/Makefile b/www/squid23/Makefile
index 0421718cc61a..8fe80a28be6c 100644
--- a/www/squid23/Makefile
+++ b/www/squid23/Makefile
@@ -98,7 +98,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
cd ${WRKSRC}/src; make install-pinger
diff --git a/www/squid24/Makefile b/www/squid24/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid24/Makefile
+++ b/www/squid24/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 616414d6d357..3a5657df0b45 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -93,7 +93,7 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-heap-replacement
post-extract:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
# I don't think many people use the pinger nowadays, and if you