aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2000-05-15 11:53:29 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2000-05-15 11:53:29 +0000
commit9251f84302c3ae058966c919e6f284b8524a1849 (patch)
tree2e6fe5cc075c4bd81f4a8a7ff93cacf369a16bba /www
parent3f1d3e06a2ad3115c92011685d53ee4442122c54 (diff)
downloadports-9251f84302c3ae058966c919e6f284b8524a1849.tar.gz
ports-9251f84302c3ae058966c919e6f284b8524a1849.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/scripts/configure.php46
-rw-r--r--www/mod_php4/scripts/configure.php46
-rw-r--r--www/mod_php5/scripts/configure.php46
3 files changed, 75 insertions, 63 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index a323a432710e..8f3e797a7bae 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -33,22 +31,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -203,6 +202,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index ac54e5f9076c..4f2b323c19f5 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -31,22 +29,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -187,6 +186,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index ac54e5f9076c..4f2b323c19f5 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -31,22 +29,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -187,6 +186,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done