aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 20:58:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 20:58:51 +0000
commit946b667e9597cabeeb7aacdc1f8046e406217956 (patch)
tree42cf5513c895cb42f6f422474820902c94ae6ad6 /www
parent7dd847ea0baa124b6a089cc6f65fa4d49374f4d1 (diff)
downloadports-946b667e9597cabeeb7aacdc1f8046e406217956.tar.gz
ports-946b667e9597cabeeb7aacdc1f8046e406217956.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/nanoblogger/Makefile6
-rw-r--r--www/nanoblogger/distinfo4
-rw-r--r--www/nanoblogger/files/patch-nb45
-rw-r--r--www/nanoblogger/pkg-descr31
4 files changed, 50 insertions, 36 deletions
diff --git a/www/nanoblogger/Makefile b/www/nanoblogger/Makefile
index c2fb228427fe..f4e4ea3c73b8 100644
--- a/www/nanoblogger/Makefile
+++ b/www/nanoblogger/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= nanoblogger
-PORTVERSION= 3.1
+PORTVERSION= 3.2.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small weblog engine for the UNIX command line
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_REINPLACE= yes
NO_BUILD= yes
@@ -27,7 +27,7 @@ PORTDOCS= *
.endif
post-patch:
- @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/nb
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/nb
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nb ${PREFIX}/bin
diff --git a/www/nanoblogger/distinfo b/www/nanoblogger/distinfo
index e774b59e85cd..1de484920642 100644
--- a/www/nanoblogger/distinfo
+++ b/www/nanoblogger/distinfo
@@ -1,2 +1,2 @@
-MD5 (nanoblogger-3.1.tar.gz) = 7b8eba52ded4849953c88f1747b97f9d
-SIZE (nanoblogger-3.1.tar.gz) = 51293
+MD5 (nanoblogger-3.2.3.tar.gz) = bd9f5f9d48b9b666f7bd03c76d90a724
+SIZE (nanoblogger-3.2.3.tar.gz) = 54672
diff --git a/www/nanoblogger/files/patch-nb b/www/nanoblogger/files/patch-nb
index aa06aeb9f6ed..d421db2bf5ec 100644
--- a/www/nanoblogger/files/patch-nb
+++ b/www/nanoblogger/files/patch-nb
@@ -1,26 +1,35 @@
---- nb.orig Fri Nov 12 23:28:37 2004
-+++ nb Fri Nov 12 23:29:46 2004
+--- nb.orig Tue Jul 5 10:49:45 2005
++++ nb Tue Jul 5 10:51:56 2005
@@ -1,4 +1,4 @@
-#! /bin/bash
-+#! /usr/bin/env bash
++#!/usr/bin/env bash
############################################################
- # NanoBlogger 3.0 Copyright 2004 n1xt3r (Kevin R. Wood) #
+ # NanoBlogger 3.2.3 Copyright 2005 n1xt3r (Kevin R. Wood) #
############################################################
-@@ -10,7 +10,7 @@
- VERSION="3.0"
+@@ -7,7 +7,7 @@
+ VERSION="3.2.3"
- # nanoblogger's install directory.
--BASE_DIR=`dirname $0`
-+BASE_DIR='%%PREFIX%%/share/nanoblogger'
+ # nanoblogger's base install directory.
+-NB_BASE_DIR=`dirname $0`
++NB_BASE_DIR="%%PREFIX%%/share/nanoblogger"
# create a semi ISO 8601 formatted timestamp for archives
# used explicitly, please don't edit unless you know what you're doing.
-@@ -985,7 +985,7 @@
- [ $# -gt 1 ] && argument=$2
- bad_argument=$1
- # always load global configs
-- . "$BASE_DIR"/nb.conf
-+ . %%PREFIX%%/etc/nb.conf
- # check for user's .nb.conf in their home directory
- [ -f "$HOME/.nb.conf" ] && . "$HOME/.nb.conf"
- case "$1" in
+@@ -67,7 +67,7 @@
+ # set deprecated BASE_DIR for temporary compatibility
+ BASE_DIR="$NB_BASE_DIR"
+ # always load global configs
+-[ -f "$NB_BASE_DIR/nb.conf" ] && . "$NB_BASE_DIR/nb.conf"
++[ -f "%%PREFIX%%/etc/nb.conf" ] && . "%%PREFIX%%/etc/nb.conf"
+ # check for user's .nb.conf in their home directory
+ [ -f "$HOME/.nb.conf" ] && . "$HOME/.nb.conf"
+ # allow user specified weblog directories
+@@ -1070,7 +1070,7 @@
+ nb_msg "copying default weblog files ..."
+ # copy default files and directories
+ cp "$NB_BASE_DIR"/default/*.* "$BLOG_DIR"
+- for weblog_dir in "$NB_BASE_DIR"/default/*/; do
++ for weblog_dir in "$NB_BASE_DIR"/default/*; do
+ cp -R "$weblog_dir" "$BLOG_DIR"
+ done
+ # create some critical empty directories
diff --git a/www/nanoblogger/pkg-descr b/www/nanoblogger/pkg-descr
index d469314bdab8..e319185f0ffb 100644
--- a/www/nanoblogger/pkg-descr
+++ b/www/nanoblogger/pkg-descr
@@ -4,21 +4,26 @@ uses common UNIX tools such as cat, grep and sed.
Features include:
* intuitive commandline interface
* support for multiple weblogs
+ * support for multiple categories
* easy editing and management of entries
* archiving by category, entry, and month
- * category support
- * permalinks
- * RSS syndication (comes with RSS 1.0 (RDF) format)
- * a fully functional web site, using templates and stylesheets for easy
- customization (you're looking at it!)
+ * pagination
+ * permanent links
+ * RSS syndication (comes with RSS 1.0 and 2.0 formats)
+ * Atom syndication (comes with 0.3 format)
+ * templates and CSS style sheets for full control of appearance
* placeholders for easy template manipulation
- * plugins for calendar, recent entries, weblog status, etc.
+ * plugins for calendar, recent entries, weblog status, fortunes, etc.
* auto-formatting, e.g. line breaks translate to HTML
- * parts for extensibility (e.g. news.htm, 2003-06.htm)
- * per-weblog configuration via a seperate config file (blog.conf)
- * no dependency on any javascript, server-side scripting, or server-side
- includes
- * no need for MySQL or any other special database (uses flat-file)
- * some small effort at shell portability
+ * support for relative and absolute links
+ * extensibility through reusability
+ * global configuration to set defaults (nb.conf)
+ * per-weblog configuration to override global defaults (blog.conf)
+ * intelligent build system, only rebuilds relative parts for a modified entry
+ * simple cache system, for faster content generation
+ * auto-detection of weblog from current directory
+ * no dependency on any java-script, server-side scripting, or server-side includes
+ * no dependency on any special database (uses flat-file)
+ * multi-platform portability (or at least wherever there's bash and the required commands)
-WWW: http://home.columbus.rr.com/n1xt3r/nanoblogger/
+WWW: http://nanoblogger.sourceforge.net/