aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-03-08 03:39:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-03-08 03:39:19 +0000
commit89274f141e53a9f6fe13db13771eef98ebf2b8a0 (patch)
treea278ab6ed0156e02dd0f755be04d10c0b14b657e /www
parent6e580af3a72cea1d0d895c62a8c9c3b30d3c885c (diff)
downloadports-89274f141e53a9f6fe13db13771eef98ebf2b8a0.tar.gz
ports-89274f141e53a9f6fe13db13771eef98ebf2b8a0.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/slash/Makefile2
-rw-r--r--www/slash/files/patch-Makefile31
2 files changed, 30 insertions, 3 deletions
diff --git a/www/slash/Makefile b/www/slash/Makefile
index 04c05e2b2cbf..f46fe02419e1 100644
--- a/www/slash/Makefile
+++ b/www/slash/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-D
RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
-BROKEN= Incorrect pkg-plist
+MAKE_ARGS+= SLASH_PREFIX=${PREFIX}/slash
DOCS= README INSTALL
diff --git a/www/slash/files/patch-Makefile b/www/slash/files/patch-Makefile
index d4b5b649434b..b508e3654805 100644
--- a/www/slash/files/patch-Makefile
+++ b/www/slash/files/patch-Makefile
@@ -1,5 +1,32 @@
---- Makefile.orig Mon Mar 18 19:22:59 2002
-+++ Makefile Mon Mar 18 19:22:25 2002
+--- Makefile.orig Wed Jul 3 17:22:34 2002
++++ Makefile Mon Mar 7 09:50:44 2005
+@@ -62,7 +62,7 @@
+ slash:
+ @echo "=== INSTALLING SLASH MODULES ==="
+ @if [ ! "$(RPM)" ] ; then \
+- (cd Slash; $(PERL) Makefile.PL; make install UNINST=1); \
++ (cd Slash; $(PERL) Makefile.PL PREFIX=$(PREFIX); make install UNINST=1); \
+ else \
+ echo " - Performing an RPM build"; \
+ (cd Slash; $(PERL) Makefile.PL INSTALLSITEARCH=$(INSTALLSITEARCH) INSTALLSITELIB=$(INSTALLSITELIB) INSTALLMAN3DIR=$(INSTALLMAN3DIR); make install UNINST=1); \
+@@ -76,7 +76,7 @@
+ echo == $$PWD; \
+ if [ -f Makefile.PL ]; then \
+ if [ ! "$(RPM)" ] ; then \
+- $(PERL) Makefile.PL; \
++ $(PERL) Makefile.PL PREFIX=$(PREFIX); \
+ make install UNINST=1;\
+ else \
+ echo " - Performing an RPM build."; \
+@@ -86,7 +86,7 @@
+ fi); \
+ done)
+
+-all: install
++all:
+
+ install: slash plugins
+
@@ -167,15 +167,11 @@
if [ -d $(INIT) ]; then \
init=$(INIT); \