aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-10-30 15:32:53 +0000
committerClement Laforet <clement@FreeBSD.org>2004-10-30 15:32:53 +0000
commitfa4c5a2a41bacb877edcd0e690da4d3f01b1d2ce (patch)
tree1185de910199bfcd40cb55b22686769b5c7422d0 /www
parent7ea58dff91e2aed92b072427e540fd65cdeb8f54 (diff)
downloadports-fa4c5a2a41bacb877edcd0e690da4d3f01b1d2ce.tar.gz
ports-fa4c5a2a41bacb877edcd0e690da4d3f01b1d2ce.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c50
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c50
4 files changed, 102 insertions, 2 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index ab6256cf320c..63695e3a274b 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.52
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo
diff --git a/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c b/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c
new file mode 100644
index 000000000000..e2df23d4921f
--- /dev/null
+++ b/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c
@@ -0,0 +1,50 @@
+Index: modules/experimental/util_ldap_cache_mgr.c
+===================================================================
+RCS file: /home/cvs/httpd-2.0/modules/experimental/Attic/util_ldap_cache_mgr.c,v
+retrieving revision 1.3.2.13
+diff -u -r1.3.2.13 util_ldap_cache_mgr.c
+--- modules/experimental/util_ldap_cache_mgr.c 23 Sep 2004 16:55:37 -0000 1.3.2.13
++++ modules/experimental/util_ldap_cache_mgr.c 24 Sep 2004 16:40:23 -0000
+@@ -173,7 +173,7 @@
+ void util_ald_cache_purge(util_ald_cache_t *cache)
+ {
+ unsigned long i;
+- util_cache_node_t *p, *q;
++ util_cache_node_t *p, *q, **pp;
+ apr_time_t t;
+
+ if (!cache)
+@@ -184,7 +184,8 @@
+ cache->numpurges++;
+
+ for (i=0; i < cache->size; ++i) {
+- p = cache->nodes[i];
++ pp = cache->nodes + i;
++ p = *pp;
+ while (p != NULL) {
+ if (p->add_time < cache->marktime) {
+ q = p->next;
+@@ -192,10 +193,11 @@
+ util_ald_free(cache, p);
+ cache->numentries--;
+ cache->npurged++;
+- p = q;
++ p = *pp = q;
+ }
+ else {
+- p = p->next;
++ pp = &(p->next);
++ p = *pp;
+ }
+ }
+ }
+@@ -687,6 +689,9 @@
+ break;
+ }
+
++ }
++ else {
++ buf = "";
+ }
+ }
+ else {
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index ab6256cf320c..63695e3a274b 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.52
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo
diff --git a/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c b/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c
new file mode 100644
index 000000000000..e2df23d4921f
--- /dev/null
+++ b/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c
@@ -0,0 +1,50 @@
+Index: modules/experimental/util_ldap_cache_mgr.c
+===================================================================
+RCS file: /home/cvs/httpd-2.0/modules/experimental/Attic/util_ldap_cache_mgr.c,v
+retrieving revision 1.3.2.13
+diff -u -r1.3.2.13 util_ldap_cache_mgr.c
+--- modules/experimental/util_ldap_cache_mgr.c 23 Sep 2004 16:55:37 -0000 1.3.2.13
++++ modules/experimental/util_ldap_cache_mgr.c 24 Sep 2004 16:40:23 -0000
+@@ -173,7 +173,7 @@
+ void util_ald_cache_purge(util_ald_cache_t *cache)
+ {
+ unsigned long i;
+- util_cache_node_t *p, *q;
++ util_cache_node_t *p, *q, **pp;
+ apr_time_t t;
+
+ if (!cache)
+@@ -184,7 +184,8 @@
+ cache->numpurges++;
+
+ for (i=0; i < cache->size; ++i) {
+- p = cache->nodes[i];
++ pp = cache->nodes + i;
++ p = *pp;
+ while (p != NULL) {
+ if (p->add_time < cache->marktime) {
+ q = p->next;
+@@ -192,10 +193,11 @@
+ util_ald_free(cache, p);
+ cache->numentries--;
+ cache->npurged++;
+- p = q;
++ p = *pp = q;
+ }
+ else {
+- p = p->next;
++ pp = &(p->next);
++ p = *pp;
+ }
+ }
+ }
+@@ -687,6 +689,9 @@
+ break;
+ }
+
++ }
++ else {
++ buf = "";
+ }
+ }
+ else {