aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-06-24 05:10:41 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-06-24 05:10:41 +0000
commit8e0b593b9eb299201f6e5e59f07796e35947d1ed (patch)
treef422e642df9faab84b7c562bd3084f6dbaca72ac /www
parent137b3a039638f9bafc3f22bb6d124c5c413f4f9b (diff)
downloadports-8e0b593b9eb299201f6e5e59f07796e35947d1ed.tar.gz
ports-8e0b593b9eb299201f6e5e59f07796e35947d1ed.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/gecko-mediaplayer/Makefile18
-rw-r--r--www/gecko-mediaplayer/distinfo3
-rw-r--r--www/gecko-mediaplayer/files/patch-configure11
3 files changed, 10 insertions, 22 deletions
diff --git a/www/gecko-mediaplayer/Makefile b/www/gecko-mediaplayer/Makefile
index 77df822fd33f..a2932c84d37c 100644
--- a/www/gecko-mediaplayer/Makefile
+++ b/www/gecko-mediaplayer/Makefile
@@ -3,32 +3,31 @@
PORTNAME= gecko-mediaplayer
PORTVERSION= 1.0.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www multimedia gnome
-MASTER_SITES= https://pkgs.rpmfusion.org/repo/pkgs/free/gecko-mediaplayer/gecko-mediaplayer-1.0.9.tar.gz/69b50ecbbbf34ca6d980a477345dbd40/
+MASTER_SITES= https://pkgs.rpmfusion.org/repo/pkgs/free/gecko-mediaplayer/gecko-mediaplayer-1.0.9.tar.gz/69b50ecbbbf34ca6d980a477345dbd40/ \
+ LOCAL/tobik:npapi
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ npapi-headers${EXTRACT_SUFX}:npapi
MAINTAINER= ports@FreeBSD.org
COMMENT= Multimedia browser plugin for Gecko based browsers
LICENSE= GPLv2
-BROKEN= Does not specify gecko type to use
-
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libnspr4.so:devel/nspr \
libcurl.so:ftp/curl \
libgmlib.so:multimedia/gmtk
RUN_DEPENDS= gnome-mplayer:multimedia/gnome-mplayer
-USES= compiler:c++11-lang gecko gettext pkgconfig webplugin:native
+USES= compiler:c++11-lang gettext gnome localbase pkgconfig webplugin:native
USE_GNOME= glib20
USE_CXXSTD= c++11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-schemas-install \
--with-plugin_dir="${WEBPLUGIN_DIR}"
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= GECKO_CFLAGS="-I${WRKDIR}/npapi-headers -DHAVE_NSPR"
OPTIONS_DEFINE= CACHE DOCS
OPTIONS_DEFAULT= CACHE
@@ -43,9 +42,6 @@ WEBPLUGIN_FILES+= ${PORTNAME}-${p}.so
post-patch:
@${REINPLACE_CMD} -e \
- 's|-std=c++11|| ; \
- s|-ldl||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
'/COPYING\\/d ; \
/INSTALL\\/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
diff --git a/www/gecko-mediaplayer/distinfo b/www/gecko-mediaplayer/distinfo
index eea620370bee..ef273fc6cd92 100644
--- a/www/gecko-mediaplayer/distinfo
+++ b/www/gecko-mediaplayer/distinfo
@@ -1,2 +1,5 @@
+TIMESTAMP = 1529800930
SHA256 (gecko-mediaplayer-1.0.9.tar.gz) = 212a0a87e35da9ed944f5fb827552e9978fd3ea051da89554da5ef3934d4c2a5
SIZE (gecko-mediaplayer-1.0.9.tar.gz) = 271917
+SHA256 (npapi-headers.tar.gz) = 625d86955aef95c7a0a4c192bb51a1e7833d30c2d53e390d07f97abd835744f8
+SIZE (npapi-headers.tar.gz) = 15637
diff --git a/www/gecko-mediaplayer/files/patch-configure b/www/gecko-mediaplayer/files/patch-configure
deleted file mode 100644
index 722a67774b55..000000000000
--- a/www/gecko-mediaplayer/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2010-02-24 16:19:09.000000000 +0100
-+++ configure 2010-06-14 22:12:46.000000000 +0200
-@@ -8710,7 +8710,7 @@
- if test "${with_xulrunner_sdk+set}" = set; then
- withval=$with_xulrunner_sdk;
- XULRUNNER_SDK_PREFIX=$with_xulrunner_sdk
-- GECKO_CFLAGS="-I$XULRUNNER_SDK_PREFIX/include -I$XULRUNNER_SDK_PREFIX/include/plugin -I$XULRUNNER_SDK_PREFIX/include/nspr -I$XULRUNNER_SDK_PREFIX/include/xpcom -I$XULRUNNER_SDK_PREFIX/include/string -I$XULRUNNER_SDK_PREFIX/include/java"
-+ GECKO_CFLAGS="-I$XULRUNNER_SDK_PREFIX/libxul -I$XULRUNNER_SDK_PREFIX/nspr"
- GECKO_LIBS="-L$XULRUNNER_SDK_PREFIX/lib -lxpcomglue_s -lxul -lxpcom -lplds4 -lplc4 -lnspr4 -lpthread -ldl"
- # Check whether --enable-new-libxul was given.
- if test "${enable_new_libxul+set}" = set; then