aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-19 10:30:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-19 10:30:08 +0000
commit95d4601a97bc20508aadd69c2ef898c12a6352a9 (patch)
tree2a701f02f55c29434f330e4f9a178f840a92fc7c /www
parent8209bb1e1c41f8b38cd50cb309cfc06444031bc9 (diff)
downloadports-95d4601a97bc20508aadd69c2ef898c12a6352a9.tar.gz
ports-95d4601a97bc20508aadd69c2ef898c12a6352a9.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/libhpack/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/www/libhpack/Makefile b/www/libhpack/Makefile
index 6c185feb7ac9..fb49f5071007 100644
--- a/www/libhpack/Makefile
+++ b/www/libhpack/Makefile
@@ -20,11 +20,7 @@ BROKEN_armv7= fails to compile: Can't define TIME_MAX #'
LIB_DEPENDS= libcheck.so:devel/check
-CMAKE_ARGS= -DBUILD_DOCS=OFF \
- -DBUILD_TESTS=OFF \
- -DENABLE_GCOV=OFF \
- -DLINUX=ON \
- -DUSE_VALGRIND=OFF
+CMAKE_OFF= BUILD_DOCS BUILD_TESTS ENABLE_GCOV USE_VALGRIND
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USES= cmake pathfix pkgconfig python:2.7,build shebangfix
@@ -44,5 +40,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|STATIC|SHARED|' ${WRKSRC}/libchula/CMakeLists.txt ${WRKSRC}/libhpack/CMakeLists.txt
@${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_LIBDIR}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt ${WRKSRC}/libchula/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|LINUX|BSD|' ${WRKSRC}/libchula-qa/mem_mgr.c
.include <bsd.port.mk>