aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/pclock/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-27 14:51:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-27 14:51:16 +0000
commit7b7c3ad636cea2a2858bc8d04886680aacdcfeeb (patch)
treec211467203140d2b35e4cda644d5a52153ff82ca /x11-clocks/pclock/Makefile
parent7664565a22038237f227ff6d04eba569195324bf (diff)
downloadports-7b7c3ad636cea2a2858bc8d04886680aacdcfeeb.tar.gz
ports-7b7c3ad636cea2a2858bc8d04886680aacdcfeeb.zip
Notes
Diffstat (limited to 'x11-clocks/pclock/Makefile')
-rw-r--r--x11-clocks/pclock/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/x11-clocks/pclock/Makefile b/x11-clocks/pclock/Makefile
index e598f1580fb3..8102b456644e 100644
--- a/x11-clocks/pclock/Makefile
+++ b/x11-clocks/pclock/Makefile
@@ -7,24 +7,29 @@
PORTNAME= pclock
PORTVERSION= 0.13.1
+PORTREVISION= 1
CATEGORIES= x11-clocks windowmaker afterstep
-MASTER_SITES= ftp://ftp.kourakos.com/pub/pclock/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple analog clock program for the Window Maker dock
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig/src
+
USE_X_PREFIX= yes
USE_XPM= yes
+USE_GETOPT_LONG= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" OBJS="Main.o Graphics.o" \
+ INCDIR="-I. -I${X11BASE}/include ${CPPFLAGS}" \
+ LIBDIR="-L${X11BASE}/lib ${LDFLAGS}"
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/pclock ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/pclock/pixmaps && ${CHMOD} a+rx ${PREFIX}/share/pclock/pixmaps
- @${ECHO} "===> Installing sample pixmaps in ${PREFIX}/share/pclock/pixmaps"
- @${INSTALL_DATA} ${WRKSRC}/XPM/*.xpm ${PREFIX}/share/pclock/pixmaps
+post-extract:
+ cd ${WRKSRC} && ${RM} -f getopt*
-post-install:
- @${ECHO} "===> Use 'pclock --help' for usage instructions"
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pclock ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/../XPM/*.xpm ${DATADIR}/pixmaps
.include <bsd.port.mk>