aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/wmtimer/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-28 02:02:43 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-28 02:02:43 +0000
commit0569f5534c0e5b734b31e80dfd61a00385940a90 (patch)
treeedf82ff399d4591e758eae245dcde28b1d80e356 /x11-clocks/wmtimer/Makefile
parent76999372056570c8e22e40b1525ec74b410282ff (diff)
downloadports-0569f5534c0e5b734b31e80dfd61a00385940a90.tar.gz
ports-0569f5534c0e5b734b31e80dfd61a00385940a90.zip
Notes
Diffstat (limited to 'x11-clocks/wmtimer/Makefile')
-rw-r--r--x11-clocks/wmtimer/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/x11-clocks/wmtimer/Makefile b/x11-clocks/wmtimer/Makefile
index 8ad6d582f9e7..3f66ba4b4ea4 100644
--- a/x11-clocks/wmtimer/Makefile
+++ b/x11-clocks/wmtimer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wmtimer
-PORTVERSION= 2.2
+PORTVERSION= 2.3
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://home.dwave.net/~jking/wmtimer/
@@ -18,6 +18,8 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GTK= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.if !defined(BATCH)
HAS_CONFIGURE= yes
@@ -25,14 +27,6 @@ IS_INTERACTIVE= yes
.endif # !BATCH
pre-patch:
- @${PERL} -pi -n \
- -e "s!CFLAGS =! CFLAGS \+=!;" \
- -e "s!-I/usr/lib/glib/include!`${GTK_CONFIG} --cflags` `${GLIB_CONFIG} --cflags`!;" \
- -e "s!-lgtk -lgdk -rdynamic -lgmodule -lglib -ldl!`${GTK_CONFIG} --libs` `${GLIB_CONFIG} --libs`!;" \
- -e "s!/usr/X11R6/lib!${X11BASE}/lib!;" \
- -e "s!/usr/X11R6/include!${X11BASE}/include!;" \
- -e "s!/usr/lib!${LOCALBASE}/lib!;" \
- ${WRKSRC}/Makefile
.if defined(IS_INTERACTIVE)
@${PERL} -pi -ne "s!/bin/bash!${SH}!" ${WRKSRC}/configure
.endif # IS_INTERACTIVE