aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-07 23:40:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-07 23:40:53 +0000
commit1aaf94f34010317ce35510fd8596d770708fad68 (patch)
tree138e3efe1b918cd429b9c0efde07e4e18d2f7108 /x11-clocks
parent4764219faeb6a96b16c6a4fe08b99189ad38ddea (diff)
downloadports-1aaf94f34010317ce35510fd8596d770708fad68.tar.gz
ports-1aaf94f34010317ce35510fd8596d770708fad68.zip
Notes
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/Makefile1
-rw-r--r--x11-clocks/gdesklets-ebichuclock/Makefile38
-rw-r--r--x11-clocks/gdesklets-ebichuclock/distinfo1
-rw-r--r--x11-clocks/gdesklets-ebichuclock/pkg-descr5
-rw-r--r--x11-clocks/gdesklets-ebichuclock/pkg-message9
-rw-r--r--x11-clocks/gdesklets-ebichuclock/pkg-plist11
6 files changed, 65 insertions, 0 deletions
diff --git a/x11-clocks/Makefile b/x11-clocks/Makefile
index 76479f7c1ee7..4b6fa66e334a 100644
--- a/x11-clocks/Makefile
+++ b/x11-clocks/Makefile
@@ -13,6 +13,7 @@
SUBDIR += eyeclock
SUBDIR += gdesklets-clock
SUBDIR += gdesklets-countdown
+ SUBDIR += gdesklets-ebichuclock
SUBDIR += gdesklets-praytime
SUBDIR += glclock
SUBDIR += kdetoys3
diff --git a/x11-clocks/gdesklets-ebichuclock/Makefile b/x11-clocks/gdesklets-ebichuclock/Makefile
new file mode 100644
index 000000000000..c58404ced596
--- /dev/null
+++ b/x11-clocks/gdesklets-ebichuclock/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gdesklets-ebichuclock
+# Date created: 07 January 2004
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ebichuclock
+PORTVERSION= 0.1.1
+CATEGORIES= x11-clocks gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A very simple clock with a small Ebichu picture in it
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets \
+ ${X11BASE}/share/gnome/gdesklets/Sensors/Clock/__init__.py:${PORTSDIR}/x11-clocks/gdesklets-clock
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+
+NAME= ebichuclock
+DATADIR= ${PREFIX}/share/gnome
+PKGMESSAGE= ${WRKDIR}/pkg-message
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; s|%%NAME%%|${NAME}|g' > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
+ @${INSTALL_DATA} ${WRKSRC}/*.display ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/gfx/*.png ${DATADIR}/gdesklets/Displays/${NAME}/gfx/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/gdesklets-ebichuclock/distinfo b/x11-clocks/gdesklets-ebichuclock/distinfo
new file mode 100644
index 000000000000..e89f64c50fb3
--- /dev/null
+++ b/x11-clocks/gdesklets-ebichuclock/distinfo
@@ -0,0 +1 @@
+MD5 (ebichuclock-0.1.1.tar.bz2) = 2a977f8753a1651d22d6b49860d5b1c0
diff --git a/x11-clocks/gdesklets-ebichuclock/pkg-descr b/x11-clocks/gdesklets-ebichuclock/pkg-descr
new file mode 100644
index 000000000000..5d26043d6c80
--- /dev/null
+++ b/x11-clocks/gdesklets-ebichuclock/pkg-descr
@@ -0,0 +1,5 @@
+Ebichuclock is something like emiclock with Ebichu in it.
+Ofcourse the idea is based on our favorite hamster
+(and no i do not mean hamtaro :-)
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/x11-clocks/gdesklets-ebichuclock/pkg-message b/x11-clocks/gdesklets-ebichuclock/pkg-message
new file mode 100644
index 000000000000..ddb9640c7c1e
--- /dev/null
+++ b/x11-clocks/gdesklets-ebichuclock/pkg-message
@@ -0,0 +1,9 @@
+
+To list displays installed by this port:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/%%NAME%%
+
+To add this desklet to your desktop:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/%%NAME%%/<name>.display
+
diff --git a/x11-clocks/gdesklets-ebichuclock/pkg-plist b/x11-clocks/gdesklets-ebichuclock/pkg-plist
new file mode 100644
index 000000000000..3b7773ea451f
--- /dev/null
+++ b/x11-clocks/gdesklets-ebichuclock/pkg-plist
@@ -0,0 +1,11 @@
+share/gnome/gdesklets/Displays/ebichuclock/README
+share/gnome/gdesklets/Displays/ebichuclock/ebichuclock-happy.display
+share/gnome/gdesklets/Displays/ebichuclock/ebichuclock-pie.display
+share/gnome/gdesklets/Displays/ebichuclock/ebichuclock-xface.display
+share/gnome/gdesklets/Displays/ebichuclock/ebichuclock.display
+share/gnome/gdesklets/Displays/ebichuclock/gfx/ebichu0.png
+share/gnome/gdesklets/Displays/ebichuclock/gfx/ebichu1.png
+share/gnome/gdesklets/Displays/ebichuclock/gfx/ebichu2.png
+share/gnome/gdesklets/Displays/ebichuclock/gfx/ebichuclock.png
+@dirrm share/gnome/gdesklets/Displays/ebichuclock/gfx
+@dirrm share/gnome/gdesklets/Displays/ebichuclock