aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /x11-clocks
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/alarm-clock/Makefile3
-rw-r--r--x11-clocks/alarm-clock/files/patch-src__alarm_runner.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/x11-clocks/alarm-clock/Makefile b/x11-clocks/alarm-clock/Makefile
index 261d38cdcadf..a95d413d5588 100644
--- a/x11-clocks/alarm-clock/Makefile
+++ b/x11-clocks/alarm-clock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= alarm-clock
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= x11-clocks deskutils
MASTER_SITES= http://www.alarm-clock.pl/media/distfiles/
@@ -14,7 +15,7 @@ MAINTAINER= romain@FreeBSD.org
COMMENT= Alarm Clock for the GNOME desktop
LIB_DEPENDS= unique-1:${PORTSDIR}/x11-toolkits/unique \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/x11-clocks/alarm-clock/files/patch-src__alarm_runner.c b/x11-clocks/alarm-clock/files/patch-src__alarm_runner.c
new file mode 100644
index 000000000000..a5cd46a75348
--- /dev/null
+++ b/x11-clocks/alarm-clock/files/patch-src__alarm_runner.c
@@ -0,0 +1,11 @@
+--- src/alarm_runner.c.orig 2011-08-12 17:00:32.000000000 +0200
++++ src/alarm_runner.c 2011-08-12 17:01:09.000000000 +0200
+@@ -210,7 +210,7 @@ show_popup(gchar *name)
+ text = g_key_file_get_string(loaded_alarms, name, "PassivePopupText", NULL);
+
+ if (notify != NULL) notify_notification_close(notify, NULL);
+- notify = notify_notification_new_with_status_icon(title, text, NULL, status_icon);
++ notify = notify_notification_new(title, text, NULL);
+
+ notify_notification_set_urgency(notify, type);
+ notify_notification_set_timeout(notify, timeout * 1000);