aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /x11-clocks
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/amor-kde4/Makefile2
-rw-r--r--x11-clocks/kteatime-kde4/Makefile2
-rw-r--r--x11-clocks/kteatime/Makefile2
-rw-r--r--x11-clocks/ktimer-kde4/Makefile2
-rw-r--r--x11-clocks/ktimer/Makefile2
-rw-r--r--x11-clocks/ktux-kde4/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/x11-clocks/amor-kde4/Makefile b/x11-clocks/amor-kde4/Makefile
index 9d969bb6f87c..82b3dc742d04 100644
--- a/x11-clocks/amor-kde4/Makefile
+++ b/x11-clocks/amor-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Small animation which sits on top of active window
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
diff --git a/x11-clocks/kteatime-kde4/Makefile b/x11-clocks/kteatime-kde4/Makefile
index f68c6cf9efc5..198c06f00b8b 100644
--- a/x11-clocks/kteatime-kde4/Makefile
+++ b/x11-clocks/kteatime-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Handy timer for steeping tea
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
diff --git a/x11-clocks/kteatime/Makefile b/x11-clocks/kteatime/Makefile
index 8a22425a21db..2f64c090e029 100644
--- a/x11-clocks/kteatime/Makefile
+++ b/x11-clocks/kteatime/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= x11-clocks kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Handy timer for steeping tea
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash doctools ecm \
i18n iconthemes notifications notifyconfig sonnet textwidgets \
widgetsaddons xmlgui
diff --git a/x11-clocks/ktimer-kde4/Makefile b/x11-clocks/ktimer-kde4/Makefile
index f2e8abe1ff7b..e5e644cc5f13 100644
--- a/x11-clocks/ktimer-kde4/Makefile
+++ b/x11-clocks/ktimer-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Countdown launcher for KDE
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= automoc4 kdelibs
USE_QT= qmake_build moc_build rcc_build uic_build
diff --git a/x11-clocks/ktimer/Makefile b/x11-clocks/ktimer/Makefile
index 8b2d669a1dfc..962538489e2a 100644
--- a/x11-clocks/ktimer/Makefile
+++ b/x11-clocks/ktimer/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= x11-clocks kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Countdown launcher for KDE
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
dbusaddons doctools ecm i18n iconthemes jobwidgets kio \
notifications service widgetsaddons xmlgui
diff --git a/x11-clocks/ktux-kde4/Makefile b/x11-clocks/ktux-kde4/Makefile
index fbf00f183a4b..7f132dd34233 100644
--- a/x11-clocks/ktux-kde4/Makefile
+++ b/x11-clocks/ktux-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Tux-in-a-Spaceship screen saver
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs workspace automoc4
USE_QT= qt3support moc_build qmake_build rcc_build uic_build