aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 14:39:57 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 14:39:57 +0000
commita70065bd454f9f7fd6707cd1baa704f964abf75d (patch)
tree0d09cc1a312bf01d0fa77031220a392a16960528 /x11-clocks
parent8b1c886389b672ae2ba5342f6a95007016b571a4 (diff)
downloadports-a70065bd454f9f7fd6707cd1baa704f964abf75d.tar.gz
ports-a70065bd454f9f7fd6707cd1baa704f964abf75d.zip
x11-clocks/wmfishtime: Remove GTK1 option
x11-toolkits/gtk12 is gone since r488008.
Notes
Notes: svn path=/head/; revision=491817
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/wmfishtime/Makefile24
-rw-r--r--x11-clocks/wmfishtime/files/patch-Makefile8
2 files changed, 12 insertions, 20 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
index 213b25352b2a..9e7243f4ff02 100644
--- a/x11-clocks/wmfishtime/Makefile
+++ b/x11-clocks/wmfishtime/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmfishtime
PORTVERSION= 1.24
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
http://www.sourcefiles.org/Toys/Clocks/
@@ -14,24 +14,16 @@ COMMENT= Time/date applet for WindowMaker with fishes swimming around
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
+USES= gnome pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_XORG= x11
-MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS} -Wall ${GTK_CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- GTK_LIBS="${GTK_LIBS}"
+MAKE_ARGS= CFLAGS="${CPPFLAGS} ${CFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/wmfishtime man/man1/wmfishtime.1.gz
-OPTIONS_SINGLE= TOOLKIT
-OPTIONS_SINGLE_TOOLKIT= GTK1 GTK2
-OPTIONS_DEFAULT= GTK2
-
-GTK1_USE= gnome=gtk12
-GTK1_CPPFLAGS= $$(pkg-config --cflags gdk)
-GTK1_LDFLAGS= $$(pkg-config --libs gdk)
-GTK2_USE= gnome=gtk20
-GTK2_CPPFLAGS= $$(pkg-config --cflags gdk-x11-2.0 x11)
-GTK2_LDFLAGS= $$(pkg-config --libs gdk-x11-2.0 x11) -lm
-TOOLKIT_DESC= GTK Toolkit
+CPPFLAGS+= $$(pkg-config --cflags gdk-x11-2.0 x11)
+LDFLAGS+= $$(pkg-config --libs gdk-x11-2.0 x11) -lm
post-patch:
${REINPLACE_CMD} -E -e 's|1\.23|${PORTVERSION}|g' ${WRKSRC}/fishmon.c ${WRKSRC}/wmfishtime.1
diff --git a/x11-clocks/wmfishtime/files/patch-Makefile b/x11-clocks/wmfishtime/files/patch-Makefile
index ff24164ce6f4..bc17c92d9604 100644
--- a/x11-clocks/wmfishtime/files/patch-Makefile
+++ b/x11-clocks/wmfishtime/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sun May 27 05:49:41 2001
-+++ Makefile Sun Jul 6 20:29:07 2003
-@@ -6,23 +6,21 @@
+--- Makefile.orig 2001-05-26 20:49:41 UTC
++++ Makefile
+@@ -6,23 +6,21 @@ PREFIX = $(DESTDIR)/usr/X11R6
# no user serviceable parts below this line
# optimization cflags
@@ -15,7 +15,7 @@
SHELL = sh
OBJS = fishmon.o
-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
-+LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"`
++LIBS =
INSTALL = -m 755
all: wmfishtime