aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-06 00:06:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-06 00:06:35 +0000
commit005fb957349afb38d01913c7c28af34bde6a642f (patch)
tree54f62bcc823a3e7f8ff62189782e38b0b8922851 /x11-clocks
parent08691ea4fbffc9ede59582e39d037270c763379a (diff)
downloadports-005fb957349afb38d01913c7c28af34bde6a642f.tar.gz
ports-005fb957349afb38d01913c7c28af34bde6a642f.zip
Notes
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/Makefile1
-rw-r--r--x11-clocks/gdesklets-countdown/Makefile49
-rw-r--r--x11-clocks/gdesklets-countdown/distinfo1
-rw-r--r--x11-clocks/gdesklets-countdown/pkg-descr6
-rw-r--r--x11-clocks/gdesklets-countdown/pkg-message17
-rw-r--r--x11-clocks/gdesklets-countdown/pkg-plist16
6 files changed, 90 insertions, 0 deletions
diff --git a/x11-clocks/Makefile b/x11-clocks/Makefile
index d8b1bf2bee0d..db3771be7ed3 100644
--- a/x11-clocks/Makefile
+++ b/x11-clocks/Makefile
@@ -12,6 +12,7 @@
SUBDIR += emiclock
SUBDIR += eyeclock
SUBDIR += gdesklets-clock
+ SUBDIR += gdesklets-countdown
SUBDIR += glclock
SUBDIR += kdetoys3
SUBDIR += mlclock
diff --git a/x11-clocks/gdesklets-countdown/Makefile b/x11-clocks/gdesklets-countdown/Makefile
new file mode 100644
index 000000000000..e1370d4dddeb
--- /dev/null
+++ b/x11-clocks/gdesklets-countdown/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: gdesklets-countdown
+# Date created: 06 January 2004
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= countdown
+PORTVERSION= 0.8
+CATEGORIES= x11-clocks gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-
+DISTNAME= Countdown-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Countdown the remaining time until a configurable date
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+
+NAME= Countdown
+DATADIR= ${PREFIX}/share/gnome
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+ @${WRKSRC}/Install_LTVFontSelector_Sensor.bin --nomsg ${WRKSRC}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/LTVFontSelector/
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/LTVFontSelector/*.py ${DATADIR}/gdesklets/Sensors/LTVFontSelector/
+ @${INSTALL_DATA} ${WRKSRC}/*.display ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/gfx/*.png ${DATADIR}/gdesklets/Displays/${NAME}/gfx/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/LTVFontSelector
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/LTVFontSelector
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/gdesklets-countdown/distinfo b/x11-clocks/gdesklets-countdown/distinfo
new file mode 100644
index 000000000000..c92d0d9820a8
--- /dev/null
+++ b/x11-clocks/gdesklets-countdown/distinfo
@@ -0,0 +1 @@
+MD5 (Countdown-0.8.tar.bz2) = b69ba353eb51342a24b1588190f08431
diff --git a/x11-clocks/gdesklets-countdown/pkg-descr b/x11-clocks/gdesklets-countdown/pkg-descr
new file mode 100644
index 000000000000..49faaa72344c
--- /dev/null
+++ b/x11-clocks/gdesklets-countdown/pkg-descr
@@ -0,0 +1,6 @@
+This desklet allows to countdown the remaining time until a configurable
+date. It then displays a victorious 'Hurrah!', or whatever you set.
+It also provides an increasing counter ('countup' feature), displaying
+the time elapsed from the specified date.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/x11-clocks/gdesklets-countdown/pkg-message b/x11-clocks/gdesklets-countdown/pkg-message
new file mode 100644
index 000000000000..6720f4787b6d
--- /dev/null
+++ b/x11-clocks/gdesklets-countdown/pkg-message
@@ -0,0 +1,17 @@
+##
+To view the README:
+
+ cat %%PREFIX%%/share/gnome/gdesklets/Displays/Countdown/README
+ cat %%PREFIX%%/share/gnome/gdesklets/Sensors/Countdown/README
+
+To view all installed applets:
+
+ ls %%PREFIX%%/share/gnome/gdesklets/Displays
+
+To use those applets:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/Countdown/Countdown.display
+
+NOTE: Be sure to login as your user when you use the gdesklets command,
+ as the configuration will be stored in the ~/.gdesklets/ directory.
+##
diff --git a/x11-clocks/gdesklets-countdown/pkg-plist b/x11-clocks/gdesklets-countdown/pkg-plist
new file mode 100644
index 000000000000..2cf75c0f8eb7
--- /dev/null
+++ b/x11-clocks/gdesklets-countdown/pkg-plist
@@ -0,0 +1,16 @@
+share/gnome/gdesklets/Displays/Countdown/Countdown.display
+share/gnome/gdesklets/Displays/Countdown/README
+share/gnome/gdesklets/Displays/Countdown/gfx/frame.png
+share/gnome/gdesklets/Displays/Countdown/gfx/safari1.png
+share/gnome/gdesklets/Displays/Countdown/gfx/safari2.png
+share/gnome/gdesklets/Displays/Countdown/gfx/safari3.png
+share/gnome/gdesklets/Sensors/Countdown/__init__.py
+share/gnome/gdesklets/Sensors/Countdown/__init__.pyc
+share/gnome/gdesklets/Sensors/Countdown/__init__.pyo
+share/gnome/gdesklets/Sensors/LTVFontSelector/__init__.py
+share/gnome/gdesklets/Sensors/LTVFontSelector/__init__.pyc
+share/gnome/gdesklets/Sensors/LTVFontSelector/__init__.pyo
+@dirrm share/gnome/gdesklets/Sensors/LTVFontSelector
+@dirrm share/gnome/gdesklets/Sensors/Countdown
+@dirrm share/gnome/gdesklets/Displays/Countdown/gfx
+@dirrm share/gnome/gdesklets/Displays/Countdown