aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-08 18:15:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-08 18:15:22 +0000
commitcd4a4eb96a117282c7230ee63ea7ead851473117 (patch)
tree1c3d8ba22799e61fa24f8a5ec921d5a6199d3b7b /x11-clocks
parent5d5b7b6d460e5b8f89f6553120aaa8fda923ef25 (diff)
downloadports-cd4a4eb96a117282c7230ee63ea7ead851473117.tar.gz
ports-cd4a4eb96a117282c7230ee63ea7ead851473117.zip
Notes
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/wmfishtime/Makefile28
-rw-r--r--x11-clocks/wmfishtime/files/patch-fishmon.c44
-rw-r--r--x11-clocks/wmfishtime/pkg-descr14
3 files changed, 66 insertions, 20 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
index 4dfd1334b533..213b25352b2a 100644
--- a/x11-clocks/wmfishtime/Makefile
+++ b/x11-clocks/wmfishtime/Makefile
@@ -3,26 +3,38 @@
PORTNAME= wmfishtime
PORTVERSION= 1.24
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
- http://atreides.freenix.no/~anders/
+ http://www.sourcefiles.org/Toys/Clocks/
MAINTAINER= ports@FreeBSD.org
COMMENT= Time/date applet for WindowMaker with fishes swimming around
-USE_GNOME= gtk12
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= pkgconfig
-BROKEN= does not fetch
-GTK_LIBS?= `${GTK_CONFIG} --libs`
-GTK_CFLAGS?= `${GTK_CONFIG} --cflags`
MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS} -Wall ${GTK_CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
GTK_LIBS="${GTK_LIBS}"
-PLIST_FILES= bin/wmfishtime man/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/wmfishtime man/man1/wmfishtime.1.gz
+
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= GTK1 GTK2
+OPTIONS_DEFAULT= GTK2
+
+GTK1_USE= gnome=gtk12
+GTK1_CPPFLAGS= $$(pkg-config --cflags gdk)
+GTK1_LDFLAGS= $$(pkg-config --libs gdk)
+GTK2_USE= gnome=gtk20
+GTK2_CPPFLAGS= $$(pkg-config --cflags gdk-x11-2.0 x11)
+GTK2_LDFLAGS= $$(pkg-config --libs gdk-x11-2.0 x11) -lm
+TOOLKIT_DESC= GTK Toolkit
post-patch:
- ${REINPLACE_CMD} -E -e "s@1\.23@1\.24@g" ${WRKSRC}/fishmon.c ${WRKSRC}/wmfishtime.1
+ ${REINPLACE_CMD} -E -e 's|1\.23|${PORTVERSION}|g' ${WRKSRC}/fishmon.c ${WRKSRC}/wmfishtime.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${STAGEDIR}${PREFIX}/bin
diff --git a/x11-clocks/wmfishtime/files/patch-fishmon.c b/x11-clocks/wmfishtime/files/patch-fishmon.c
index f19ae9839eb0..58a376364666 100644
--- a/x11-clocks/wmfishtime/files/patch-fishmon.c
+++ b/x11-clocks/wmfishtime/files/patch-fishmon.c
@@ -1,6 +1,39 @@
---- fishmon.c.orig Sun May 27 05:53:09 2001
-+++ fishmon.c Mon Jul 7 04:01:52 2003
-@@ -1018,26 +1018,28 @@
+--- fishmon.c.orig 2004-05-12 23:55:59 UTC
++++ fishmon.c
+@@ -152,6 +152,10 @@ static char month[12][4] = { "JAN", "FEB
+
+ int main(int argc, char **argv)
+ {
++#if (GTK_MAJOR_VERSION >= 2)
++ /* This is needed to proper dockapp work on >=GTK+=2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
++#endif
+ int ch;
+ GdkEvent *event;
+ #ifdef PRO
+@@ -648,6 +652,9 @@ static void make_new_fishmon_dockapp(voi
+
+ /* make a copy for the iconwin - parameters are the same */
+ memcpy(&attri, &attr, sizeof(GdkWindowAttr));
++#if (GTK_MAJOR_VERSION >= 2)
++ attri.window_type = GTK_WINDOW_CHILD;
++#endif
+
+ sizehints.flags = USSize;
+ sizehints.width = 64;
+@@ -679,7 +686,11 @@ static void make_new_fishmon_dockapp(voi
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
++#if (GTK_MAJOR_VERSION >= 2)
++ gdk_window_show(bm.iconwin);
++#else
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++#endif
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -1020,27 +1031,29 @@ static void parse_options(int argc, char
{
static int ch = 0;
static struct option long_opts[] = {
@@ -31,12 +64,13 @@
+ case 'v':
do_version();
exit(0);
-+ break;
+ break;
+ case 'c':
+ enable_check_mail = 1;
+ break;
+ case 'b':
+ broken_wm = 1;
- break;
++ break;
}
}
+ }
diff --git a/x11-clocks/wmfishtime/pkg-descr b/x11-clocks/wmfishtime/pkg-descr
index d5ad76aa0d89..383d6726e321 100644
--- a/x11-clocks/wmfishtime/pkg-descr
+++ b/x11-clocks/wmfishtime/pkg-descr
@@ -1,9 +1,9 @@
-This is a time/date applet for WindowMaker (and BlackBox, E, SawFish...). Top
-part has the clock face, bottom part has day of the week, followed by day,
-followed by month. Yellow hand counts seconds, green hand counts minutes, red
-hand counts hours. Few seconds after startup there are at least 32 bubbles
-floating up behind the clock face. There are 4 fishes randomly swimming back
-and forth. If you move your mouse inside the dockapp window, the fish will get
-scared and run away.
+WMFishTime is a time/date applet for WindowMaker (and BlackBox, E,
+SawFish...). Top part has the clock face, bottom part has day of the
+week, followed by day, followed by month. Yellow hand counts seconds,
+green hand counts minutes, red hand counts hours. Few seconds after
+startup there are at least 32 bubbles floating up behind the clock face.
+There are 4 fishes randomly swimming back and forth. If you move your
+mouse inside the dockapp window, the fish will get scared and run away.
WWW: http://www.ne.jp/asahi/linux/timecop/#wmfishtime