aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-28 10:42:26 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-28 10:42:26 +0000
commit938b25c033fd499563209d99b8d2008465d49907 (patch)
treeebe3040accd3d45f9e5fca8c65dd9ba2107aa117 /x11-clocks
parent5a53bc762b140d1d46e5a9e3a0305b66c4635633 (diff)
downloadports-938b25c033fd499563209d99b8d2008465d49907.tar.gz
ports-938b25c033fd499563209d99b8d2008465d49907.zip
Notes
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/glclock/Makefile42
-rw-r--r--x11-clocks/glclock/pkg-descr6
2 files changed, 14 insertions, 34 deletions
diff --git a/x11-clocks/glclock/Makefile b/x11-clocks/glclock/Makefile
index 02c8f4aa5f3a..426170926673 100644
--- a/x11-clocks/glclock/Makefile
+++ b/x11-clocks/glclock/Makefile
@@ -30,40 +30,20 @@ SCRIPTS= chromeclock chromeclock_L crystalclock crystalclock_L \
TEXTURES= light.ppm marble.ppm sky.ppm wood.ppm detail.pgm \
detail2.pgm detail_b.pgm filter.pgm
-PLIST_FILES=
-.for f in ${PROGRAMS}
-PLIST_FILES+= bin/${f}
-.endfor
-.for f in ${SCRIPTS}
-PLIST_FILES+= bin/${f}
-.endfor
-.for f in ${TEXTURES}
-PLIST_FILES+= lib/X11/glclock/${f}
-.endfor
-
+PLIST_FILES= ${PROGRAMS:S,^,bin/,} ${SCRIPTS:S,^,bin/,} \
+ ${TEXTURES:S,^,lib/X11/glclock/,}
PLIST_DIRS= lib/X11/glclock
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -fexpensive-optimizations \
- -fomit-frame-pointer -fforce-mem -fforce-addr
-.if (${ARCH} != "alpha")
-CFLAGS+= -ffast-math
-.endif
-.endif
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -fexpensive-optimizations \
+ -ffast-math -fomit-frame-pointer -fforce-mem -fforce-addr
do-install:
-.for f in ${PROGRAMS}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
-.endfor
-.for f in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
-.endfor
- @${MKDIR} ${PREFIX}/lib/X11/glclock
-.for f in ${TEXTURES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/X11/glclock
-.endfor
+ ${INSTALL_PROGRAM} ${PROGRAMS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${SCRIPTS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/glclock
+ ${INSTALL_DATA} ${TEXTURES:S,^,${WRKSRC}/,} \
+ ${STAGEDIR}${PREFIX}/lib/X11/glclock
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-clocks/glclock/pkg-descr b/x11-clocks/glclock/pkg-descr
index 5a51843b8779..023865fe88ad 100644
--- a/x11-clocks/glclock/pkg-descr
+++ b/x11-clocks/glclock/pkg-descr
@@ -1,3 +1,3 @@
-glclock is a OpenGL demo with benchmarking capability. For fun and
-performance testing, glclock will be of some use for those who have
-hardware-accelerated 3D cards (see people.FreeBSD.org/~3d) or very fast CPUs.
+glclock is a OpenGL demo with benchmarking capability. For fun and
+performance testing, glclock will be of some use for those who have
+hardware-accelerated 3D cards, or fast CPUs.