aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-hyperpen
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2014-12-19 23:03:54 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2014-12-19 23:03:54 +0000
commit91293a35052d0d42238eef4625ecab486df2c162 (patch)
treee484d37e2856dd43389bc284d3dd6136848e4c6c /x11-drivers/xf86-input-hyperpen
parent56208c9b577f4dee4750b2202e4bbddf253cb7e9 (diff)
downloadports-91293a35052d0d42238eef4625ecab486df2c162.tar.gz
ports-91293a35052d0d42238eef4625ecab486df2c162.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-input-hyperpen')
-rw-r--r--x11-drivers/xf86-input-hyperpen/Makefile15
-rw-r--r--x11-drivers/xf86-input-hyperpen/distinfo2
-rw-r--r--x11-drivers/xf86-input-hyperpen/files/extra-patch-src_xf86HyperPen.c75
-rw-r--r--x11-drivers/xf86-input-hyperpen/pkg-plist3
4 files changed, 2 insertions, 93 deletions
diff --git a/x11-drivers/xf86-input-hyperpen/Makefile b/x11-drivers/xf86-input-hyperpen/Makefile
index 3e329eca89db..0c268764050c 100644
--- a/x11-drivers/xf86-input-hyperpen/Makefile
+++ b/x11-drivers/xf86-input-hyperpen/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= xf86-input-hyperpen
-PORTVERSION= ${HYPERVER}
-PORTREVISION= ${HYPERREVISION}
+PORTVERSION= 1.4.1
+PORTREVISION= 3
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -10,15 +10,4 @@ COMMENT= X.Org hyperpen input driver
XORG_CAT= driver
-.include <bsd.port.options.mk>
-
-.if defined(WITH_NEW_XORG)
-HYPERVER= 1.4.1
-HYPERREVISION= 2
-.else
-HYPERVER= 1.3.0
-HYPERREVISION= 8
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_xf86HyperPen.c
-.endif
-
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-hyperpen/distinfo b/x11-drivers/xf86-input-hyperpen/distinfo
index 7ccfb9b6d336..37edd2b8b967 100644
--- a/x11-drivers/xf86-input-hyperpen/distinfo
+++ b/x11-drivers/xf86-input-hyperpen/distinfo
@@ -1,4 +1,2 @@
-SHA256 (xorg/driver/xf86-input-hyperpen-1.3.0.tar.bz2) = e7a13a7597fa32f05d595d05a66cf94c529ba8ce1d03249bb9da5be9512c4b7b
-SIZE (xorg/driver/xf86-input-hyperpen-1.3.0.tar.bz2) = 236593
SHA256 (xorg/driver/xf86-input-hyperpen-1.4.1.tar.bz2) = 31a816f032a2adf4be10909811831191a7528152347e1726b04810ff88436816
SIZE (xorg/driver/xf86-input-hyperpen-1.4.1.tar.bz2) = 266891
diff --git a/x11-drivers/xf86-input-hyperpen/files/extra-patch-src_xf86HyperPen.c b/x11-drivers/xf86-input-hyperpen/files/extra-patch-src_xf86HyperPen.c
deleted file mode 100644
index 70713074b041..000000000000
--- a/x11-drivers/xf86-input-hyperpen/files/extra-patch-src_xf86HyperPen.c
+++ /dev/null
@@ -1,75 +0,0 @@
---- src/xf86HyperPen.c.orig 2009-02-26 16:31:24.000000000 -0600
-+++ src/xf86HyperPen.c 2010-05-03 12:29:11.000000000 -0500
-@@ -719,6 +719,9 @@
- {
- LocalDevicePtr local = (LocalDevicePtr)pHyp->public.devicePrivate;
- HyperPenDevicePtr priv = (HyperPenDevicePtr)PRIVATE(pHyp);
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ Atom axis_labels[3] = { 0 };
-+#endif
-
- if (xf86HypOpen(local) != Success) {
- if (local->fd >= 0) {
-@@ -730,6 +733,9 @@
- /* Set the real values */
- InitValuatorAxisStruct(pHyp,
- 0,
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ axis_labels[0],
-+#endif
- 0, /* min val */
- priv->hypXSize, /* max val */
- LPI2CPM(priv->hypRes), /* resolution */
-@@ -737,6 +743,9 @@
- LPI2CPM(priv->hypRes)); /* max_res */
- InitValuatorAxisStruct(pHyp,
- 1,
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ axis_labels[1],
-+#endif
- 0, /* min val */
- priv->hypYSize, /* max val */
- LPI2CPM(priv->hypRes), /* resolution */
-@@ -744,6 +753,9 @@
- LPI2CPM(priv->hypRes)); /* max_res */
- InitValuatorAxisStruct(pHyp,
- 2,
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ axis_labels[2],
-+#endif
- 0, /* min val */
- 511, /* max val */
- 512, /* resolution */
-@@ -765,8 +777,10 @@
- int loop;
- LocalDevicePtr local = (LocalDevicePtr)pHyp->public.devicePrivate;
- HyperPenDevicePtr priv = (HyperPenDevicePtr)PRIVATE(pHyp);
--
--
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ Atom btn_labels[4] = { 0 };
-+ Atom axis_labels[3] = { 0 };
-+#endif
-
- switch (what) {
- case DEVICE_INIT:
-@@ -779,6 +793,9 @@
-
- if (InitButtonClassDeviceStruct(pHyp,
- nbbuttons,
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ btn_labels,
-+#endif
- map) == FALSE) {
- ErrorF("unable to allocate Button class device\n");
- return !Success;
-@@ -802,6 +819,9 @@
-
- if (InitValuatorClassDeviceStruct(pHyp,
- nbaxes,
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 7
-+ axis_labels,
-+#endif
- #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
- xf86GetMotionEvents,
- #endif
diff --git a/x11-drivers/xf86-input-hyperpen/pkg-plist b/x11-drivers/xf86-input-hyperpen/pkg-plist
index ac8638a0057b..7633c5494cbc 100644
--- a/x11-drivers/xf86-input-hyperpen/pkg-plist
+++ b/x11-drivers/xf86-input-hyperpen/pkg-plist
@@ -1,4 +1 @@
lib/xorg/modules/input/hyperpen_drv.so
-@dirrmtry lib/xorg/modules/input
-@dirrmtry lib/xorg/modules
-@dirrmtry lib/xorg