aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-keyboard
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-12-16 11:11:09 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-12-16 11:11:09 +0000
commit47be7a61c97731aa5fe34c56767ad5e10bb5c5d2 (patch)
tree2df88f8b6e2af92b78ac24eb382268b7c290efab /x11-drivers/xf86-input-keyboard
parent7b9110d87c22c27df1baa93f8cb4cf30e205efc7 (diff)
downloadports-47be7a61c97731aa5fe34c56767ad5e10bb5c5d2.tar.gz
ports-47be7a61c97731aa5fe34c56767ad5e10bb5c5d2.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-input-keyboard')
-rw-r--r--x11-drivers/xf86-input-keyboard/Makefile4
-rw-r--r--x11-drivers/xf86-input-keyboard/distinfo4
-rw-r--r--x11-drivers/xf86-input-keyboard/files/patch-src__bsd_kbd.c14
-rw-r--r--x11-drivers/xf86-input-keyboard/files/patch-src__kbd.c24
-rw-r--r--x11-drivers/xf86-input-keyboard/pkg-plist1
5 files changed, 42 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-keyboard/Makefile b/x11-drivers/xf86-input-keyboard/Makefile
index 607fb124ce97..841bd4cdbd5e 100644
--- a/x11-drivers/xf86-input-keyboard/Makefile
+++ b/x11-drivers/xf86-input-keyboard/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-keyboard
-PORTVERSION= 1.7.0
+PORTVERSION= 1.8.0
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -9,7 +9,5 @@ COMMENT= X.Org keyboard input driver
XORG_CAT= driver
USE_XORG= kbproto
-MAN4= kbd.4x
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-keyboard/distinfo b/x11-drivers/xf86-input-keyboard/distinfo
index 35dda24723c9..158af292e26b 100644
--- a/x11-drivers/xf86-input-keyboard/distinfo
+++ b/x11-drivers/xf86-input-keyboard/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-keyboard-1.7.0.tar.bz2) = 0cd5e2845149c7f0e19ec830c6914b7f3d154bff134ce84519e39f16ce65523c
-SIZE (xorg/driver/xf86-input-keyboard-1.7.0.tar.bz2) = 319043
+SHA256 (xorg/driver/xf86-input-keyboard-1.8.0.tar.bz2) = 41c51c4e0a87aad6a1c4973c68a8de23b61162d0223f4ab36c627c307830cb5b
+SIZE (xorg/driver/xf86-input-keyboard-1.8.0.tar.bz2) = 323838
diff --git a/x11-drivers/xf86-input-keyboard/files/patch-src__bsd_kbd.c b/x11-drivers/xf86-input-keyboard/files/patch-src__bsd_kbd.c
new file mode 100644
index 000000000000..2f62b8206b6b
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/files/patch-src__bsd_kbd.c
@@ -0,0 +1,14 @@
+Index: src/bsd_kbd.c
+@@ -205,6 +205,12 @@
+ #endif
+ }
+ }
++/*
++ * Switch keyboards which are not attached to console in RAW mode
++ */
++#if defined (SYSCONS_SUPPORT) || defined (PCVT_SUPPORT)
++ ioctl(pInfo->fd, KDSKBMODE, K_RAW);
++#endif
+ return Success;
+ }
+
diff --git a/x11-drivers/xf86-input-keyboard/files/patch-src__kbd.c b/x11-drivers/xf86-input-keyboard/files/patch-src__kbd.c
new file mode 100644
index 000000000000..e9b0397baea7
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/files/patch-src__kbd.c
@@ -0,0 +1,24 @@
+Index: src/kbd.c
+@@ -25,6 +25,7 @@
+
+ #include "xf86.h"
+ #include "atKeynames.h"
++#include "xf86Priv.h"
+ #include "xf86Privstr.h"
+
+ #include <X11/extensions/XI.h>
+@@ -392,6 +393,14 @@
+ RemoveEnabledDevice(pInfo->fd);
+ pKbd->KbdOff(pInfo, what);
+ device->public.on = FALSE;
++ /*
++ * Close device file for keyboards which are not attached
++ * to console, otherwise they can't be opened again after
++ * relogin when using session manager like xdm.
++ * X server will take care about console attached keyboards.
++ */
++ if (pInfo->fd != xf86Info.consoleFd)
++ close(pInfo->fd);
+ break;
+
+ default:
diff --git a/x11-drivers/xf86-input-keyboard/pkg-plist b/x11-drivers/xf86-input-keyboard/pkg-plist
index 7e9f47e9ffe1..a2281aefc6f9 100644
--- a/x11-drivers/xf86-input-keyboard/pkg-plist
+++ b/x11-drivers/xf86-input-keyboard/pkg-plist
@@ -1,5 +1,6 @@
lib/xorg/modules/input/kbd_drv.la
lib/xorg/modules/input/kbd_drv.so
+man/man4/kbd.4x.gz
@dirrmtry lib/xorg/modules/input
@dirrmtry lib/xorg/modules
@dirrmtry lib/xorg