aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-synaptics
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /x11-drivers/xf86-input-synaptics
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
downloadports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.tar.gz
ports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/Makefile46
-rw-r--r--x11-drivers/xf86-input-synaptics/distinfo6
-rw-r--r--x11-drivers/xf86-input-synaptics/files/extra-Makefile.in11
-rw-r--r--x11-drivers/xf86-input-synaptics/pkg-plist14
4 files changed, 54 insertions, 23 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Makefile b/x11-drivers/xf86-input-synaptics/Makefile
index 8a5e57cfb4c4..aec3f7dfc78f 100644
--- a/x11-drivers/xf86-input-synaptics/Makefile
+++ b/x11-drivers/xf86-input-synaptics/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: xf86-input-synaptics
-# Date Created: 25 Sep 2008
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= xf86-input-synaptics
-PORTVERSION= 1.5.0
+PORTVERSION= ${SYNAPTICS_VERSION}
+PORTREVISION= ${SYNAPTICS_REVISION}
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -14,25 +10,47 @@ COMMENT= X.Org synaptics input driver
CONFLICTS= synaptics-[0-9]*
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+OPTIONS_DEFINE= HAL
+OPTIONS_DEFAULT=HAL
+
+.include <bsd.port.options.mk>
-USES= pathfix
-USE_XORG= x11 xextproto videoproto
+USES= pathfix
+USE_XORG= x11
XORG_CAT= driver
+.if ${PORT_OPTIONS:MHAL}
+PLIST_SUB+= HAL=""
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.else
+PLIST_SUB+= HAL="@comment "
+.endif
+
MAN1= syndaemon.1 \
synclient.1
MAN4= synaptics.4x
-post-install:
- ${MKDIR} ${PREFIX}/share/hal/fdi/policy/10osvendor
- ${INSTALL_DATA} ${WRKSRC}/conf/11-x11-synaptics.fdi \
- ${PREFIX}/share/hal/fdi/policy/10osvendor/
-
.if defined(WITH_NEW_XORG)
+SYNAPTICS_VERSION= 1.7.1
+SYNAPTICS_REVISION= 0
PLIST_SUB+= NEW="" OLD="@comment "
.else
+SYNAPTICS_VERSION= 1.6.4
+SYNAPTICS_REVISION= 0
PLIST_SUB+= NEW="@comment " OLD=""
+EXTRA_PATCHES+= ${PATCHDIR}/extra-Makefile.in
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MHAL}
+ ${MKDIR} ${PREFIX}/share/hal/fdi/policy/10osvendor
+ ${INSTALL_DATA} ${WRKSRC}/conf/11-x11-synaptics.fdi \
+ ${PREFIX}/share/hal/fdi/policy/10osvendor/
+.if !defined(WITH_NEW_XORG)
+ ${MKDIR} ${PREFIX}/share/hal/fdi/policy/20thirdparty
+ ${INSTALL_DATA} ${WRKSRC}/conf/11-x11-synaptics.fdi \
+ ${PREFIX}/share/hal/fdi/policy/20thirdparty/
+.endif
.endif
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-synaptics/distinfo b/x11-drivers/xf86-input-synaptics/distinfo
index 21ece95f394e..bad1c22f40ed 100644
--- a/x11-drivers/xf86-input-synaptics/distinfo
+++ b/x11-drivers/xf86-input-synaptics/distinfo
@@ -1,2 +1,4 @@
-SHA256 (xorg/driver/xf86-input-synaptics-1.5.0.tar.bz2) = 95cc5399fc49c9a35b02c2272cd99b8438f4609b219278c66a79e74c916a1c4e
-SIZE (xorg/driver/xf86-input-synaptics-1.5.0.tar.bz2) = 431123
+SHA256 (xorg/driver/xf86-input-synaptics-1.6.4.tar.bz2) = fe15b1afc61b40800f74a0dcf976c15b299ca0680ae5e537baef543455a732ee
+SIZE (xorg/driver/xf86-input-synaptics-1.6.4.tar.bz2) = 447004
+SHA256 (xorg/driver/xf86-input-synaptics-1.7.1.tar.bz2) = db5825660e1fb23190697f609bf75d4450fe707344a14298e1c9b47039bbb58e
+SIZE (xorg/driver/xf86-input-synaptics-1.7.1.tar.bz2) = 441407
diff --git a/x11-drivers/xf86-input-synaptics/files/extra-Makefile.in b/x11-drivers/xf86-input-synaptics/files/extra-Makefile.in
new file mode 100644
index 000000000000..957f9fcdbc51
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/files/extra-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2013-04-04 14:47:16.881259598 +0200
++++ Makefile.in 2013-04-04 14:47:20.568244417 +0200
+@@ -321,7 +321,7 @@
+ --with-sdkdir='$${includedir}/xorg' \
+ --with-xorg-conf-dir='$${datadir}/X11/xorg.conf.d'
+
+-SUBDIRS = include src man tools conf test
++SUBDIRS = include src man tools test
+ MAINTAINERCLEANFILES = ChangeLog INSTALL
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = xorg-synaptics.pc
diff --git a/x11-drivers/xf86-input-synaptics/pkg-plist b/x11-drivers/xf86-input-synaptics/pkg-plist
index 4d1aec8680a1..3f9ad117dbf2 100644
--- a/x11-drivers/xf86-input-synaptics/pkg-plist
+++ b/x11-drivers/xf86-input-synaptics/pkg-plist
@@ -1,18 +1,18 @@
bin/synclient
bin/syndaemon
include/xorg/synaptics-properties.h
-include/xorg/synaptics.h
+%%OLD%%include/xorg/synaptics.h
lib/xorg/modules/input/synaptics_drv.la
lib/xorg/modules/input/synaptics_drv.so
libdata/pkgconfig/xorg-synaptics.pc
%%NEW%%share/X11/xorg.conf.d/50-synaptics.conf
-share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi
-%%OLD%%share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi
+%%HAL%%share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi
+%%HAL%%%%OLD%%share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi
@dirrmtry lib/xorg/modules/input
@dirrmtry lib/xorg/modules
@dirrmtry lib/xorg
@dirrmtry include/xorg
-@dirrmtry share/hal/fdi/policy/10osvendor
-@dirrmtry share/hal/fdi/policy
-@dirrmtry share/hal/fdi
-@dirrmtry share/hal
+%%HAL%%@dirrmtry share/hal/fdi/policy/10osvendor
+%%HAL%%@dirrmtry share/hal/fdi/policy
+%%HAL%%@dirrmtry share/hal/fdi
+%%HAL%%@dirrmtry share/hal