aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-21 17:03:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-21 17:03:32 +0000
commit29e347e19709b94e2a25b8f749afaa22b4613213 (patch)
tree7fb1ab5c9603709eeba2da5c25166d99dc1147d6 /x11-drivers/xf86-video-ati
parent551496002207129285b709a89863af8a414819a9 (diff)
downloadports-29e347e19709b94e2a25b8f749afaa22b4613213.tar.gz
ports-29e347e19709b94e2a25b8f749afaa22b4613213.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile1
-rw-r--r--x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 4d3b485278b3..5ac3cd07c8b3 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xf86-video-ati
PORTVERSION= 6.14.3
+PORTREVISION= 1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c b/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c
new file mode 100644
index 000000000000..84a992a3bfd9
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c
@@ -0,0 +1,17 @@
+--- src/radeon_accel.c.orig 2012-04-15 19:36:08.000000000 +0200
++++ src/radeon_accel.c 2012-04-15 19:36:15.000000000 +0200
+@@ -982,10 +982,9 @@
+
+ for (; nwords > 0; --nwords, ++d, ++s)
+ #ifdef __powerpc__
+- asm volatile("stwbrx %0,0,%1" : : "r" (*s), "r" (d));
++ asm volatile("sthbrx %0,0,%1" : : "r" (*s), "r" (d));
+ #else
+- *d = ((*s >> 24) & 0xff) | ((*s >> 8) & 0xff00)
+- | ((*s & 0xff00) << 8) | ((*s & 0xff) << 24);
++ *d = (*s >> 8) | (*s << 8);
+ #endif
+ return;
+ }
+
+