aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /x11-drivers/xf86-video-ati
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
downloadports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.tar.gz
ports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile10
-rw-r--r--x11-drivers/xf86-video-ati/distinfo4
-rw-r--r--x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c12
3 files changed, 9 insertions, 17 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 0f173cd9a0eb..369e3d2cf62a 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: xf86-video-ati
-# Date Created: 17 Feb 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= xf86-video-ati
-PORTVERSION= 6.14.3
-PORTREVISION= 1
+PORTVERSION= 6.14.6
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -15,7 +9,7 @@ COMMENT= X.Org ati display driver
USE_GL= gl
XORG_CAT= driver
-USE_XORG= xf86driproto xineramaproto videoproto xf86miscproto xextproto glproto
+USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
MAN4= ati.4x radeon.4x
CONFIGURE_ARGS+=--disable-kms
diff --git a/x11-drivers/xf86-video-ati/distinfo b/x11-drivers/xf86-video-ati/distinfo
index 8308036858f8..baa6ed57a8e1 100644
--- a/x11-drivers/xf86-video-ati/distinfo
+++ b/x11-drivers/xf86-video-ati/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-ati-6.14.3.tar.bz2) = 844a2649eff6a3e92aff3e1837ea864f1561b4822b3e5d5ccb27b3b7fb8137b4
-SIZE (xorg/driver/xf86-video-ati-6.14.3.tar.bz2) = 1113119
+SHA256 (xorg/driver/xf86-video-ati-6.14.6.tar.bz2) = aa5286b3e4f0187d7df14785c06dd800255d9405205dbf061da5d77df86bec36
+SIZE (xorg/driver/xf86-video-ati-6.14.6.tar.bz2) = 1139495
diff --git a/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c b/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c
index 84a992a3bfd9..73d311a98c82 100644
--- a/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c
+++ b/x11-drivers/xf86-video-ati/files/patch-src_radeon_accel.c
@@ -1,17 +1,15 @@
---- src/radeon_accel.c.orig 2012-04-15 19:36:08.000000000 +0200
-+++ src/radeon_accel.c 2012-04-15 19:36:15.000000000 +0200
-@@ -982,10 +982,9 @@
+--- src/radeon_accel.c.orig 2012-06-25 10:19:41.000000000 +0200
++++ src/radeon_accel.c 2012-07-30 02:11:51.000000000 +0200
+@@ -967,10 +967,9 @@
for (; nwords > 0; --nwords, ++d, ++s)
#ifdef __powerpc__
- asm volatile("stwbrx %0,0,%1" : : "r" (*s), "r" (d));
+ asm volatile("sthbrx %0,0,%1" : : "r" (*s), "r" (d));
#else
-- *d = ((*s >> 24) & 0xff) | ((*s >> 8) & 0xff00)
+- *d = ((*s >> 24) & 0xff) | ((*s >> 8) & 0xff00)
- | ((*s & 0xff00) << 8) | ((*s & 0xff) << 24);
+ *d = (*s >> 8) | (*s << 8);
#endif
return;
- }
-
-
+ }