aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-intel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-21 17:03:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-21 17:03:32 +0000
commit29e347e19709b94e2a25b8f749afaa22b4613213 (patch)
tree7fb1ab5c9603709eeba2da5c25166d99dc1147d6 /x11-drivers/xf86-video-intel/Makefile
parent551496002207129285b709a89863af8a414819a9 (diff)
downloadports-29e347e19709b94e2a25b8f749afaa22b4613213.tar.gz
ports-29e347e19709b94e2a25b8f749afaa22b4613213.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-intel/Makefile')
-rw-r--r--x11-drivers/xf86-video-intel/Makefile49
1 files changed, 44 insertions, 5 deletions
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index fbabd24c2808..8620b644eeeb 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -6,20 +6,59 @@
#
PORTNAME= xf86-video-intel
-PORTVERSION= 2.7.1
-PORTREVISION= 4
+PORTVERSION= ${INTEL_VERSION}
+PORTREVISION= ${INTEL_REVISION}
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
COMMENT= Driver for Intel integrated graphics chipsets
-CONFLICTS= xf86-video-i810-[0-9]*
-
ONLY_FOR_ARCHS= amd64 i386
USE_GL= gl
+USE_LDCONFIG= yes
XORG_CAT= driver
USE_XORG= xvmc xineramaproto xextproto x11 xf86driproto glproto
MAN4= intel.4x
-.include <bsd.port.mk>
+.if defined(WITH_NEW_XORG)
+INTEL_VERSION= 2.17.0
+INTEL_REVISION= 0
+MAKE_JOBS_UNSAFE=yes
+PLIST_SUB+= OLD="@comment "
+.else
+INTEL_VERSION= 2.7.1
+INTEL_REVISION= 4
+PLIST_SUB+= OLD=""
+
+EXTRA_PATCHES+= ${PATCHDIR}/extra-src_ch7017_ch7017.c \
+ ${PATCHDIR}/extra-src_i830_render.c \
+ ${PATCHDIR}/extra-src_ch7xxx_ch7xxx.c \
+ ${PATCHDIR}/extra-src_i830_video.c \
+ ${PATCHDIR}/extra-src_i810_driver.c \
+ ${PATCHDIR}/extra-src_i915_hwmc.c \
+ ${PATCHDIR}/extra-src_i810_hwmc.c \
+ ${PATCHDIR}/extra-src_i915_render.c \
+ ${PATCHDIR}/extra-src_i810_video.c \
+ ${PATCHDIR}/extra-src_i965_render.c \
+ ${PATCHDIR}/extra-src_i830_dri.c \
+ ${PATCHDIR}/extra-src_ivch_ivch.c \
+ ${PATCHDIR}/extra-src_i830_driver.c \
+ ${PATCHDIR}/extra-src_sil164_sil164.c \
+ ${PATCHDIR}/extra-src_i830_dvo.c \
+ ${PATCHDIR}/extra-src_tfp410_tfp410.c \
+ ${PATCHDIR}/extra-src_i830_i2c.c \
+ ${PATCHDIR}/extra-uxa_uxa-priv.h
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NEW_XORG)
+pre-configure:
+.if !exists(${LOCALBASE}/lib/libkms.so)
+ @${ECHO} "${PKGNAME}: Rebuild graphics/libdrm with the WITH_KMS option."
+ @${FALSE}
+.endif
+.endif
+
+.include <bsd.port.post.mk>