aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-intel/Makefile
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-03-06 02:12:22 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-03-06 02:12:22 +0000
commit91a846b45edeac73b9a1cb75f1a53144b5b3d626 (patch)
tree0f6109ae3af18b700a7ec3b55fd2d34a3f31ebaf /x11-drivers/xf86-video-intel/Makefile
parente19969c795b7341b4a062d09113ead0d614a576f (diff)
downloadports-91a846b45edeac73b9a1cb75f1a53144b5b3d626.tar.gz
ports-91a846b45edeac73b9a1cb75f1a53144b5b3d626.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-intel/Makefile')
-rw-r--r--x11-drivers/xf86-video-intel/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index 150b5f187ed9..218ee4e3c87b 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xf86-video-intel
-PORTVERSION= 2.99.917.20170103
+PORTVERSION= 2.99.917.20170228
CATEGORIES= x11-drivers
MASTER_SITES= http://cgit.freedesktop.org/xorg/${XORG_CAT}/${PORTNAME}/snapshot/
DISTNAME= ${PORTNAME}-${COMMIT_ID}
@@ -10,10 +10,13 @@ DISTNAME= ${PORTNAME}-${COMMIT_ID}
MAINTAINER= x11@FreeBSD.org
COMMENT= Driver for Intel integrated graphics chipsets
+LICENSE= MIT # various
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
libdrm.so:graphics/libdrm
-COMMIT_ID= 028c946df0855728b2a34d1d588701dc6c5ad4c1
+COMMIT_ID= 78d7a09b0343829c81257024b164b0b3764392ac
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Intel integrated GPU only exists in Intel x86 processors/chipsets
@@ -27,6 +30,17 @@ USE_XORG= pciaccess pixman x11 xcb xext xrender xv xvmc
USES+= cpe autoreconf
CPE_VENDOR= x
-CONFIGURE_ARGS+= --with-default-accel=uxa
+OPTIONS_SINGLE= ACCEL
+OPTIONS_SINGLE_ACCEL= SNA UXA
+OPTIONS_DEFAULT= UXA
+
+ACCEL_DESC= Default AccelMethod (if not specified in xorg.conf)
+SNA_DESC= SandyBridge's New Acceleration
+UXA_DESC= Unified Acceleration Architecture
+
+CONFIGURE_ARGS+= --disable-udev
+
+SNA_CONFIGURE_ON= --with-default-accel=sna
+UXA_CONFIGURE_ON= --with-default-accel=uxa
.include <bsd.port.mk>