aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-nouveau/Makefile
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-04-10 18:26:09 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-04-10 18:26:09 +0000
commitf2633f7724cb77c6dc0f8be97a494bfacd7b6ce2 (patch)
treeee33d5715d3b899d3104d012231865b429ed74f2 /x11-drivers/xf86-video-nouveau/Makefile
parent9067dde6a8400a79520220713b2d4e14be9dda50 (diff)
Notes
Diffstat (limited to 'x11-drivers/xf86-video-nouveau/Makefile')
-rw-r--r--x11-drivers/xf86-video-nouveau/Makefile38
1 files changed, 31 insertions, 7 deletions
diff --git a/x11-drivers/xf86-video-nouveau/Makefile b/x11-drivers/xf86-video-nouveau/Makefile
index f3590bed69d1..3295fc8ed61c 100644
--- a/x11-drivers/xf86-video-nouveau/Makefile
+++ b/x11-drivers/xf86-video-nouveau/Makefile
@@ -1,15 +1,15 @@
-# New ports collection makefile for: xf86-video-nouveau
-# Date Created: 29 Jan 2009
-# Whom: Anonymous <swell.k@gmail.com>
+# New ports collection makefile for: xf86-video-nouveau
+# Date Created: 29 Jan 2009
+# Whom: Anonymous <swell.k@gmail.com>
#
# $FreeBSD$
#
PORTNAME= xf86-video-nouveau
-PORTVERSION= 0.0.10.20090129
-PORTREVISION= 1
+PORTVERSION= 0.0.10.${SNAPDATE}
+DISTVERSIONSUFFIX=.${SNAPREV}
CATEGORIES= x11-drivers
-MASTER_SITES= ftp://ftp.lissyara.su/users/Guest/
+MASTER_SITES= ftp://ftp.lissyara.su/users/Guest/distfiles/
MAINTAINER= x11@FreeBSD.org
COMMENT= Free nouveau display driver for nvidia-based cards
@@ -18,6 +18,30 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto xf86driproto glproto
MAN4= nouveau.4x
-BROKEN= does not compile
+MAKE_JOBS_SAFE= yes
+
+SNAPDATE= 20090408
+SNAPREV= d8545e6
+
+post-configure:
+ ${REINPLACE_CMD} '/NV_DRIVER_DATE/s/".*"/"${SNAPDATE}.${SNAPREV}"/' ${WRKSRC}/config.h
+
+GIT_WORK= ${WRKDIR}/${PORTNAME}.git-clone
+GIT_REV= $$(echo $$(date -ur$$(git log --pretty=format:%ct -1 \
+ ) +%Y%m%d).$$(git log --pretty=format:%h -1))
+
+maint-gen-distfile:
+ git clone git://anongit.freedesktop.org/git/nouveau/xf86-video-nouveau \
+ ${GIT_WORK}
+
+ ( cd ${GIT_WORK}; \
+ git log --stat >ChangeLog; \
+ autoreconf -if; \
+ ${TAR} cjf ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME:S/${SNAPDATE}.${SNAPREV}$$//}${GIT_REV}.tar.bz2 \
+ --exclude '.git*' --exclude autogen.sh --exclude autom4te.cache \
+ -s "|${GIT_WORK}|${DISTNAME:S/${SNAPDATE}.${SNAPREV}$$//}${GIT_REV}|" \
+ ${GIT_WORK} )
+
+ ${RM} -rf ${GIT_WORK}
.include <bsd.port.mk>