aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-openchrome
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-01-23 00:33:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-01-23 00:33:12 +0000
commitaacd3948deef62d2bfba874b3f0c199c882afed7 (patch)
treee027584a219377ce6051ba61b87b4f19180418b7 /x11-drivers/xf86-video-openchrome
parent88139c25be4fcf30b9aa5728f2cbb949d5ae0ced (diff)
downloadports-aacd3948deef62d2bfba874b3f0c199c882afed7.tar.gz
ports-aacd3948deef62d2bfba874b3f0c199c882afed7.zip
Update to 0.5.0 which is compatible with newer xorg
PR: 216286 Submitted by: matthew@reztek.cz
Notes
Notes: svn path=/head/; revision=432178
Diffstat (limited to 'x11-drivers/xf86-video-openchrome')
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile17
-rw-r--r--x11-drivers/xf86-video-openchrome/distinfo5
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-configure4
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c11
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-src_via__id.c10
-rw-r--r--x11-drivers/xf86-video-openchrome/pkg-plist12
6 files changed, 24 insertions, 35 deletions
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
index b5b74e25197b..a4f0664feecb 100644
--- a/x11-drivers/xf86-video-openchrome/Makefile
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-openchrome
-PORTVERSION= 0.3.3
-PORTREVISION= 6
+PORTVERSION= 0.5.0
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -11,13 +10,23 @@ COMMENT= X.Org openChrome display driver
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libdrm.so:graphics/libdrm
+
USE_GL= gl
XORG_CAT= driver
-USE_XORG= xf86driproto xvmc glproto
+USE_XORG= x11 xext xv
MAKE_ARGS+= drivermandir=${LOCALBASE}/man/man4
-ONLY_FOR_ARCHS= amd64 i386 ia64
+.include <bsd.port.options.mk>
+
+# XvMC is only supported by this driver on x86
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+USE_XORG+= xvmc
+PLIST_SUB+= XVMC=""
+.else
+PLIST_SUB+= XVMC="@comment "
+.endif
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-openchrome/distinfo b/x11-drivers/xf86-video-openchrome/distinfo
index 59ce0a19a7b5..58404374a9b9 100644
--- a/x11-drivers/xf86-video-openchrome/distinfo
+++ b/x11-drivers/xf86-video-openchrome/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xorg/driver/xf86-video-openchrome-0.3.3.tar.bz2) = e49e2f1e5dac86408e5a74b87038cc4082d2c3fba4e0579823161991432412ed
-SIZE (xorg/driver/xf86-video-openchrome-0.3.3.tar.bz2) = 518705
+TIMESTAMP = 1480077395
+SHA256 (xorg/driver/xf86-video-openchrome-0.5.0.tar.bz2) = 49fdd613975a332a0a64720b382420354aecaf2fcbb4920efd094d5a0ac955bb
+SIZE (xorg/driver/xf86-video-openchrome-0.5.0.tar.bz2) = 542713
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-configure b/x11-drivers/xf86-video-openchrome/files/patch-configure
index d32348a547bb..d60306b3cd04 100644
--- a/x11-drivers/xf86-video-openchrome/files/patch-configure
+++ b/x11-drivers/xf86-video-openchrome/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2013-05-23 15:11:54 UTC
+--- configure.orig 2016-07-06 16:22:03 UTC
+++ configure
-@@ -12742,7 +12742,7 @@ $as_echo "#define X_HAVE_XAAGETROP 1" >>
+@@ -13388,7 +13388,7 @@ $as_echo "#define X_HAVE_XAAGETROP 1" >>
$as_echo "#define X_NEED_I2CSTART 1" >>confdefs.h
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c b/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c
deleted file mode 100644
index e7b63c200dc8..000000000000
--- a/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/via_driver.c.orig 2015-11-19 15:49:03.658837000 +0100
-+++ src/via_driver.c 2015-11-19 15:51:11.689034000 +0100
-@@ -806,7 +806,7 @@ via_xf86crtc_resize(ScrnInfoPtr scrn, in
- {
- xf86CrtcConfigPtr xf86_config = XF86_CRTC_CONFIG_PTR(scrn);
- struct buffer_object *old_front = NULL, *new_front = NULL;
-- int old_width, old_height, old_dwidth, format;
-+ int old_width = 0, old_height = 0, old_dwidth = 0, format;
- int cpp = (scrn->bitsPerPixel + 7) >> 3, i;
- ScreenPtr screen = scrn->pScreen;
- VIAPtr pVia = VIAPTR(scrn);
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-src_via__id.c b/x11-drivers/xf86-video-openchrome/files/patch-src_via__id.c
deleted file mode 100644
index 35ba5e3945a0..000000000000
--- a/x11-drivers/xf86-video-openchrome/files/patch-src_via__id.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/via_id.c.orig 2013-05-23 15:11:28 UTC
-+++ src/via_id.c
-@@ -231,6 +231,7 @@ static struct ViaCardIdStruct ViaCardId[
- {"VIA VT3343 (P4M890)", VIA_P4M890, 0x1106, 0x3343, VIA_DEVICE_CRT},
- {"MSI P4M890M-L/IL (MS-7255)", VIA_P4M890, 0x1462, 0x7255, VIA_DEVICE_CRT},
- {"Biostar P4M890-M7 TE", VIA_P4M890, 0x1565, 0x1207, VIA_DEVICE_CRT},
-+ {"Mitac 8624 (Joybook R41E)", VIA_P4M890, 0x1071, 0x8624, VIA_DEVICE_CRT | VIA_DEVICE_LCD},
- {"ASRock P4VM890", VIA_P4M890, 0x1849, 0x3343, VIA_DEVICE_CRT},
-
- /*** VX800 ***/
diff --git a/x11-drivers/xf86-video-openchrome/pkg-plist b/x11-drivers/xf86-video-openchrome/pkg-plist
index 4e137dcac478..0bf636889ff8 100644
--- a/x11-drivers/xf86-video-openchrome/pkg-plist
+++ b/x11-drivers/xf86-video-openchrome/pkg-plist
@@ -1,8 +1,8 @@
-lib/libchromeXvMC.so
-lib/libchromeXvMC.so.1
-lib/libchromeXvMC.so.1.0.0
-lib/libchromeXvMCPro.so
-lib/libchromeXvMCPro.so.1
-lib/libchromeXvMCPro.so.1.0.0
+%%XVMC%%lib/libchromeXvMC.so
+%%XVMC%%lib/libchromeXvMC.so.1
+%%XVMC%%lib/libchromeXvMC.so.1.0.0
+%%XVMC%%lib/libchromeXvMCPro.so
+%%XVMC%%lib/libchromeXvMCPro.so.1
+%%XVMC%%lib/libchromeXvMCPro.so.1.0.0
lib/xorg/modules/drivers/openchrome_drv.so
man/man4/openchrome.4x.gz