aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-scfb
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
commit3f87b5cb51a9164076426ff318d5d77c12b0ced3 (patch)
treef850017ca906c1f973d599485b77a7dceb60e2fc /x11-drivers/xf86-video-scfb
parentce75c0657853608ceeaeda9f2d28dc0d2c634129 (diff)
downloadports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.tar.gz
ports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-scfb')
-rw-r--r--x11-drivers/xf86-video-scfb/Makefile12
-rw-r--r--x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c11
2 files changed, 13 insertions, 10 deletions
diff --git a/x11-drivers/xf86-video-scfb/Makefile b/x11-drivers/xf86-video-scfb/Makefile
index 5ffdfcf262ee..a1d9499b5443 100644
--- a/x11-drivers/xf86-video-scfb/Makefile
+++ b/x11-drivers/xf86-video-scfb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xf86-video-scfb
PORTVERSION= 0.0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-drivers
MAINTAINER= ray@FreeBSD.org
@@ -12,14 +12,6 @@ COMMENT= X.Org syscons display driver
USE_GITHUB= yes
GH_ACCOUNT= rayddteam
-USES= libtool pkgconfig
-GNU_CONFIGURE= yes
-DIST_SUBDIR= xorg/driver
-USE_XORG= xorg-server xproto randrproto xi renderproto xextproto \
- inputproto kbproto fontsproto videoproto dri2proto \
- xf86driproto glproto xineramaproto resourceproto \
- scrnsaverproto presentproto
-CONFIGURE_ENV= DRIVER_MAN_SUFFIX=4x DRIVER_MAN_DIR='$$(mandir)/man4'
-INSTALL_TARGET= install-strip
+XORG_CAT= driver
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c b/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
index eee6e58dc527..193b053b64e5 100644
--- a/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
+++ b/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
@@ -58,6 +58,17 @@
#endif
return mapaddr;
}
+@@ -366,8 +367,8 @@ ScfbPreInit(ScrnInfoPtr pScrn, int flags
+ struct fbtype fb;
+ int default_depth, wstype;
+ const char *dev;
+- char *mod = NULL, *s;
+- const char *reqSym = NULL;
++ char *mod = NULL;
++ const char *reqSym = NULL, *s;
+ Gamma zeros = {0.0, 0.0, 0.0};
+ DisplayModePtr mode;
+
@@ -633,9 +634,9 @@ ScfbShadowInit(ScreenPtr pScreen)
}