aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xorg-drivers
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-09-13 19:45:08 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-09-13 19:45:08 +0000
commit62df320cc3d1faf415675ee470a2b6338548e00b (patch)
tree6eb76e71941e2aad2fb558ec0436f85cf000c6f5 /x11-drivers/xorg-drivers
parent87cca574fd7f379db0710c925eab655b62046077 (diff)
downloadports-62df320cc3d1faf415675ee470a2b6338548e00b.tar.gz
ports-62df320cc3d1faf415675ee470a2b6338548e00b.zip
Notes
Diffstat (limited to 'x11-drivers/xorg-drivers')
-rw-r--r--x11-drivers/xorg-drivers/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/x11-drivers/xorg-drivers/Makefile b/x11-drivers/xorg-drivers/Makefile
index 17418fe27406..6b6478b9f0d8 100644
--- a/x11-drivers/xorg-drivers/Makefile
+++ b/x11-drivers/xorg-drivers/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xorg-drivers
-PORTVERSION= 7.2
-PORTREVISION= 2
+PORTVERSION= 7.3
CATEGORIES= x11-drivers
MASTER_SITES= # none
DISTFILES= # none
@@ -29,8 +28,8 @@ VIDEO_ON= ati \
i810 \
nv \
vesa vga via
-VIDEO_OFF= apm ark \
- chips cirrus cyrix \
+VIDEO_OFF= apm ark \
+ chips cirrus cyrix \
dummy \
fbdev \
glint \
@@ -61,7 +60,17 @@ INPUT_OFF= acecad \
palmax penmount \
spaceorb summa \
tek4957 \
- void
+ vmmouse void
+
+QUIRKS= keyboard:kbd jamstudio:js_x
+
+.if defined(XORG_COMPLETE)
+. for type in input video
+${type:U}_ON:= ${${type:U}_ON} ${${type:U}_OFF}
+${type:U}_OFF= # nil
+. endfor
+.endif
+
.for default in on off
. for type in input video
@@ -81,8 +90,12 @@ IGNORE= You can't choose both i810 and intel drivers as they are conflicting
. for type in input video
. for i in ${${type:U}_${default:U}}
DEFAULT=${default}
-. if (${DEFAULT} == "on" && !defined(WITHOUT_${i:U})) || (${DEFAULT} == "off" && defined(WITH_${i:U}))
-RUN_DEPENDS+= ${${type:U}DIR}/${i:C/jamstudio/js_x/}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
+. if (${DEFAULT} == "on" && !defined(WITHOUT_${i:U})) || (${DEFAULT} == "off" && defined(WITH_${i:U}))
+. if ${QUIRKS:M${i}\:*:C/.*://} != ""
+RUN_DEPENDS+= ${${type:U}DIR}/${QUIRKS:M${i}\:*:C/.*://}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
+. else
+RUN_DEPENDS+= ${${type:U}DIR}/${i}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
+. endif
. endif
. endfor
. endfor