aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xorg-drivers
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-10-09 19:30:14 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-10-09 19:30:14 +0000
commit816f004f0b2a62c240ff5dfc1c768d53a330aa85 (patch)
treed96f76e07fa236d3700005613274e6050a4b0b0b /x11-drivers/xorg-drivers
parent451bceb7cc5e939fe5acadc7fae251b2655332c4 (diff)
downloadports-816f004f0b2a62c240ff5dfc1c768d53a330aa85.tar.gz
ports-816f004f0b2a62c240ff5dfc1c768d53a330aa85.zip
Notes
Diffstat (limited to 'x11-drivers/xorg-drivers')
-rw-r--r--x11-drivers/xorg-drivers/Makefile32
1 files changed, 23 insertions, 9 deletions
diff --git a/x11-drivers/xorg-drivers/Makefile b/x11-drivers/xorg-drivers/Makefile
index 6b6478b9f0d8..d33e242ffb5a 100644
--- a/x11-drivers/xorg-drivers/Makefile
+++ b/x11-drivers/xorg-drivers/Makefile
@@ -28,6 +28,11 @@ VIDEO_ON= ati \
i810 \
nv \
vesa vga via
+
+.if ${ARCH} == "sparc64"
+VIDEO_ON+= sunffb
+.endif
+
VIDEO_OFF= apm ark \
chips cirrus cyrix \
dummy \
@@ -36,16 +41,13 @@ VIDEO_OFF= apm ark \
i128 i740 imstt intel \
mga \
neomagic newport nsc \
+ openchrome \
rendition \
s3 s3virge savage siliconmotion sis \
tdfx tga trident tseng \
vmware voodoo
-.if ${ARCH} == "sparc64"
-VIDEO_ON+= sunffb
-.else
-VIDEO_OFF+= sunffb
-.endif
+VIDEO_EXCL= i810:intel via:openchrome
INPUT_ON= mouse \
keyboard
@@ -62,16 +64,20 @@ INPUT_OFF= acecad \
tek4957 \
vmmouse void
-QUIRKS= keyboard:kbd jamstudio:js_x
+QUIRKS= keyboard:kbd jamstudio:js_x openchrome:via
.if defined(XORG_COMPLETE)
. for type in input video
${type:U}_ON:= ${${type:U}_ON} ${${type:U}_OFF}
${type:U}_OFF= # nil
+. for i in ${${type:U}_EXCL}
+B= ${i:C/.*://}
+${type:U}_ON:= ${${type:U}_ON:C/${B}//}
+${type:U}_OFF:= ${${type:U}_OFF} ${B}
+. endfor
. endfor
.endif
-
.for default in on off
. for type in input video
. for i in ${${type:U}_${default:U}}
@@ -82,8 +88,16 @@ OPTIONS+= ${i:U} "Install ${i} ${type} driver" ${default}
.include <bsd.port.pre.mk>
-.if defined(WITH_INTEL) && !defined(WITHOUT_I810)
-IGNORE= You can't choose both i810 and intel drivers as they are conflicting
+.for i in ${VIDEO_EXCL}
+A= ${i:C/:.*//}
+B= ${i:C/.*://}
+. if defined(WITH_${B:U}) && !defined(WITHOUT_${A:U})
+DRV_CONFLICTS+= ${i}
+. endif
+.endfor
+
+.if defined(DRV_CONFLICTS)
+IGNORE= can't be installed because of conflicting drivers (${DRV_CONFLICTS})
.endif
.for default in on off