aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2018-01-16 17:47:09 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2018-01-16 17:47:09 +0000
commit2652ea585cd97a982b7c00376d13eb7580bfa52b (patch)
tree540447f0c2b34af6ab2bd3e96504e1ed5bc65604 /x11-drivers
parent07d4135a6d4f0a28050579fda837f4eedd04f578 (diff)
downloadports-2652ea585cd97a982b7c00376d13eb7580bfa52b.tar.gz
ports-2652ea585cd97a982b7c00376d13eb7580bfa52b.zip
This package contains the X.Org xf86-video-qxl driver.
WWW: https://www.x.org/ PR: 225103 Submitted by: olevole@olevole.ru
Notes
Notes: svn path=/head/; revision=459199
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-qxl/Makefile31
-rw-r--r--x11-drivers/xf86-video-qxl/distinfo3
-rw-r--r--x11-drivers/xf86-video-qxl/files/patch-qxl_option_helpers.h11
-rw-r--r--x11-drivers/xf86-video-qxl/files/patch-spiceqxl_audio.c14
-rw-r--r--x11-drivers/xf86-video-qxl/pkg-descr3
-rw-r--r--x11-drivers/xf86-video-qxl/pkg-plist5
7 files changed, 68 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index f6c82e42b860..ceb8ad499312 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -37,6 +37,7 @@
SUBDIR += xf86-video-neomagic
SUBDIR += xf86-video-nv
SUBDIR += xf86-video-openchrome
+ SUBDIR += xf86-video-qxl
SUBDIR += xf86-video-r128
SUBDIR += xf86-video-rendition
SUBDIR += xf86-video-s3
diff --git a/x11-drivers/xf86-video-qxl/Makefile b/x11-drivers/xf86-video-qxl/Makefile
new file mode 100644
index 000000000000..623617fbca30
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xf86-video-qxl
+DISTVERSION= 0.1.5
+CATEGORIES= x11-drivers
+
+MAINTAINER= olevole@olevole.ru
+COMMENT= X.Org X server -- QXL display driver
+
+LICENSE= MIT
+
+BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
+ ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+LIB_DEPENDS= libspice-server.so:devel/libspice-server
+
+USES= localbase:ldflags pkgconfig python:2.7 shebangfix
+
+USE_XORG= xf86dgaproto xfont
+XORG_CAT= driver
+
+CONFIGURE_ARGS+=--enable-xspice
+
+python_OLD_CMD= "/usr/bin/python"
+SHEBANG_FILES= scripts/Xspice
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/X11/xorg.conf.d
+ ${INSTALL_DATA} ${WRKSRC}/examples/spiceqxl.xorg.conf.example \
+ ${STAGEDIR}${PREFIX}/etc/X11/xorg.conf.d/spiceqxl.xorg.conf.example
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-qxl/distinfo b/x11-drivers/xf86-video-qxl/distinfo
new file mode 100644
index 000000000000..0a152f7d5154
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514372367
+SHA256 (xorg/driver/xf86-video-qxl-0.1.5.tar.bz2) = b18682e04503c6326f7bf7190f3ee50a3d4d69758a2a3cc9af102a6b3f114c92
+SIZE (xorg/driver/xf86-video-qxl-0.1.5.tar.bz2) = 508266
diff --git a/x11-drivers/xf86-video-qxl/files/patch-qxl_option_helpers.h b/x11-drivers/xf86-video-qxl/files/patch-qxl_option_helpers.h
new file mode 100644
index 000000000000..53660f962bff
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/files/patch-qxl_option_helpers.h
@@ -0,0 +1,11 @@
+--- src/qxl_option_helpers.h.bak 2017-09-12 12:00:11 UTC
++++ src/qxl_option_helpers.h
+@@ -1,6 +1,8 @@
+ #ifndef OPTION_HELPERS_H
+ #define OPTION_HELPERS_H
+
++#define linux
++
+ #include <xf86Crtc.h>
+ #include <xf86Opt.h>
+
diff --git a/x11-drivers/xf86-video-qxl/files/patch-spiceqxl_audio.c b/x11-drivers/xf86-video-qxl/files/patch-spiceqxl_audio.c
new file mode 100644
index 000000000000..9ba92890929e
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/files/patch-spiceqxl_audio.c
@@ -0,0 +1,14 @@
+--- src/spiceqxl_audio.c.bak 2017-09-12 12:00:11 UTC
++++ src/spiceqxl_audio.c
+@@ -410,7 +410,10 @@
+ strcat(fname, "/");
+ strcat(fname, e->name);
+
+- f->fd = open(fname, O_RDONLY | O_RSYNC | O_NONBLOCK);
++// f->fd = open(fname, O_RDONLY | O_RSYNC | O_NONBLOCK);
++ // POSIX specifies three different flavors for synchronous I/O: O_SYNC, O_DSYNC, and O_RSYNC.
++ // In BSD, these are all equivalent.
++ f->fd = open(fname, O_RDONLY | O_SYNC | O_NONBLOCK);
+ free(fname);
+ if (f->fd < 0) {
+ ErrorF("playback: open FIFO '%s' failed: %s\n", e->name, strerror(errno));
diff --git a/x11-drivers/xf86-video-qxl/pkg-descr b/x11-drivers/xf86-video-qxl/pkg-descr
new file mode 100644
index 000000000000..42e5e054f1d7
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the X.Org xf86-video-qxl driver.
+
+WWW: https://www.x.org/
diff --git a/x11-drivers/xf86-video-qxl/pkg-plist b/x11-drivers/xf86-video-qxl/pkg-plist
new file mode 100644
index 000000000000..d6b0686ca6b0
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/pkg-plist
@@ -0,0 +1,5 @@
+lib/xorg/modules/drivers/spiceqxl_drv.so
+lib/xorg/modules/drivers/qxl_drv.so
+bin/Xspice
+%%PORTDOCS%%%%DOCSDIR%%/spiceqxl.xorg.conf.example
+@sample etc/X11/xorg.conf.d/spiceqxl.xorg.conf.example etc/X11/xorg.conf.d/spiceqxl.xorg.conf