aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-03-28 19:14:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-03-28 19:14:53 +0000
commit282afb1d92dadb011f08c0d7fa4a867e2edc8720 (patch)
treec871558eca40695f6c64832cd66f2ea0ddd08a55 /x11-drivers
parent7d114e99566e7b2e118479ceae8dba098be87f37 (diff)
downloadports-282afb1d92dadb011f08c0d7fa4a867e2edc8720.tar.gz
ports-282afb1d92dadb011f08c0d7fa4a867e2edc8720.zip
New port: x11-drivers/xorgxrdp
xorgxrdp is a set of drivers that enables Xorg to use RDP session with xrdp. WWW: http://www.xrdp.org/ PR: 213219 Submitted by: Koichiro IWAO <meta+ports@vmeta.jp>
Notes
Notes: svn path=/head/; revision=437150
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xorgxrdp/Makefile45
-rw-r--r--x11-drivers/xorgxrdp/distinfo5
-rw-r--r--x11-drivers/xorgxrdp/pkg-descr3
-rw-r--r--x11-drivers/xorgxrdp/pkg-plist10
5 files changed, 64 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index e6975de9c529..f6c82e42b860 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -53,5 +53,6 @@
SUBDIR += xf86-video-vmware
SUBDIR += xf86-video-voodoo
SUBDIR += xorg-drivers
+ SUBDIR += xorgxrdp
.include <bsd.port.subdir.mk>
diff --git a/x11-drivers/xorgxrdp/Makefile b/x11-drivers/xorgxrdp/Makefile
new file mode 100644
index 000000000000..0e7e8bdcb5f7
--- /dev/null
+++ b/x11-drivers/xorgxrdp/Makefile
@@ -0,0 +1,45 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= xorgxrdp
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= x11-drivers
+DIST_SUBDIR= xrdp
+
+MAINTAINER= meta+ports@vmeta.jp
+COMMENT= X.Org driver enabling use through an RDP session with xrdp
+
+LICENSE= MIT
+
+BUILD_DEPENDS= nasm:devel/nasm
+
+USES= autoreconf libtool:build pkgconfig
+USE_XORG= dri2proto dri3proto glproto inputproto presentproto randrproto \
+ renderproto resourceproto scrnsaverproto xf86driproto xineramaproto \
+ xorg-server
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= neutrinolabs
+GH_PROJECT= xrdp:xrdp
+GH_TAGNAME= 7cc1dd2:xrdp
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+CFLAGS+= -I${LOCALBASE}/include
+LIBS+= -I${LOCALBASE}/lib
+CONFIGURE_ENV+= XRDP_CFLAGS=-I${WRKSRC_xrdp}/common
+
+OPTIONS_DEFINE= DEBUG
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ${PORT_OPTIONS:MDEBUG}
+ ${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's|#define LOG_LEVEL [0-9]*|#define LOG_LEVEL 20|'
+.endif
+
+pre-configure:
+ @cd ${WRKSRC} && ./bootstrap
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xorgxrdp/distinfo b/x11-drivers/xorgxrdp/distinfo
new file mode 100644
index 000000000000..8f65250b5dca
--- /dev/null
+++ b/x11-drivers/xorgxrdp/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1481518351
+SHA256 (xrdp/neutrinolabs-xorgxrdp-v0.2.0_GH0.tar.gz) = 2a1be0ec3ae7bc7c9700a4da129cb5c56e0f71c7bb7469c08f139589964da2f1
+SIZE (xrdp/neutrinolabs-xorgxrdp-v0.2.0_GH0.tar.gz) = 82328
+SHA256 (xrdp/neutrinolabs-xrdp-7cc1dd2_GH0.tar.gz) = 61b8eabbad2be684bf3750db385b1a1e4058bd30cb6d2489d73f9a7a741a44ec
+SIZE (xrdp/neutrinolabs-xrdp-7cc1dd2_GH0.tar.gz) = 1873040
diff --git a/x11-drivers/xorgxrdp/pkg-descr b/x11-drivers/xorgxrdp/pkg-descr
new file mode 100644
index 000000000000..45d255d3aefc
--- /dev/null
+++ b/x11-drivers/xorgxrdp/pkg-descr
@@ -0,0 +1,3 @@
+xorgxrdp is a set of drivers that enables Xorg to use RDP session with xrdp.
+
+WWW: http://www.xrdp.org/
diff --git a/x11-drivers/xorgxrdp/pkg-plist b/x11-drivers/xorgxrdp/pkg-plist
new file mode 100644
index 000000000000..8170631330d8
--- /dev/null
+++ b/x11-drivers/xorgxrdp/pkg-plist
@@ -0,0 +1,10 @@
+@dir /etc/X11/xrdp
+/etc/X11/xrdp/xorg.conf
+lib/xorg/modules/drivers/xrdpdev_drv.a
+lib/xorg/modules/drivers/xrdpdev_drv.so
+lib/xorg/modules/input/xrdpkeyb_drv.a
+lib/xorg/modules/input/xrdpkeyb_drv.so
+lib/xorg/modules/input/xrdpmouse_drv.a
+lib/xorg/modules/input/xrdpmouse_drv.so
+lib/xorg/modules/libxorgxrdp.a
+lib/xorg/modules/libxorgxrdp.so