aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2018-10-18 02:10:00 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2018-10-18 02:10:00 +0000
commit425938f86a2f6187cd5fed83e89be868faa781a6 (patch)
tree62f79ac758c241f63fcc5f836d630abd5af1d5d8 /x11-drivers
parent6829e6204bbd09571432b2dde80b90f438f2d647 (diff)
downloadports-425938f86a2f6187cd5fed83e89be868faa781a6.tar.gz
ports-425938f86a2f6187cd5fed83e89be868faa781a6.zip
resurrect old port: xf86-video-ati@479538 as xf86-video-ati-legacy
As there are some issues with the later xf86-video-ati revisions on old DRMs such as drm-legacy-kmod, resurrect the old version of the port as legacy. Add conflict with newer port. Note intended use in pkg-descr. Approved by: x11 (zeising)
Notes
Notes: svn path=/head/; revision=482322
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-ati-legacy/Makefile31
-rw-r--r--x11-drivers/xf86-video-ati-legacy/distinfo3
-rw-r--r--x11-drivers/xf86-video-ati-legacy/pkg-descr2
-rw-r--r--x11-drivers/xf86-video-ati-legacy/pkg-plist5
-rw-r--r--x11-drivers/xf86-video-ati/Makefile2
6 files changed, 44 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index ceb8ad499312..4db175c7b049 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -24,6 +24,7 @@
SUBDIR += xf86-video-ark
SUBDIR += xf86-video-ast
SUBDIR += xf86-video-ati
+ SUBDIR += xf86-video-ati-legacy
SUBDIR += xf86-video-chips
SUBDIR += xf86-video-cirrus
SUBDIR += xf86-video-dummy
diff --git a/x11-drivers/xf86-video-ati-legacy/Makefile b/x11-drivers/xf86-video-ati-legacy/Makefile
new file mode 100644
index 000000000000..fd55138e6b79
--- /dev/null
+++ b/x11-drivers/xf86-video-ati-legacy/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xf86-video-ati-legacy
+PORTVERSION= 7.9.0
+PORTREVISION= 3
+PORTEPOCH= 1
+CATEGORIES= x11-drivers
+DISTNAME= xf86-video-ati-${DISTVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org ati display driver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
+ libdrm_radeon.so:graphics/libdrm
+
+CONFLICTS_INSTALL= xf86-video-ati
+
+USE_GL= gl
+XORG_CAT= driver
+USE_XORG= pciaccess
+
+# No Radeon kernel driver on non-x86 and PC98.
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86
+
+CONFIGURE_ARGS+=--disable-udev
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-ati-legacy/distinfo b/x11-drivers/xf86-video-ati-legacy/distinfo
new file mode 100644
index 000000000000..3e957c655ee2
--- /dev/null
+++ b/x11-drivers/xf86-video-ati-legacy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489676661
+SHA256 (xorg/driver/xf86-video-ati-7.9.0.tar.bz2) = 3cad872e6330afb1707da11e4e959e6887ebe5bcd81854b4d2e496c52c059875
+SIZE (xorg/driver/xf86-video-ati-7.9.0.tar.bz2) = 848502
diff --git a/x11-drivers/xf86-video-ati-legacy/pkg-descr b/x11-drivers/xf86-video-ati-legacy/pkg-descr
new file mode 100644
index 000000000000..b77a63fc03d2
--- /dev/null
+++ b/x11-drivers/xf86-video-ati-legacy/pkg-descr
@@ -0,0 +1,2 @@
+This package contains the X.Org xf86-video-ati driver. It is an old version
+intended to be used with the drm-legacy-kmod.
diff --git a/x11-drivers/xf86-video-ati-legacy/pkg-plist b/x11-drivers/xf86-video-ati-legacy/pkg-plist
new file mode 100644
index 000000000000..d7aee07c05b0
--- /dev/null
+++ b/x11-drivers/xf86-video-ati-legacy/pkg-plist
@@ -0,0 +1,5 @@
+lib/xorg/modules/drivers/ati_drv.so
+lib/xorg/modules/drivers/radeon_drv.so
+man/man4/ati.4x.gz
+man/man4/radeon.4x.gz
+share/X11/xorg.conf.d/10-radeon.conf
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 0144d770a81d..7f74b203942a 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
libdrm_radeon.so:graphics/libdrm
+CONFLICTS_INSTALL= xf86-video-ati-legacy
+
USE_GL= gl
XORG_CAT= driver
USE_XORG= pciaccess