aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-10 18:57:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-10 18:57:18 +0000
commita7b7f3e2d89b96fcaf24ab3ec54e82f7669ee4cd (patch)
treebef57d9fe4c531acd40813eb7b6c66ce280391fa /x11-drivers
parent84b292852f5cbffd670d739a607921b241001a32 (diff)
downloadports-a7b7f3e2d89b96fcaf24ab3ec54e82f7669ee4cd.tar.gz
ports-a7b7f3e2d89b96fcaf24ab3ec54e82f7669ee4cd.zip
x11-drivers/xf86-input-wacom: update to 0.34.2
Notes
Notes: svn path=/head/; revision=435838
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile3
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo6
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c12
3 files changed, 15 insertions, 6 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index d7e3063a2c9c..14422254d9fe 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.34.0
-PORTREVISION= 1
+PORTVERSION= 0.34.2
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index 922b5635d6bf..8335b3e28eff 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480975206
-SHA256 (xorg/driver/xf86-input-wacom-0.34.0.tar.bz2) = f15d8e4f3bf3a5b2db0b3f9c9565361b084896c3cb54ac11b8de5e405f9cb045
-SIZE (xorg/driver/xf86-input-wacom-0.34.0.tar.bz2) = 598624
+TIMESTAMP = 1489012292
+SHA256 (xorg/driver/xf86-input-wacom-0.34.2.tar.bz2) = 2ad1b9db141104370aef4966aae419dde915caea316e1df2c6ac063545706b1c
+SIZE (xorg/driver/xf86-input-wacom-0.34.2.tar.bz2) = 632058
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c b/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
index 77db151e5ed9..3f2e4f13414f 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
@@ -1,4 +1,4 @@
---- src/xf86Wacom.c.orig 2015-10-23 17:26:33 UTC
+--- src/xf86Wacom.c.orig 2017-02-24 04:04:55 UTC
+++ src/xf86Wacom.c
@@ -667,6 +667,17 @@ void wcmReadPacket(InputInfoPtr pInfo)
@@ -18,3 +18,13 @@
/* for all other errors, hope that the hotplugging code will
* remove the device */
if (errno != EAGAIN && errno != EINTR)
+@@ -823,9 +834,7 @@ static void wcmUnlinkTouchAndPen(InputIn
+ static int wcmDevProc(DeviceIntPtr pWcm, int what)
+ {
+ InputInfoPtr pInfo = (InputInfoPtr)pWcm->public.devicePrivate;
+-#ifdef DEBUG
+ WacomDevicePtr priv = (WacomDevicePtr)pInfo->private;
+-#endif
+ Status rc = !Success;
+
+ DBG(2, priv, "BEGIN dev=%p priv=%p "