aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-05-29 19:32:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-05-29 19:32:08 +0000
commiteeabcd70248e684c12bf5ce627262c4dcfefc9fd (patch)
tree61e86a48fc419a6aba9b078c954a99e5afd93e3d /x11-drivers
parent55e4a46b72c21c39a558a31bc9f4fad6f8484a89 (diff)
downloadports-eeabcd70248e684c12bf5ce627262c4dcfefc9fd.tar.gz
ports-eeabcd70248e684c12bf5ce627262c4dcfefc9fd.zip
Notes
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile3
-rw-r--r--x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c14
2 files changed, 16 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 6bf515860539..017beb636ae6 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -14,7 +14,8 @@ USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG)
+.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG) || \
+ (${ARCH} != i386 && ${ARCH} != amd64)
ATI_VERSION= 6.14.6
ATI_REVISION= 3
CONFIGURE_ARGS+=--disable-kms
diff --git a/x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c b/x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c
new file mode 100644
index 000000000000..26e3d4a08f08
--- /dev/null
+++ b/x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c
@@ -0,0 +1,14 @@
+--- src/nv_driver.c.orig 2014-01-19 15:24:45.000000000 -0600
++++ src/nv_driver.c 2014-01-19 15:24:07.000000000 -0600
+@@ -1543,7 +1543,11 @@
+ xf86FreeInt10(pNv->pInt);
+ return FALSE;
+ }
++#ifdef __powerpc__ /* XXX probably MI */
++ vgaHWSetMmioFuncs(VGAHWPTR(pScrn), pNv->IOAddress, 0);
++#else
+ vgaHWSetStdFuncs(VGAHWPTR(pScrn));
++#endif
+
+ /* We use a programmable clock */
+ pScrn->progClock = TRUE;