aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-10-13 17:01:27 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-10-13 17:01:27 +0000
commitf67c6ccb3292c129872d5858ba0d809aa3ac6936 (patch)
treee6663595adf31f67151689492c06877202df9c6e /x11-drivers
parent57aecc2f3f7baae53f782650b9080d6bc9d83228 (diff)
downloadports-f67c6ccb3292c129872d5858ba0d809aa3ac6936.tar.gz
ports-f67c6ccb3292c129872d5858ba0d809aa3ac6936.zip
Notes
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile14
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo4
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c74
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.h10
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-test-wacom-tests.c19
-rw-r--r--x11-drivers/xf86-input-wacom/pkg-plist6
6 files changed, 116 insertions, 11 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index 3c2ff67b13fe..ea1294904110 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,14 +1,15 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.24.99.1
-PORTREVISION= 1
+PORTVERSION= 0.26.1
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
MAINTAINER= jbeich@vfemail.net
COMMENT= X.Org Wacom tablet driver
+LICENSE= GPLv2 # or any later version
+
BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
RUN_DEPENDS= webcamd>0:${PORTSDIR}/multimedia/webcamd
@@ -19,6 +20,14 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS= --without-systemd-unit-dir \
--without-udev-rules-dir \
--without-doxygen
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DEBUG TEST
+
+DEBUG_CONFIGURE_ENABLE=debug
+
+TEST_CONFIGURE_ENABLE=unit-tests
+TEST_ALL_TARGET=check
post-patch:
@${REINPLACE_CMD} -e 's/as_fn_error.*udev/${TRUE} &/' \
@@ -31,7 +40,6 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/xorg/modules/input/wacom_drv.so
${MKDIR} ${STAGEDIR}${PREFIX}/etc/X11/xorg.conf.d
${INSTALL_DATA} ${FILESDIR}/wacom.conf.sample \
${STAGEDIR}${PREFIX}/etc/X11/xorg.conf.d
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index 008040a4629d..cfb92c6747a5 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-wacom-0.24.99.1.tar.bz2) = 4b68b1570bd6ce085010980fa1842825e5d676cd2962ec6ad2d7d5bc52149983
-SIZE (xorg/driver/xf86-input-wacom-0.24.99.1.tar.bz2) = 586002
+SHA256 (xorg/driver/xf86-input-wacom-0.26.1.tar.bz2) = 08e261185eb85ea60aa237c73fdb65360cda985198d3c252972f8230c3d194e2
+SIZE (xorg/driver/xf86-input-wacom-0.26.1.tar.bz2) = 589576
diff --git a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
new file mode 100644
index 000000000000..38f72b713dc6
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
@@ -0,0 +1,74 @@
+--- test/fake-symbols.c~
++++ test/fake-symbols.c
+@@ -92,7 +92,11 @@ xf86NameCmp(const char *s1, const char *
+ }
+
+ _X_EXPORT char *
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 18
+ xf86CheckStrOption(OPTTYPE optlist, const char *name, CONST char *deflt)
++#else
++xf86CheckStrOption(OPTTYPE optlist, const char *name, char *deflt)
++#endif
+ {
+ return NULL;
+ }
+@@ -231,7 +235,7 @@ InitValuatorAxisStruct(DeviceIntPtr dev,
+ {
+ return TRUE;
+ }
+-#else
++#elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 12
+ _X_EXPORT void
+ InitValuatorAxisStruct(DeviceIntPtr dev, int axnum, Atom label,
+ int minval, int maxval, int resolution,
+@@ -239,6 +243,14 @@ InitValuatorAxisStruct(DeviceIntPtr dev,
+ {
+ return;
+ }
++#else
++_X_EXPORT void
++InitValuatorAxisStruct(DeviceIntPtr dev, int axnum, Atom label,
++ int minval, int maxval, int resolution,
++ int min_res, int max_res)
++{
++ return;
++}
+ #endif
+
+ _X_EXPORT void
+@@ -279,7 +291,7 @@ InitPtrFeedbackClassDeviceStruct(DeviceI
+ _X_EXPORT int
+ XIChangeDeviceProperty (DeviceIntPtr dev, Atom property, Atom type,
+ int format, int mode, unsigned long len,
+-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 16
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 16
+ const void *
+ #elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 12
+ const pointer
+@@ -506,6 +518,7 @@ xf86UnblockSIGIO (int wasset)
+
+ /* This is not the same as the X server one, but it'll do for the tests */
+ #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
++#define InputOption InputOption_custom
+ typedef struct _InputOption {
+ struct _InputOption *next;
+ char *key;
+@@ -537,6 +550,7 @@ input_option_free_list(InputOption **opt
+ *opts = tmp;
+ }
+ }
++#undef InputOption
+ #endif
+
+ #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 16
+@@ -558,9 +572,9 @@ _X_EXPORT void xf86PostTouchEvent(Device
+ uint32_t flags, const ValuatorMask *mask) {
+ return;
+ }
++#endif
+
+ _X_EXPORT void
+ xf86PrintChipsets(const char *drvname, const char *drvmsg, SymTabPtr chips)
+ {
+ }
+-#endif
diff --git a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.h b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.h
new file mode 100644
index 000000000000..d61107ef2384
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.h
@@ -0,0 +1,10 @@
+--- test/fake-symbols.h~
++++ test/fake-symbols.h
+@@ -2,7 +2,6 @@
+ #include <dix.h>
+ #include <os.h>
+ #include <exevents.h>
+-#include <Xprintf.h>
+ #include <xf86.h>
+ #include <xf86Xinput.h>
+ #include <xf86_OSproc.h>
diff --git a/x11-drivers/xf86-input-wacom/files/patch-test-wacom-tests.c b/x11-drivers/xf86-input-wacom/files/patch-test-wacom-tests.c
new file mode 100644
index 000000000000..07becd773898
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/patch-test-wacom-tests.c
@@ -0,0 +1,19 @@
+--- test/wacom-tests.c~
++++ test/wacom-tests.c
+@@ -184,7 +184,7 @@ test_normalize_pressure(void)
+
+ priv.common = &common;
+ priv.pInfo = &pInfo;
+- pInfo.name = strdupa("Wacom test device");
++ pInfo.name = strdup("Wacom test device");
+ common.wcmPressureRecalibration = 1;
+
+ priv.minPressure = 0;
+@@ -229,6 +229,7 @@ test_normalize_pressure(void)
+ /* we count up, so assume normalised pressure goes up too */
+ assert(prev_pressure == pressure);
+ }
++ free(pInfo.name);
+ }
+
+ /**
diff --git a/x11-drivers/xf86-input-wacom/pkg-plist b/x11-drivers/xf86-input-wacom/pkg-plist
index 2d527bea30f9..d906dcc5e464 100644
--- a/x11-drivers/xf86-input-wacom/pkg-plist
+++ b/x11-drivers/xf86-input-wacom/pkg-plist
@@ -11,9 +11,3 @@ lib/xorg/modules/input/wacom_drv.so
libdata/pkgconfig/xorg-wacom.pc
man/man1/xsetwacom.1.gz
man/man4/wacom.4x.gz
-@dirrmtry lib/xorg/modules/input
-@dirrmtry lib/xorg/modules
-@dirrmtry lib/xorg
-@dirrmtry include/xorg
-@dirrmtry etc/X11/xorg.conf.d
-@dirrmtry etc/X11