aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-06-21 21:27:04 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-06-21 21:27:04 +0000
commit0fd1f3e89999463e0f969bafb1ce885b85c715c7 (patch)
tree5557e5f5ec76d79b50f13401ccb546b4bc921cc9 /x11-drivers
parent633968a4638a8f8fa9c3722c8f6d257be116e08a (diff)
downloadports-0fd1f3e89999463e0f969bafb1ce885b85c715c7.tar.gz
ports-0fd1f3e89999463e0f969bafb1ce885b85c715c7.zip
x11-drivers/xf86-input-mouse: Update to 1.9.3
Regenerate patches to make them apply cleanly.
Notes
Notes: svn path=/head/; revision=473003
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile3
-rw-r--r--x11-drivers/xf86-input-mouse/distinfo6
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c49
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in4
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_mouse.c19
5 files changed, 42 insertions, 39 deletions
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index 697dae1b97c2..9899e5f598b4 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-mouse
-PORTVERSION= 1.9.2
-PORTREVISION= 1
+PORTVERSION= 1.9.3
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-mouse/distinfo b/x11-drivers/xf86-input-mouse/distinfo
index 06655a5e93da..47d0116199e8 100644
--- a/x11-drivers/xf86-input-mouse/distinfo
+++ b/x11-drivers/xf86-input-mouse/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479392438
-SHA256 (xorg/driver/xf86-input-mouse-1.9.2.tar.bz2) = f425d5b05c6ab412a27e0a1106bb83f9e2662b307210abbe48270892387f4b2f
-SIZE (xorg/driver/xf86-input-mouse-1.9.2.tar.bz2) = 377685
+TIMESTAMP = 1529521635
+SHA256 (xorg/driver/xf86-input-mouse-1.9.3.tar.bz2) = 93ecb350604d05be98b7d4e5db3b8155a44890069a7d8d6b800c0bea79c85cc5
+SIZE (xorg/driver/xf86-input-mouse-1.9.3.tar.bz2) = 382013
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
index 997661eeb160..8fa88a869549 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
@@ -1,4 +1,4 @@
---- src/bsd_mouse.c.orig 2015-04-20 01:07:33 UTC
+--- src/bsd_mouse.c.orig 2018-06-19 04:36:21 UTC
+++ src/bsd_mouse.c
@@ -26,6 +26,24 @@
* authorization from the copyright holder(s) and author(s).
@@ -59,7 +59,7 @@
#define HUP_GENERIC_DESKTOP 0x0001
#define HUP_BUTTON 0x0009
-@@ -75,11 +104,13 @@ static const char *FindDevice(InputInfoP
+@@ -75,11 +104,13 @@ static const char *FindDevice(InputInfoPtr, const char
#define DEFAULT_MOUSE_DEV "/dev/mouse"
#define DEFAULT_SYSMOUSE_DEV "/dev/sysmouse"
#define DEFAULT_PS2_DEV "/dev/psm0"
@@ -113,7 +113,7 @@
int i;
mousehw_t hw;
mousemode_t mode;
-@@ -188,7 +240,13 @@ SetupAuto(InputInfoPtr pInfo, int *proto
+@@ -188,7 +240,13 @@ SetupAuto(InputInfoPtr pInfo, int *protoPara)
if (pInfo->fd == -1)
return NULL;
@@ -127,7 +127,7 @@
i = 1;
ioctl(pInfo->fd, MOUSE_SETLEVEL, &i);
-@@ -207,9 +265,18 @@ SetupAuto(InputInfoPtr pInfo, int *proto
+@@ -207,9 +265,18 @@ SetupAuto(InputInfoPtr pInfo, int *protoPara)
protoPara[0] = mode.syncmask[0];
protoPara[1] = mode.syncmask[1];
}
@@ -148,7 +148,7 @@
}
}
}
-@@ -232,41 +299,41 @@ SetSysMouseRes(InputInfoPtr pInfo, const
+@@ -232,41 +299,41 @@ SetSysMouseRes(InputInfoPtr pInfo, const char *protoco
(protocol && xf86NameCmp(protocol, "SysMouse") == 0)) {
/*
* As the FreeBSD sysmouse driver defaults to protocol level 0
@@ -229,7 +229,7 @@
#endif
} else {
/*
-@@ -293,28 +360,32 @@ FindDevice(InputInfoPtr pInfo, const cha
+@@ -293,28 +360,32 @@ FindDevice(InputInfoPtr pInfo, const char *protocol, i
* the test for whether /dev/sysmouse is usable can be made.
*/
if (!strcmp(*pdev, DEFAULT_MOUSE_DEV)) {
@@ -275,7 +275,7 @@
break;
}
}
-@@ -486,30 +557,78 @@ wsconsPreInit(InputInfoPtr pInfo, const
+@@ -486,30 +557,78 @@ wsconsPreInit(InputInfoPtr pInfo, const char *protocol
#if defined(USBMOUSE_SUPPORT)
@@ -362,7 +362,7 @@
switch (what) {
case DEVICE_INIT:
-@@ -518,38 +637,96 @@ usbMouseProc(DeviceIntPtr pPointer, int
+@@ -518,40 +637,96 @@ usbMouseProc(DeviceIntPtr pPointer, int what)
for (nbuttons = 0; nbuttons < MSE_MAXBUTTONS; ++nbuttons)
map[nbuttons + 1] = nbuttons + 1;
@@ -382,7 +382,7 @@
+ ? AXIS_LABEL_PROP_ABS_Y : AXIS_LABEL_PROP_REL_Y);
+ axes_labels[2] = XIGetKnownProperty(AXIS_LABEL_PROP_ABS_PRESSURE);
+#endif
-+
+
+ InitButtonClassDeviceStruct(pPointer, min(pMse->buttons, MSE_MAXBUTTONS),
+#ifdef HAVE_LABELS
+ btn_labels,
@@ -401,7 +401,7 @@
+ (acol->xmin != acol->xmax || acol->ymin != acol->ymax) ?
+ Absolute : Relative);
+ InitPtrFeedbackClassDeviceStruct(pPointer, pMse->Ctrl);
-
++
/* X valuator */
- xf86InitValuatorAxisStruct(pPointer, 0, 0, -1, 1, 0, 1);
+ xf86InitValuatorAxisStruct(pPointer, 0,
@@ -458,8 +458,10 @@
- pInfo->fd = -1;
- } else {
- xf86FlushInput(pInfo->fd);
+-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 23
- if (!xf86InstallSIGIOHandler (pInfo->fd, usbSigioReadInput,
- pInfo))
+-#endif
- AddEnabledDevice(pInfo->fd);
- }
+ if (pUsbMse->opened++ == 0) {
@@ -482,7 +484,7 @@
}
pMse->lastButtons = 0;
pMse->lastMappedButtons = 0;
-@@ -560,7 +737,7 @@ usbMouseProc(DeviceIntPtr pPointer, int
+@@ -562,7 +737,7 @@ usbMouseProc(DeviceIntPtr pPointer, int what)
case DEVICE_OFF:
case DEVICE_CLOSE:
if (pInfo->fd != -1) {
@@ -491,7 +493,7 @@
if (pUsbMse->packetSize > 8 && pUsbMse->buffer) {
free(pUsbMse->buffer);
}
-@@ -571,6 +748,7 @@ usbMouseProc(DeviceIntPtr pPointer, int
+@@ -573,6 +748,7 @@ usbMouseProc(DeviceIntPtr pPointer, int what)
xf86CloseSerial(pInfo->fd);
pInfo->fd = -1;
}
@@ -499,7 +501,7 @@
pPointer->public.on = FALSE;
usleep(300000);
break;
-@@ -586,45 +764,154 @@ usbReadInput(InputInfoPtr pInfo)
+@@ -588,45 +764,154 @@ usbReadInput(InputInfoPtr pInfo)
{
MouseDevPtr pMse;
UsbMsePtr pUsbMse;
@@ -675,7 +677,7 @@
}
static void
-@@ -633,14 +920,17 @@ usbSigioReadInput (int fd, void *closure
+@@ -635,14 +920,17 @@ usbSigioReadInput (int fd, void *closure)
usbReadInput ((InputInfoPtr) closure);
}
@@ -696,21 +698,22 @@
pUsbMse = malloc(sizeof(UsbMseRec));
if (pUsbMse == NULL) {
-@@ -649,12 +939,7 @@ usbPreInit(InputInfoPtr pInfo, const cha
+@@ -651,13 +939,8 @@ usbPreInit(InputInfoPtr pInfo, const char *protocol, i
return FALSE;
}
- pMse->protocol = protocol;
- xf86Msg(X_CONFIG, "%s: Protocol: %s\n", pInfo->name, protocol);
--
++ bzero(pUsbMse, sizeof(UsbMseRec));
+
- /* Collect the options, and process the common options. */
- COLLECT_INPUT_OPTIONS(pInfo, NULL);
- xf86ProcessCommonOptions(pInfo, pInfo->options);
-+ bzero(pUsbMse, sizeof(UsbMseRec));
-
+-
/* Check if the device can be opened. */
pInfo->fd = xf86OpenSerial(pInfo->options);
-@@ -670,19 +955,134 @@ usbPreInit(InputInfoPtr pInfo, const cha
+ if (pInfo->fd == -1) {
+@@ -672,19 +955,134 @@ usbPreInit(InputInfoPtr pInfo, const char *protocol, i
}
/* Get USB informations */
reportDesc = hid_get_report_desc(pInfo->fd);
@@ -857,7 +860,7 @@
/* Allocate buffer */
if (pUsbMse->packetSize <= 8) {
pUsbMse->buffer = pMse->protoBuf;
-@@ -692,56 +1092,129 @@ usbPreInit(InputInfoPtr pInfo, const cha
+@@ -694,56 +1092,129 @@ usbPreInit(InputInfoPtr pInfo, const char *protocol, i
if (pUsbMse->buffer == NULL) {
xf86Msg(X_ERROR, "%s: cannot allocate buffer\n", pInfo->name);
free(pUsbMse);
@@ -909,7 +912,7 @@
pMse->mousePriv = pUsbMse;
+ return TRUE;
+}
-+
+
+/* This function is called when the protocol is "usb". */
+static Bool
+usbPreInit(InputInfoPtr pInfo, const char *protocol, int flags)
@@ -985,7 +988,7 @@
+ pMse->disableXY = TRUE;
+ pMse->hasZ = acol->hasZ;
+ pMse->hasW = acol->hasW;
-
++
/* Process common mouse options (like Emulate3Buttons, etc). */
pMse->CommonOptions(pInfo);
@@ -1024,7 +1027,7 @@
/* Setup the local procs. */
pInfo->device_control = usbMouseProc;
pInfo->read_input = usbReadInput;
-@@ -784,7 +1257,9 @@ OSMouseInit(int flags)
+@@ -786,7 +1257,9 @@ OSMouseInit(int flags)
p->CheckProtocol = CheckProtocol;
#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)) && defined(MOUSE_PROTO_SYSMOUSE)
p->SetupAuto = SetupAuto;
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in b/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
index 68ee4657fb9e..9a9716be07d7 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2016-11-22 04:55:36 UTC
+--- src/Makefile.in.orig 2018-06-21 20:18:48 UTC
+++ src/Makefile.in
-@@ -357,7 +357,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include $(
+@@ -357,7 +357,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include $(XORG_CFLAGS)
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
index 14e1f75ca959..1f834d0ce18a 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
@@ -1,4 +1,4 @@
---- src/mouse.c.orig 2016-09-06 03:53:31 UTC
+--- src/mouse.c.orig 2018-06-19 04:36:21 UTC
+++ src/mouse.c
@@ -304,13 +304,39 @@ MouseCommonOptions(InputInfoPtr pInfo)
@@ -59,15 +59,16 @@
pMse->flipXY = xf86SetBoolOption(pInfo->options, "FlipXY", FALSE);
if (xf86SetBoolOption(pInfo->options, "InvX", FALSE)) {
pMse->invX = -1;
-@@ -339,7 +369,7 @@ MouseCommonOptions(InputInfoPtr pInfo)
+@@ -339,8 +369,8 @@ MouseCommonOptions(InputInfoPtr pInfo)
} else
pMse->invY = 1;
pMse->angleOffset = xf86SetIntOption(pInfo->options, "AngleOffset", 0);
--
+ pMse->sensitivity = xf86SetRealOption(pInfo->options, "Sensitivity", 1.0);
+-
if (pMse->pDragLock)
free(pMse->pDragLock);
+ pMse->pDragLock = NULL;
@@ -449,14 +479,17 @@ MouseCommonOptions(InputInfoPtr pInfo)
free(s);
}
@@ -126,7 +127,7 @@
}
static void
-@@ -997,6 +1006,8 @@ MousePreInit(InputDriverPtr drv, InputIn
+@@ -996,6 +1005,8 @@ MousePreInit(InputDriverPtr drv, InputInfoPtr pInfo, i
/* Default Mapping: 1 2 3 8 9 10 11 ... */
for (i = 0; i < MSE_MAXBUTTONS; i++)
pMse->buttonMap[i] = 1 << (i > 2 && i < MSE_MAXBUTTONS-4 ? i+4 : i);
@@ -135,7 +136,7 @@
protocol = MousePickProtocol(pInfo, device, protocol, &protocolID);
-@@ -2198,7 +2209,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
+@@ -2197,7 +2208,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int buttons, int
if (pMse->emulateWheel) {
/* Emulate wheel button handling */
@@ -144,7 +145,7 @@
wheelButtonMask = 0;
else
wheelButtonMask = 1 << (pMse->wheelButton - 1);
-@@ -2288,6 +2299,9 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
+@@ -2287,6 +2298,9 @@ MouseDoPostEvent(InputInfoPtr pInfo, int buttons, int
}
}
}
@@ -154,7 +155,7 @@
}
/* Absorb the mouse movement while the wheel button is pressed. */
-@@ -2305,7 +2319,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
+@@ -2304,7 +2318,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int buttons, int
if (pMse->emulate3ButtonsSoft && pMse->emulate3Pending && (dx || dy))
buttonTimer(pInfo);
@@ -163,7 +164,7 @@
xf86PostMotionEvent(pInfo->dev, 0, 0, 2, dx, dy);
if (change) {
-@@ -2418,12 +2432,10 @@ MousePostEvent(InputInfoPtr pInfo, int t
+@@ -2417,12 +2431,10 @@ MousePostEvent(InputInfoPtr pInfo, int truebuttons,
int dx, int dy, int dz, int dw)
{
MouseDevPtr pMse;
@@ -176,7 +177,7 @@
if (pMse->protocolID == PROT_MMHIT)
b = reverseBits(hitachMap, truebuttons);
-@@ -2516,11 +2528,11 @@ MousePostEvent(InputInfoPtr pInfo, int t
+@@ -2515,11 +2527,11 @@ MousePostEvent(InputInfoPtr pInfo, int truebuttons,
/* Accumulate the scaled dx, dy in the private variables
fracdx,fracdy and return the integer number part */