aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-04-15 06:05:30 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-04-15 06:05:30 +0000
commit305cb2061f8700c0c6192e233bf3b5886f36f644 (patch)
tree8c3f37d58b0797750cde2779793b66e65eff62d2 /x11-drivers
parent2338086a8c52a6549f4a92f6a3ff19446b03dbc3 (diff)
downloadports-305cb2061f8700c0c6192e233bf3b5886f36f644.tar.gz
ports-305cb2061f8700c0c6192e233bf3b5886f36f644.zip
Notes
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-rdc/Makefile25
-rw-r--r--x11-drivers/xf86-video-rdc/distinfo3
-rw-r--r--x11-drivers/xf86-video-rdc/pkg-descr3
-rw-r--r--x11-drivers/xf86-video-rdc/pkg-plist4
5 files changed, 36 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index fa6e4302ea60..89bddf48d6da 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -41,6 +41,7 @@
SUBDIR += xf86-video-r128
SUBDIR += xf86-video-radeonhd
SUBDIR += xf86-video-radeonhd-devel
+ SUBDIR += xf86-video-rdc
SUBDIR += xf86-video-rendition
SUBDIR += xf86-video-s3
SUBDIR += xf86-video-s3virge
diff --git a/x11-drivers/xf86-video-rdc/Makefile b/x11-drivers/xf86-video-rdc/Makefile
new file mode 100644
index 000000000000..28c69df4a0d8
--- /dev/null
+++ b/x11-drivers/xf86-video-rdc/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xf86-video-rdc
+# Date created: 14 April 2010
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf86-video-rdc
+MASTER_SITES= http://www.SpringDaemons.com/stas/
+PORTVERSION= 0.5
+CATEGORIES= x11-drivers
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= X.Org RDC display driver
+
+#USE_GL= gl
+XORG_CAT= driver
+USE_XORG= xvmc xf86driproto xextproto x11 glproto
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/xorg/modules/drivers
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/rdc_drv.so \
+ ${PREFIX}/lib/xorg/modules/drivers/rdc_drv.so
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-rdc/distinfo b/x11-drivers/xf86-video-rdc/distinfo
new file mode 100644
index 000000000000..7f93949dcead
--- /dev/null
+++ b/x11-drivers/xf86-video-rdc/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorg/driver/xf86-video-rdc-0.5.tar.bz2) = 1a0a9dbdd54fb3ab3e81f35193b1c23c
+SHA256 (xorg/driver/xf86-video-rdc-0.5.tar.bz2) = 513d990a2ee69a6c85fc855e4b71b024fdd6b0b9bedbd8332fab6c94c0a22eef
+SIZE (xorg/driver/xf86-video-rdc-0.5.tar.bz2) = 279659
diff --git a/x11-drivers/xf86-video-rdc/pkg-descr b/x11-drivers/xf86-video-rdc/pkg-descr
new file mode 100644
index 000000000000..25f612342b80
--- /dev/null
+++ b/x11-drivers/xf86-video-rdc/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the X.Org driver for RDC Semiconductors video chip.
+
+WWW: http://www.rdc.com.tw/en/
diff --git a/x11-drivers/xf86-video-rdc/pkg-plist b/x11-drivers/xf86-video-rdc/pkg-plist
new file mode 100644
index 000000000000..5bb95aad78b9
--- /dev/null
+++ b/x11-drivers/xf86-video-rdc/pkg-plist
@@ -0,0 +1,4 @@
+lib/xorg/modules/drivers/rdc_drv.so
+@dirrmtry lib/xorg/modules/drivers
+@dirrmtry lib/xorg/modules
+@dirrmtry lib/xorg